Package Details: mingw-w64-poppler 0.66.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-poppler.git (read-only)
Package Base: mingw-w64-poppler
Description: PDF rendering library based on xpdf 3.0 (mingw-w64)
Upstream URL: https://poppler.freedesktop.org
Keywords: mingw mingw-w64 poppler poppler-glib poppler-qt5
Licenses: GPL
Submitter: Schala
Maintainer: pingplug
Last Packager: pingplug
Votes: 8
Popularity: 0.019033
First Submitted: 2013-11-12 23:53
Last Updated: 2018-06-30 02:28

Latest Comments

specialworld83 commented on 2018-06-11 14:39

Good evening, the qt5 poppler library no longer exists. If it is recompiled it works

Martchus commented on 2018-04-30 18:48

Thanks for re-adding the Qt 5 version. However, I think you'll need to add mingw-w64-qt5-base also to makedepends.

Martchus commented on 2018-04-22 21:35

The Qt 5 version is missing as well. Why did you remove it?

Martchus commented on 2018-04-22 20:34

@pingplug Thanks for taking over maintenance. Just one thing, you've forgotten to replace mingw-w64-configure with mingw-w64-cmake when switching to CMake. And the makedependency python is missing like @J5lx already pointed out.

J5lx commented on 2018-01-05 14:27

You should add python to makedepends since it is needed to generate some files for the build process. Without it, the build fails like this:

Making all in glib
make[2]: Entering directory '/build/mingw-w64-poppler/src/poppler-0.57.0/i686/glib'
  GEN      stamp-poppler-enums.h
/usr/bin/env: ‘/usr/bin/python’: No such file or directory
make[2]: *** [Makefile:1241: stamp-poppler-enums.h] Error 127
make[2]: Leaving directory '/build/mingw-w64-poppler/src/poppler-0.57.0/i686/glib'
make[1]: *** [Makefile:654: all-recursive] Error 1
make[1]: Leaving directory '/build/mingw-w64-poppler/src/poppler-0.57.0/i686'
make: *** [Makefile:537: all] Error 2

Schala commented on 2017-08-03 23:08

it's fixed, just built it last night

yan12125 commented on 2016-06-06 05:41

mingw-w64-qt4 is currently broken on GCC 6. Could you comment out the qt4 dependency before qt4 is fixed?

ant32 commented on 2015-06-14 18:34

You can also download the binaries from here http://sf.net/p/mingw-w64-archlinux

ant32 commented on 2015-06-14 18:24

https://bugs.archlinux.org/task/45239 Simplest way to fix this would be to add the two lines to the header.

https://aur.archlinux.org/packages/mingw-w64-poppler/ is an updated version of poppler but still has the same compile issue if the file isn't fixed.

I have an issue thying to upload the updated sources
fatal: unable to access 'https://aur4.archlinux.org/mingw-w64-poppler.git/': The requested URL returned error: 403

Will look into it once I have time.

lantw44 commented on 2015-06-14 12:07

CXX libpoppler_la-GlobalParams.lo
In file included from ../../poppler/GlobalParams.cc:59:0:
/usr/i686-w64-mingw32/include/shlobj.h:37:3: error: 'EXTERN_C' does not name a type
SHFOLDERAPI SHGetFolderPathW (HWND hwnd, int csidl, HANDLE hToken, DWORD dwFlags, LPWSTR pszPath);
^
Makefile:1239: recipe for target 'libpoppler_la-GlobalParams.lo' failed

All comments