Package Details: mingw-w64-python2 2.7.9-1

Git Clone URL: (read-only)
Package Base: mingw-w64-python2
Description: A high-level scripting language (mingw-w64)
Upstream URL:
Licenses: PSF
Submitter: xantares
Maintainer: None
Last Packager: Dr-Shadow
Votes: 4
Popularity: 0.000000
First Submitted: 2013-10-17 08:42
Last Updated: 2015-07-01 07:53

Latest Comments

xantares commented on 2014-12-04 16:01

you can now take advantage of the mingw-configure script to simplify PKGBUILD and set the right compilation flags:
- set makedepends=mingw-w64-configure instead of mingw-w64-gcc|pkg-config
- use ${_arch}-configure instead of
../configure \
--prefix=/usr/${_arch} \
--host=${_arch} \
--build=$CHOST \
--enable-shared \

mingwandroid commented on 2014-10-26 14:28

Hi Dr-Shadow,

Is there any chance you can email me at mingw dot android at gmail dot com to discuss future directions for this, in regard to:


xantares commented on 2014-10-19 08:25

orphaned, take care of it!

Dr-Shadow commented on 2014-10-18 19:34

Same here, I could build mingw-w64-python2 ver2.7.8 with patches from there :

(I only replaced patches + pkgver/rel in PKGBUILD)

mingwandroid commented on 2014-01-23 18:18

We should add tcl/tk for tkinter (and idle). It's currently failing to find the libs / headers even if I add them as a dependency.

xantares commented on 2014-01-23 17:05

It's okay now!

xantares commented on 2014-01-23 10:28

The current state is: builds but interpreter crashes for i686, works for x86_64.

xantares commented on 2014-01-22 10:15


xantares commented on 2013-11-08 21:53

I think python2.exe should be called instead, I've not heard from the mingwandroid guy, let's be patient.


ant32 commented on 2013-11-08 21:43

As far as I can find out python2 is required to build this package. Could you either confirm that it builds without it installed or add it to the makedepends?

All comments