Package Details: mingw-w64-qt5-base-angle 5.13.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base-angle.git (read-only)
Package Base: mingw-w64-qt5-base-angle
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Conflicts: mingw-w64-qt5-base, mingw-w64-qt5-base-angle, mingw-w64-qt5-base-dynamic, mingw-w64-qt5-base-noopengl, mingw-w64-qt5-base-openql
Provides: mingw-w64-qt5-base
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 15
Popularity: 0.000000
First Submitted: 2016-08-19 20:15
Last Updated: 2019-06-26 12:44

Required by (45)

Sources (34)

Pinned Comments

Martchus commented on 2016-05-18 22:01

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.7.0-mingw-w64

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

For general notes, discussion and issues not only concerning this variant please use the comment section of the package mingw-w64-qt5-base.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Martchus commented on 2016-05-12 11:54

I'll look into it later. I haven't rebuilt this with mingw-w64-gcc 6.1 anyways.

Salamandar commented on 2016-05-12 11:50

I cannot build the package…
Building the x86_64 version worked but :
/home/salamandar/tmp/MingW-w64/aur-mingw-w64-qt5-base/PKGBUILD: ligne 273 : popd: pile de répertoire vide

I changed the popd to
cd "${srcdir}/${_pkgfqn}"
It stopped when starting the i686 build :
You cannot make a shadow build from a source tree containing a previous build.
Cannot proceed.

Martchus commented on 2016-03-28 21:23

Do not update to 5.6.0 if you want to link against Qt in a CMake project. I just found out that this is currently broken. I think I fixed it but I need to test before pushing the changes.
EDIT: The issue should be resolved now.

FoPref commented on 2016-03-28 17:15

Thank you very much for your work on this.
I tried mingw-w64-qt5-base-opengl 5.6 from your repository and it works great!

Martchus commented on 2016-03-27 21:03

xantares: No reason to say sorry - I've already updated all mingw-w64-qt5-* packages on my GitHub repo (https://github.com/Martchus/PKGBUILDs).

However, building the WebKit module didn't work when I tried it last time. I did a few adjustments and it might work now, but I still need to test before committing the changes. I still need to test whether the other modules actually work, too.

These packages where originally based on the Fedora packages. Because Fedora devs haven't updated yet and use a very old version of ANGLE I needed to do some adjustments on my own. I hope I didn't break anything.

There are also some new packages available: mingw-w64-qt5-{canvas3d,connectivity,quickcontrols2}

The package mingw-w64-qt5-quick1 is no longer available in Qt 5.6.0 so it won't be updated.

xantares commented on 2016-03-09 08:35

thanks a bunch!

Martchus commented on 2016-03-08 23:38

Fixed it. At least for me it works now. (I haven't tested whether it actually runs, but it compiles without errors.) For changes see the commit message. Rebuild mingw-w64-angleproject first because it needed to be fixed as well.

Martchus commented on 2016-03-07 18:26

When comparing the mentioned header files I've noticed that the new version only adds the relevant definitions if GL_GLEXT_PROTOTYPES is defined. So defining GL_GLEXT_PROTOTYPES should fix this issue.

I'm currently trying to rebuild. If I am correct I'll updated the PKGBUILD. It might be a good idea to check the other Qt modules (especially Qt Webkit), too.

Martchus commented on 2016-03-07 18:00

nickoe: This build script does not use the dynamic switch. (I already thought about using it, but for now the priority is to make the current version work first.)

I'm trying to figure out what's going on later. I guess it has something to do with the updated ANGLE.

nickoe commented on 2016-03-07 17:51

I see the same error. Maybe related to:
https://bugreports.qt.io/browse/QTBUG-43993
https://bugreports.qt.io/browse/QTBUG-45451