Package Details: mingw-w64-qt5-base-angle 5.13.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base-angle.git (read-only)
Package Base: mingw-w64-qt5-base-angle
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Conflicts: mingw-w64-qt5-base, mingw-w64-qt5-base-angle, mingw-w64-qt5-base-dynamic, mingw-w64-qt5-base-noopengl, mingw-w64-qt5-base-openql
Provides: mingw-w64-qt5-base
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 15
Popularity: 0.000000
First Submitted: 2016-08-19 20:15
Last Updated: 2019-06-26 12:44

Required by (45)

Sources (34)

Pinned Comments

Martchus commented on 2016-05-18 22:01

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.7.0-mingw-w64

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

For general notes, discussion and issues not only concerning this variant please use the comment section of the package mingw-w64-qt5-base.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

hanckmann commented on 2015-02-15 18:31

Via this package I have installed mingw-w64-gettext (among the rest), but I still get this error:

*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html

==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build mingw-w64-glib2.

Any idea how to fix this?

ant32 commented on 2015-02-09 20:32

Finally fixed opengl. Yeh!! :)

yan12125 commented on 2015-02-06 06:55

Unable to build. Seems mingw-w64-libmariadbclient is renamed to mingw-w64-mariadb-connector-c.

ant32 commented on 2014-12-29 19:57

My main reason for not doing that was that the building takes long so I didn't want to force everybody to build parts of Qt that they didn't need. Also this package is largely a copy of fedora's Qt and they do it separately. Building everything together would solve some problems with qt5bootstrap but for instance I wasn't able to build qtwebkit yet so everything would now have stayed behind until I (or somebody else) had that fixed.

Anonymous comment on 2014-12-27 07:35

Just a question, but considering how most of the native linux qt5 packages are built from a single source tarball and PKGBUILD, should one not do the same for mingw-w64-qt5 packages?

ant32 commented on 2014-12-18 17:42

Thanks for posting. I don't have time to fix this right now.

Some other packages to build I have to create workarounds with libQt5Bootstrap which I think is not a Qt bug but something that needs to be fixed on how we do things in Archlinux. What the problem there is (as far as I know ), is that we store both native and mingw libs in /usr/{i686,x86_64}-w64-mingw32/lib which causes messed up linking when building native mingw tools. We can't place them in /usr/lib in qt's case since it already contains the native qt libs. Fedora stores them in different directories but I don't really like their folder structure. This needs to be discussed in the forums.

I do belive though that this is a bug in Qt and needs to be reported there if someone wants to get this fixed for future releases. Any help is always welcome. If you have trouble building consider downloading compiled packages from my mingw repo http://sourceforge.net/projects/mingw-w64-archlinux/

Hopefully this has nothing to do with this patch "qt5-dont-build-host-libs-static.patch" I'm not sure if I should be applying this patch from Fedora, feedback would be appreciated.

yan12125 commented on 2014-12-14 10:04

When upgrading from 5.3.2-1, I encounter the following compilation error:
/tmp/yaourt-tmp-yan/aur-mingw-w64-qt5-base/src/build-i686-w64-mingw32/bin/moc: symbol lookup error: /tmp/yaourt-tmp-yan/aur-mingw-w64-qt5-base/src/build-i686-w64-mingw32/bin/moc: undefined symbol: _ZN18QCommandLineOptionC1ERK7QString
Seems moc 5.4.0 uses libQt5Bootstrap.so.5 of 5.3.2, where ABI is not compatible. `pacman -R mingw-w64-qt5-base` before upgrading solves this issue.

ant32 commented on 2014-12-11 16:01

This needs to be arch=(i686 x86_64) since it produces native tools that are architecture specific.

Also please wait to flag this till https://www.archlinux.org/packages/?sort=&q=qt5-base is updated. Notifying me about it in advance though is kind of nice so I can start working on it :)

xantares commented on 2014-11-13 17:29

hi, shouldnt it be: arch=(any) ? same for the -static package.

Schala commented on 2014-08-20 01:52

Hmm... guess I'll orphan since Qt5 is a beast to configure and build, and you seem better equipped.