Package Details: mingw-w64-qt5-base-angle 5.13.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base-angle.git (read-only)
Package Base: mingw-w64-qt5-base-angle
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Conflicts: mingw-w64-qt5-base, mingw-w64-qt5-base-angle, mingw-w64-qt5-base-dynamic, mingw-w64-qt5-base-noopengl, mingw-w64-qt5-base-openql
Provides: mingw-w64-qt5-base
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 15
Popularity: 0.000000
First Submitted: 2016-08-19 20:15
Last Updated: 2019-06-26 12:44

Required by (45)

Sources (34)

Pinned Comments

Martchus commented on 2016-05-18 22:01

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.7.0-mingw-w64

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

For general notes, discussion and issues not only concerning this variant please use the comment section of the package mingw-w64-qt5-base.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 Next › Last »

Auguste commented on 2014-07-25 11:35

i have problem linking against mingw-w64-libmariadbclient 10.0.12-1. is this a known issue?

Schala commented on 2014-07-24 23:57

next version cause it's a big build

Svenstaro commented on 2014-07-20 05:58

Change dep of sqlit3 to sqlite.

xantares commented on 2014-07-07 17:25

orphaned

ant32 commented on 2014-07-07 15:05

http://pkgs.fedoraproject.org/cgit/mingw-qt5-qtbase.git/
http://pkgs.fedoraproject.org/cgit/?s=idle&q=mingw-

XanClic commented on 2014-06-25 22:20

Yes, the last time I tried -opengl, I hit that error, too (I only now remembered).

Generally, I could cope with 5.2.1, but I really don't like to use an orphaned package (it's easy to see why, as it currently doesn't build), that's why I refrained from using -opengl (that, and when I looked into its PKGBUILD, there were the same ANGLE patches, so I just assumed it'd be no different; I missed the "-opengl desktop").

ant32 commented on 2014-06-25 21:22

Trying to build opengl qt I got an error.

x86_64-w64-mingw32-g++ -c -include .pch/release/qt_gui_pch.h -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -std=c++0x -fno-exceptions -frtti -Wall -Wextra -DUNICODE -DQT_NO_MTDEV -DQT_NO_LIBUDEV -DQT_NO_EVDEV -DQT_NO_USING_NAMESPACE -DQT_BUILD_GUI_LIB -DQT_BUILDING_QT -D_CRT_SECURE_NO_WARNINGS -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x040800 -D_USE_MATH_DEFINES -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/src/gui -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtGui' -I'../../include' -I'../../include/QtGui' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtGui/5.3.0' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtGui/5.3.0/QtGui' -I'tmp' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/src/gui/image' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtCore/5.3.0' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtCore/5.3.0/QtCore' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/include/QtCore' -I'../../include/QtCore' -I'.moc/release' -I'.' -I'/build/mingw-w64-qt5-base-opengl/src/qtbase-opensource-src-5.3.0/mkspecs/win32-g++' -o .obj/release/moc_qpalette.o .moc/release/moc_qpalette.cpp
/usr/lib/gcc/x86_64-w64-mingw32/4.9.0/../../../../x86_64-w64-mingw32/bin/as: .obj/release/qopenglversionfunctionsfactory.o: too many sections (47663)
{standard input}: Assembler messages:
{standard input}: Fatal error: can't write .obj/release/qopenglversionfunctionsfactory.o: File too big
/usr/lib/gcc/x86_64-w64-mingw32/4.9.0/../../../../x86_64-w64-mingw32/bin/as: .obj/release/qopenglversionfunctionsfactory.o: too many sections (47663)
{standard input}: Fatal error: can't close .obj/release/qopenglversionfunctionsfactory.o: File too big
Makefile.Release:53905: recipe for target '.obj/release/qopenglversionfunctionsfactory.o' failed
make[3]: *** [.obj/release/qopenglversionfunctionsfactory.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/build/mingw-w64-qt5-base-opengl/src/build-x86_64-w64-mingw32/src/gui'
Makefile:34: recipe for target 'release' failed
make[2]: *** [release] Error 2
make[2]: Leaving directory '/build/mingw-w64-qt5-base-opengl/src/build-x86_64-w64-mingw32/src/gui'
Makefile:437: recipe for target 'sub-gui-make_first' failed
make[1]: *** [sub-gui-make_first] Error 2
make[1]: Leaving directory '/build/mingw-w64-qt5-base-opengl/src/build-x86_64-w64-mingw32/src'
Makefile:41: recipe for target 'sub-src-make_first' failed
make: *** [sub-src-make_first] Error 2

ant32 commented on 2014-06-25 20:39

This PKGBUILD was/is ready to be compiled as opengl. All you need to do is change the name in the PKGBUILD to mingw-w64-qt5-base-opengl. I'll try compile it and upload it to https://sourceforge.net/projects/mingw-w64-archlinux/files/x86_64/ . There still is 5.2.1 if you are happy with that.

XanClic commented on 2014-06-25 16:43

Hi,

Is there a specific reason why this package compiles Qt with ANGLE instead of normal desktop OpenGL? I really need OpenGL 3.3, so I'd love either this package to be compiled to use normal OpenGL or another version which does, if possible.

Thanks,
Max

Auguste commented on 2014-06-24 01:14

it compiles now.