Package Details: mingw-w64-qt5-base 5.13.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base.git (read-only)
Package Base: mingw-w64-qt5-base
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 19
Popularity: 0.653298
First Submitted: 2016-08-30 21:28
Last Updated: 2019-06-26 12:44

Sources (34)

Pinned Comments

Martchus commented on 2018-05-29 08:29

Before upgrading, be sure to remove the old version of the package from your system. Preferably, build the package in a clean chroot using makechrootpkg.

Also, please read the other comments and issues on GitHub for known bugs and limitations.

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

Martchus commented on 2018-03-11 20:19

@theone74 It is currently not possible to use the MariaDB plugin with the static version of Qt because mariadb-connector-c comes with its own pthread implementation which has conflicting symbols with the pthread library Qt uses. Since some PostgreSQL update the same is true for the PostgreSQL plugin.

So you have to disable the plugin. When using CMake, plugins are not be automatically added so you should not run into the issue by default. When using qmake you need to disable the plugin manually, eg. you can add the following arguments to enable only the plugins which actually work:

CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static

(from https://github.com/Martchus/PKGBUILDs/blob/master/qt5-tools/mingw-w64/PKGBUILD#L38)


BTW: Patches to fix this are welcome of course. Since I don't use the plugin myself, I'm currently not motivated to take the effort myself. Updating the mariadb-connector-c packages is also not done yet.

Martchus commented on 2016-07-10 19:47

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs

Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.11.0-mingw-w64<br> if you like to contribute to patches, read this: https://github.com/Martchus/PKGBUILDs/#contributing-to-patches)

If you would like to contribute, here is a list of known bugs and things needing improvement:

  • The linker library search paths for applications which need to be build for the host architecture aren't set correctly. Hence those paths are currently set manually which is quite hacky. Affected packages are mingw-w64-qt5-declarative and mingw-w64-qt5-tools and (also the apple-darwin versions).
  • Compiling QtAV using the ANGLE version doesn't work. I don't know whether other applications/libs using OpenGL via Qt are also affected but it is very likely.
  • Updating mingw-w64-qt5-webkit to ng version.
  • See also https://github.com/Martchus/PKGBUILDs/issues

Also note the comments about the different variants inside the PKGBUILD itself.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

adsun commented on 2017-08-05 17:57

Some undefined references in openssl linking.

https://gist.github.com/Adsun701/8569eb5e94bc0d7cd314ac56e1b86cf6

Any way to fix this?

Martchus commented on 2017-07-06 21:52

Updated to 5.9.1

* OpenSSL
- Use of old OpenSSL 1.0 is still required.
- Static build links now (statically) against OpenSSL rather than loading OpenSSL at runtime. This makes more sense as it allows to distribute everything in a single binary. Unfortunately this will lead to symbol clash when trying to link an application against OpenSSL 1.1.
- Dynamic build still doesn't link against OpenSSL. OpenSSL is loaded at runtime instead (same as before) using the following search order: ssleay32.dll/libeay32.dll, libssl-10.dll/libcrypto-10.dll, libssl-8.dll/libcrypto-8.dll, libssl-7.dll/libcrypto-7.dll

* The patch 0023-Allow-usage-of-static-version-with-CMake.patch has been improved so static-only modules can be found under regular name. Additionally, it is now possible to use the static variant via CMake by just setting USE_STATIC_QT_BY_DEFAULT. Then the static variant is used by default without the need of using 'Static'-prefix.
- eg. https://github.com/Martchus/Qt-CMake-HelloWorld/blob/mingw-w64-static-by-default/CMakeLists.txt
- prefixed version which allows using both variants in the same project is still possible:
https://github.com/Martchus/Qt-CMake-HelloWorld/blob/mingw-w64-static/CMakeLists.txt

* There is no update for Qt WebKit, but I suppose it wouldn't be worth the rebuilding effort anyways. Instead I'll try updating to ng version.

xantares commented on 2017-07-04 21:26

hi,
export OPENSSL_LIBS -lssl -lcrypto, those are 1.1?
xan.

Martchus commented on 2017-06-08 20:06

Qt 5.9.0 is there :-)
See my previous comment about openssl. Additionally, this is using pcre2 now. The location module now always needs ANGLE at build time (for some plugin), otherwise the build fails. Since problems of patch 0023-Allow-usage-of-static-version-with-CMake.patch still haven't been resolved yet you might want to build without it if you don't need to use the static version with CMake.

Users of my binary repo must execute the following commands after upgrading all Qt modules to be able to use the static version with CMake:
```
find /usr/{i686,x86_64}-w64-mingw32/lib/cmake -iname 'StaticQt5*Config.cmake' -exec sed -i 's/Qt5::\(.*\)Private/StaticQt5::\1Private/g' {} \;
find /usr/{i686,x86_64}-w64-mingw32/lib -iname 'Qt5*.static.prl' -exec sed -i 's/-lpcre16/-lversion -lpcre2-16/g' {} \;
find /usr/{i686,x86_64}-w64-mingw32/lib/qt/mkspecs/mingw-w64-g++ -iname '*.conf' -exec sed -i 's/-lpcre16/-lversion -lpcre2-16/g' {} \;
```
(I just don't want to keep my server busy for hours with rebuilding if executing 3 commands is sufficient.)

Martchus commented on 2017-06-07 10:32

@xantares As far as I'm concerned there is no such patch. The regular qt5-base still uses the old openssl. I follow this approach for Qt 5.9.0 and it seems to work fine. Hence I already provide mingw-w64-openssl-1.0 which doesn't conflict with mingw-w64-openssl. So the error should be gone when I push 5.9 here. Till then, don't update to openssl to 1.1. Or use the packages for 5.9 which are already available in my PKGBUILDs repo.

xantares commented on 2017-06-07 06:35

hi,
it doesnt build because of openssl>= 1.1, is there a similar patch for what's available for qt4 ?
xan.

Martchus commented on 2017-05-01 22:18

Note that this is likely not compatible with the latest version of mingw-w64-openssl so I wouldn't recommend updating it so far. Maybe a package mingw-w64-openssl-1.0 like the regular openssl-1.0 is required.

Martchus commented on 2017-02-07 00:39

Current version is on 'update/qt5' branch of my PKGBUILDs repository: https://github.com/Martchus/PKGBUILDs/tree/update/qt5

I haven't pushed it yet because there are still some outstanding problems with the static variant. One is that dependencies are not correctly written in prl files. However, those files are used by the CMake modules which hence not work correctly (specifically the dependency cycle between freetype2 and harfbuzz is messed). Not sure how to fix this. Also building qt5-tools failed last time I tried to build it due to missing dependencies required by Qt DBus. This should be fixed now, but I'll have to verify first.

Martchus commented on 2017-01-25 18:48

Updating this to 5.8.0 will take some time. Patches are rebased, however the new config system doesn't allow to configure Qt in the same way as it was possible in previous versions (can not use iconv and pkg-config for instance).

dviktor commented on 2017-01-01 22:07

I have cleared ~/.cache/pacaur completely and after that all compiled fine!