Package Details: mingw-w64-zlib 1.2.8-5

Git Clone URL: https://aur.archlinux.org/mingw-w64-zlib.git (read-only)
Package Base: mingw-w64-zlib
Description: A compression/decompression Library (mingw-w64)
Upstream URL: http://www.zlib.net/
Licenses: custom:zlib
Conflicts: mingw-w64-zlib-static
Provides: mingw-w64-zlib-static
Submitter: ekpyron
Maintainer: xantares
Last Packager: xantares
Votes: 29
Popularity: 0.586051
First Submitted: 2012-03-22 22:55
Last Updated: 2015-07-20 18:18

Latest Comments

Edric commented on 2015-05-13 15:40

Had the same problem, in the configure.log i seen it was trying to compile with native gcc and it was not installed. Installed gcc ... no more problem...

ekpyron commented on 2014-11-27 11:57

@beda121

Do you maybe have some weird CFLAGS set in /etc/makepkg.conf? Anyways I also never saw that error before, but I updated the PKGBUILD to not only override the CFLAGS during make, but also during ./configure - maybe that solves your problem?

beda121 commented on 2014-11-26 09:25

hi,
I cannot compile it:

Using ar
Checking for x86_64-unknown-linux-gnu-gcc...
Compiler error reporting is too harsh for ./configure (perhaps remove -Werror).
** ./configure aborting.

Never seen this before.

ekpyron commented on 2014-10-30 14:53

@xantares

I changed the flags, but I don't think it's a good idea to force the use of cmake as long as the package can be built without it.

xantares commented on 2014-10-30 14:37

hi,
could you use these flags:"-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
instead of "-DNO_FSEEKO -Wall -O3", (why -DNO_FSEEKO?)

else there's a cmake build system, maybe we could use that? (correct flags are set in mingw-cmake)
xan.

xantares commented on 2014-10-30 14:36

could you use these flags:"-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
instead of "-DNO_FSEEKO -Wall -O3"

else there's a cmake build system, maybe we could use that

ekpyron commented on 2014-02-06 07:20

@xantares
It's fixed, thank you.

xantares commented on 2014-02-05 10:53

dll should be 755:
install -m755 -t "${pkgdir}/usr/${_arch}/bin" zlib1.dll
-xan

ant32 commented on 2013-05-02 14:00

1.2.8 is out

ekpyron commented on 2012-05-15 23:23

Done, thank you.

sseering commented on 2012-05-15 19:56

The version 1.2.6 isnt hosted anymore. Change the package version to 1.2.7 and it will work again.