Package Details: mininim 201701122309-1

Git Clone URL: https://aur.archlinux.org/mininim.git (read-only, click to copy)
Package Base: mininim
Description: the Advanced Prince of Persia Engine, based on 1989 release
Upstream URL: https://oitofelix.github.io/mininim/
Licenses: GPL3
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 1
Popularity: 0.000000
First Submitted: 2016-02-24 18:58
Last Updated: 2018-08-24 17:23

Latest Comments

megadriver commented on 2019-05-05 09:32

Had to add this to prepare() in order to be able to build the package:

sed -i 's|2.60|2.63|' configure.ac

dreieck commented on 2018-05-02 19:47

Note: When running mininim, the software exits with the following error:

mininim: create_bitmap (320, 200): cannot create bitmap

dreieck commented on 2018-05-02 17:48

A new release is available: https://github.com/oitofelix/mininim/archive/v201701122309.tar.gz

dreieck commented on 2018-05-02 17:40

The comment from rafaelff from 2016-12-23 does still apply.

Please add sed -i 's|-5.0|-5|' "${srcdir}/${pkgname}-${pkgver}/configure.ac" to te prepare()-function of the PKGBUILD.

rafaelff commented on 2016-12-23 22:21

Please consider renaming dependency gnulib to gnulib-git, as the former was merged to the latter [1].

[1] https://lists.archlinux.org/pipermail/aur-general/2013-February/022031.html

rafaelff commented on 2016-12-23 22:20

This package's configure.ac fails to find allegro (and derivated packages) because it tells pkg-config to search for 'allegro-5.0'(.pc), 'allegro_image-5.0'(.pc) and other '-5.0' files. However, allegro provide them without ".0".

In order to solve this, one solution is to add the following command line to prepare():
sed -i 's|-5.0|-5|' configure.ac

Anonymous comment on 2016-03-15 07:28

It's working now. Thanks!

Anonymous comment on 2016-03-13 23:27

/bin/sh: line 2: --name=The Advanced Prince of Persia Engine (a childhood dream): command not found
Makefile:1161: recipe for target 'mininim.1' failed
make[3]: *** [mininim.1] Error 127