Package Details: mist 0.11.1-1

Git Clone URL: https://aur.archlinux.org/mist.git (read-only, click to copy)
Package Base: mist
Description: Ethereum wallet and Dapp browser.
Upstream URL: https://github.com/ethereum/mist
Licenses: GPL
Conflicts: mist-git
Provides: mist
Submitter: atweiden
Maintainer: onestone
Last Packager: onestone
Votes: 86
Popularity: 0.017650
First Submitted: 2014-12-03 21:04 (UTC)
Last Updated: 2018-08-18 22:25 (UTC)

Dependencies (9)

Required by (1)

Sources (3)

Latest Comments

onestone commented on 2018-08-18 22:29 (UTC)

I did not consider v0.11.1 important, as it contains only a fix for a Windows-specific issue, irrelevant on Arch Linux. But updated anyway, as it bothers some of you.

cleopatra17 commented on 2018-08-18 13:13 (UTC)

Bumping this in hopes of catching maintainer's attention to update the package.

onestone commented on 2018-03-26 17:56 (UTC)

You should not run Mist as root.

Indeed, there are not many peers accepting light-client connections. You may have to wait, but eventually peers should be found. Or you can tell Mist to launch anyway, and disable light-client in the Develop menu.

christbkk commented on 2018-03-26 17:42 (UTC)

ok got it running but now it stops at Looking for peers (don't go further)

christbkk commented on 2018-03-26 17:36 (UTC)

just fyi i get an error "couldn't connect to node" after startup. Will try to run it as admin (sudo)

onestone commented on 2018-03-24 12:44 (UTC)

Updated to v0.10.0, simplifying the PKGBUILD a bit in the process. Seems to work fine for me, let me know if you see any new issues.

onestone commented on 2018-03-22 12:25 (UTC)

v0.10.0 no longer provides .DEB packages, so significant changes are necessary. I'm working on it.

christbkk commented on 2018-03-22 03:53 (UTC)

Thanks for the updates onestone. Looking forward to 0.10 which fixes finally the syncing problems :)

Ataraxy commented on 2017-10-31 10:11 (UTC)

I'm getting: lrwxrwxrwx 1 root root 24 Oct 31 16:53 /usr/share/mist/libgcrypt.so.11 -> /usr/lib/libgcrypt.so.11 But the target does not exist. It exists in: https://www.archlinux.org/packages/community/x86_64/libgcrypt15/files/ Is this a required dependency?

onestone commented on 2017-10-16 23:51 (UTC)

I've adopted the package and updated it to the latest release 0.9.2

cameel commented on 2017-10-16 19:03 (UTC)

Sorry for holding the package. It's up for taking now. I got a message saying "You were removed from the co-maintainer list of mist" and I did not expect that it really meant that I became the maintainer (I thought I was simply removed by 5schdn since I wasn't active for a long time). I noticed it just now.

chrbirks commented on 2017-10-16 17:00 (UTC)

Can the package maintainer please assign it to someone else who has the time to keep it up to date.

RyanH commented on 2017-10-14 19:25 (UTC)

@Inder any progress with an update? I can try to push an update but if you are already working on it I won't cause us to be doing double work :)

christbkk commented on 2017-10-10 11:34 (UTC)

Can someone update this package? Thanks

5chdn commented on 2017-10-10 07:23 (UTC)

You can use Parity instead of Geth as underlying node.

chrbirks commented on 2017-10-09 19:56 (UTC)

Why is parity listed as an optional dependency? How is it related to mist?

0ri2N commented on 2017-10-08 17:14 (UTC)

@5chdn I can take over this package and have already worked on a Mist new version for Arch Linux.

5chdn commented on 2017-10-08 13:33 (UTC)

Sorry, could anyone take over?

lucas commented on 2017-10-08 09:59 (UTC)

Please Update!

lukemontalvo commented on 2017-10-03 21:08 (UTC)

Please update the package, it's been a week since upstream released the latest version with a security fix.

solnce commented on 2017-08-18 14:08 (UTC)

I'm running this in a minimal openbox environment. mist won't start and complains about two missing files, which can be found in the following packages. Please updates the dependencies accordingly. libgtk-x11-2.0.so.0 (gtk2) libXss.s0.1 (libxss)

5chdn commented on 2017-07-25 09:22 (UTC)

Updated to 0.9.0 and fixed the desktop file.

GreenRaccoon23 commented on 2017-05-25 23:01 (UTC)

Building off of apaatsio, you need to run this after installation: sudo sed -i 's/Exec="\/opt\/Mist\/mist"/Exec="\/usr\/bin\/mist"/' "/usr/share/applications/mist.desktop";

apaatsio commented on 2017-05-07 14:46 (UTC)

When clicking the launch icon on XFCE menu I get the following error message: Failed to execute command ""/opt/Mist/mist"" The correct path is /usr/bin/mist

swalladge commented on 2017-03-17 00:17 (UTC)

Your custom .desktop file isn't being installed in the pkgbuild - rather the desktop file included in the deb is being installed, which has the wrong exec path.

robcat commented on 2017-01-10 22:51 (UTC)

On a fresh Arch installation, mist complains about missing files: libgtk-x11-2.0.so.0 and libXss.so.1. I had to install gtk2 and libxss.

kdb424 commented on 2016-10-27 04:06 (UTC)

Updated, please update the package. Thank you.

5chdn commented on 2016-10-17 08:02 (UTC)

the fuck. i just noticed the x32 binary does not contain any geth node. this is driving me crazy. I will remove the conflict, so you can install the geth package.

lhl commented on 2016-10-17 07:46 (UTC)

I don't know if anyone else had problems w/ geth binaries not being packaged in 0.8.6-1, but my package didn't have it and was failing on the last chmod command. What I did was remove the conflict with geth-git and installed that (with the DOS attacks, I run parity half the time anyway lately so never use the mist-packaged geth anymore) and the chmod line and it installs and runs peachy.

5chdn commented on 2016-09-28 20:05 (UTC)

jesus! not again!

bemyak commented on 2016-09-27 20:21 (UTC) (edited on 2016-09-27 20:21 (UTC) by bemyak)

Now they added "v" before the package version. This works for me now: ~~~ source_x86_64=( "${pkgname}-${_strver}-64.deb::https://github.com/ethereum/${pkgname}/releases/download/v${pkgver}/Mist-linux64-$_strver.deb" ) ~~~ The same thing is for i686 release.

5chdn commented on 2016-09-26 14:23 (UTC)

damn this is so annoying to change already published releases. fix incoming.

bryanj4 commented on 2016-09-22 02:29 (UTC)

The Ethereum team changed the url for downloads for x64 and probably x86. Here's what I had to use to change the source to get it to download Mist: ~~~ source_x86_64=( "${pkgname}-${_strver}-64.deb::https://github.com/ethereum/$pkgname/releases/download/${pkgver}/Mist-linux64-$_strver.deb" ) ~~~

luclu commented on 2016-09-20 10:23 (UTC)

We updated to version 0.8.3 and switched to electron-packager which will create deb packages now.

gizmoguy commented on 2016-07-08 14:27 (UTC)

The checksums are different from those listed on GitHub: https://github.com/ethereum/mist/releases/tag/0.8 As such I get a validation failure when trying to install.

5chdn commented on 2016-06-15 13:43 (UTC)

geth 1.4.7 will come with mist 0.7.5, stay tuned, this is an upstream issue.

johnnybash commented on 2016-06-14 16:37 (UTC)

the build-in geth package (1.4.4) says, theres a newer version 1.4.6 available

5chdn commented on 2016-06-13 10:53 (UTC)

@ciupenhauer I don't see any 0.7.6 release available. Please check https://github.com/ethereum/mist/releases before flagging this package out of date. Thanks.

5chdn commented on 2016-06-06 20:17 (UTC)

@abogical, did that, thanks for the heads up. @lukejohnston, added, thanks.

lukejohnston commented on 2016-06-05 18:53 (UTC)

There is a missing dependency on libnotify.

Abogical commented on 2016-06-02 20:53 (UTC) (edited on 2016-06-02 20:54 (UTC) by Abogical)

@5chdn can you please use the 'source_x86_64' and 'source_i686' varaibles to download the appropriate source for each architecture. You would waste bandwidth If you were to download both. The other ethereum related packages you maintain also have this problem.

5chdn commented on 2016-05-31 15:22 (UTC)

@wlritchi go-ethereum is obsolete / old name for geth. geth is included in this release. @rndstr thanks, fixed. @lhl thanks, fixed.

lhl commented on 2016-05-28 22:29 (UTC)

mist-0-7-4-32.zip fails to pass the integrity test for me. Is this affecting anyone else?

rndstr commented on 2016-05-27 13:21 (UTC)

misses `gconf` dependency

wlritchi commented on 2016-05-26 04:57 (UTC)

Why does this conflict with go-ethereum? go-ethereum lists mist as an optional dependency.

5chdn commented on 2016-04-04 18:09 (UTC)

Fixed, sorry.

onestone commented on 2016-03-31 13:15 (UTC)

Why is meteor now a mandatory dependency?

5chdn commented on 2016-03-29 18:33 (UTC)

sorry I messed that up. fixed now.

lmm5247 commented on 2016-03-29 02:27 (UTC) (edited on 2016-03-29 02:29 (UTC) by lmm5247)

This will fix @veox's issue... sudo mkdir -p /usr/share/mist/Ethereum-Wallet sudo mkdir -p /usr/share/mist/resources/node/geth/geth yaourt -S mist (this will build, but fail to install due to the directories already existing) sudo rmdir /usr/share/mist/Ethereum-Wallet sudo rmdir /usr/share/mist/resources/node/geth/geth sudo pacman -U /tmp/yaourt-tmp-$USER mist-0.5.2-1-x86_64.pkg.tar.xz (this will install) This (as mentioned by @cameel) will fix @notungx's issue. sudo chmod 755 /usr/share/mist/resources/node/geth/geth It should launch without issue and start syncing blocks... CONNECT to IPC PATH: /home/$USER/.ethereum/geth.ipc CONNECT to IPC PATH: /home/$USER/.ethereum/geth.ipc NODECONNECTOR ERROR { [Error: connect ENOENT /home/$USER/.ethereum/geth.ipc] code: 'ENOENT', errno: 'ENOENT', syscall: 'connect', address: '/home/$USER/.ethereum/geth.ipc' } NTP time difference: -54ms Node type: geth Network: main Start node from /usr/share/mist/resources/node/geth/geth Stopping nodes... Starting geth node... Saved standard node "geth" to file: /home/$USER/.config/Mist/node Saved network type "main" to file: /home/$USER/.config/Mist/network Geth connection FOUND Checking node sync status... NODE LOG: I0328 22:23:30.294406 5377 downloader.go:288] Block synchronisation started

veox commented on 2016-03-24 11:08 (UTC)

https://aur.archlinux.org/cgit/aur.git/commit/?h=mist&id=813ee5a6a900439ae6ec38f968373058d6fa86ae introduced a bug on systems with no previous installation: the PKGBUILD tries to chmod files outside ${pkgdir}, which do not exist.

cameel commented on 2016-03-12 17:23 (UTC)

I have just posted my comments on github. So far it looks like developers assumed that the client will use the bundled binary by default and an ability to use a system-wide install of geth is basically a feature request. So I think it makes sense to add the executable flag in the PKGBUILD and drop the optional dependency for now, and, when a new version is out, adjust the package accordingly. Or, alternatively, switch to hard dependency and replace the binary with a symlink to the binary from geth package if you think this is a better solution. It has the advantage of letting user freely switch between geth and geth-git. For me personally, either is fine. I simply want to be able to use this package without manually tweaking the PKGBUILD :)

5chdn commented on 2016-03-06 12:23 (UTC)

I'm unsure, I don't like the idea that mist starts distributing additional binaries. I will escalate the discussion upstream here, if you wish to join: https://github.com/ethereum/mist/issues/264

cameel commented on 2016-03-05 22:28 (UTC)

For some odd reason /usr/share/mist/resources/node/geth/geth has no execution privileges after installation with pacman. This is why I'm getting the same error as @notungx when I run mist. Adding the privilege solves the problem. The file is not marked as executable probably because it's unpacked from a .zip achive, which has no concept of access privileges. I see that PKGBUILD explicitly sets privileges for libnode.so and Ethereum-Wallet. It should be doing that to geth as well. Please add this line at the end of package(): chmod 755 "${pkgdir}/usr/share/${pkgname}/resources/node/geth/geth" For a moment I thought that maybe lack of exacutable flag is deliberate - after all geth is an optional dependency here. But no - mist tries to use its own copy of geth even if you install the geth package from AUR. It does not seem to detect /usr/bin/geth. The dependency is misleading and should be removed. The error and the dependency make it look as if geth wasn't bundled with mist until very recently. Is this what happened here?

5chdn commented on 2016-03-04 10:25 (UTC)

Oops, thanks, fixed.

onestone commented on 2016-03-04 01:39 (UTC)

Something is wrong with the way the PKGBUILD copies the extra files (icon.png and mist.desktop). Instead of the actual files, there are only symlinks to the temporary location where the package was built: # ls -lah /usr/share/applications/mist.desktop /usr/share/mist/icon.png lrwxrwxrwx 1 root root 38 мар 4 03:29 /usr/share/applications/mist.desktop -> /tmp/pacaurtmp-user/mist/mist.desktop lrwxrwxrwx 1 root root 34 мар 4 03:29 /usr/share/mist/icon.png -> /tmp/pacaurtmp-user/mist/icon.png

notungx commented on 2016-02-23 18:48 (UTC) (edited on 2016-02-23 18:48 (UTC) by notungx)

I get the following error after executing mist: CONNECT to IPC PATH: /home/santi/.ethereum/geth.ipc CONNECT to IPC PATH: /home/santi/.ethereum/geth.ipc NODECONNECTOR ERROR { [Error: connect ECONNREFUSED /home/santi/.ethereum/geth.ipc] code: 'ECONNREFUSED', errno: 'ECONNREFUSED', syscall: 'connect', address: '/home/santi/.ethereum/geth.ipc' } Node type: geth Network: main Start node from /usr/share/mist/resources/node/geth/geth Stopping nodes... Starting geth node... UNCAUGHT EXCEPTION { [Error: spawn EACCES] code: 'EACCES', errno: 'EACCES', syscall: 'spawn' } Stopping nodes... In my laptop works just executing mist without the need of executing geth first... any ideas?

5chdn commented on 2016-02-19 11:37 (UTC)

Added, and updated.

gcarq commented on 2016-02-18 20:55 (UTC)

Please add a .desktop launcher

5chdn commented on 2015-10-16 08:04 (UTC)

Mist has it's own repository now: https://github.com/ethereum/mist It released beta1 yesterday and comes with prebuild standalone nodes: https://github.com/ethereum/mist/releases