Package Details: mkdocs 0.17.4-1

Git Clone URL: (read-only)
Package Base: mkdocs
Description: Project documentation with Markdown.
Upstream URL:
Licenses: BSD
Submitter: carlwgeorge
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 13
Popularity: 0.556272
First Submitted: 2015-06-11 18:21
Last Updated: 2018-06-09 11:28

Latest Comments

dcelasun commented on 2018-02-28 06:26

I've adopted the package and moved depends to the top level. It should now work correctly with all AUR helpers.

carlwgeorge commented on 2017-12-02 20:44

@arafey Sorry for the delay, it's up to date now.

arafey commented on 2017-11-09 02:54

@carlwgeorge, I will maintain this package if you are no longer interested in doing so. Regards

dcelasun commented on 2017-09-28 11:25

@carlwgeorge: I have never once used or mentioned yaourt, so I'm not sure why you think that would help me. Anyway, I have no intention of discussing this further, so this is my last comment on this topic.

carlwgeorge commented on 2017-09-27 23:35

@dcelasun I'm not looking bicker about yaourt flaws again, but I did want to share this link with you in case you wanted to subscribe to it.

carlwgeorge commented on 2017-06-15 21:20

@dcelasun I totally agree you are having yaourt UX issues. You should report those to yaourt.

dcelasun commented on 2017-06-13 20:36

@carlwgeorge: Thanks, but I'm not looking for an AUR helper that seemingly fits a specification that only you are aware of.

_Especially_ since you think the current behaviour of depends/makedepends is a bug (which, literally no one else [0] seem to think so) and your only "proof" is some unnamed TU who might or might not have told you something that is or isn't relevant.

So thanks, I'll pass.


P.S: Sorry for the snark, but it really gets on my nerves when people dismiss UX concerns on religious arguments and appeals to purity.

carlwgeorge commented on 2017-06-13 19:12

@dcelasun I found out that pacaur works fine to build this package. Like I said before, switch to an AUR helper that respects the specification.

carlwgeorge commented on 2017-06-04 02:45

> warning: cannot resolve "python-livereload>=2.5.1", a dependency of "mkdocs"

If you see this warning, then you are using an AUR helper that doesn't properly handle the depends array being in the package function. I suggest switching to a different AUR helper. For example, pacaur cleanly builds this PKGBUILD.

carlwgeorge commented on 2017-06-04 02:42


"An array of packages that must be installed before the software can be run."

"An array of packages that are only required to build the software."

It's not my understanding, it's the literal definition. This definition is not unique to Arch, it's the same for packaging RPMs (my $dayjob) and Debian packages.

I never filed a but because an Arch Trusted User was the one who told me about it. I can't find a bug report for it, but I'll ask that TU if it was ever filed or why it was never fixed, perhaps he can shed some light on the situation.

I'm not changing the PKGBUILD, so you can stop wasting your time giving me attitude. Your time would be much better spent finding an AUR helper that works, or filing a bug with your current AUR helper. It seems the core problem is that your AUR helper isn't looking ahead to see that one of the depends is also an AUR package, and must be built first.

All comments