Package Details: mkdocs 1.0.4-1

Git Clone URL: https://aur.archlinux.org/mkdocs.git (read-only, click to copy)
Package Base: mkdocs
Description: Project documentation with Markdown.
Upstream URL: http://www.mkdocs.org
Licenses: BSD
Submitter: None
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 16
Popularity: 0.001889
First Submitted: 2015-06-11 18:21
Last Updated: 2018-10-11 09:26

Pinned Comments

dcelasun commented on 2020-05-21 09:02

The latest version of mkdocs (1.1.2) depends on python-markdown>=3.2.1. Unfortunately, the Arch package is stuck in 3.1.1 since February. Until that changes, I can't update this package.

Latest Comments

1 2 3 4 Next › Last »

dcelasun commented on 2020-05-21 09:02

The latest version of mkdocs (1.1.2) depends on python-markdown>=3.2.1. Unfortunately, the Arch package is stuck in 3.1.1 since February. Until that changes, I can't update this package.

dcelasun commented on 2020-02-07 14:30

@antran looks like you've installed python-livereload (a dependency of mkdocs) outside the package manager (perhaps with php?) and now it's conflicting. Removing it should fix the problem.

antran commented on 2020-02-07 14:28

Hi

I am trying to install mkdocs but I get this error

python-livereload: /usr/bin/livereload exists in filesystem Errors occurred, no packages were upgraded.

Does anyone know how to fix it? Thank you so much. Best,

dcelasun commented on 2018-08-04 22:53

python-tornado 5 is in [community-testing] for now, I've reverted mkdocs until it's released into [community].

ruuda commented on 2018-08-04 21:34

This package is currently broken:

pkg_resources.DistributionNotFound: The 'tornado>=5.0' distribution was not found and is required by mkdocs

The package still has a requirement "python-tornado>=4.1", but mkdocs 1.0 requires Tornado 5.

dcelasun commented on 2018-08-03 17:14

Updated to 1.0 which comes with several backwards incompatible changes.

dcelasun commented on 2018-07-23 17:58

Please don't mark as out of date for alpha/beta builds.

dcelasun commented on 2018-02-28 06:26

I've adopted the package and moved depends to the top level. It should now work correctly with all AUR helpers.

Anonymous comment on 2017-12-02 20:44

@arafey Sorry for the delay, it's up to date now.

arafey commented on 2017-11-09 02:54

@carlwgeorge, I will maintain this package if you are no longer interested in doing so. Regards