Package Details: mkinitcpio-nosystemd 22-2

Git Clone URL: https://aur.archlinux.org/mkinitcpio-nosystemd.git (read-only)
Package Base: mkinitcpio-nosystemd
Description: Modular initramfs image creation utility
Upstream URL: https://projects.archlinux.org/mkinitcpio.git/
Licenses: GPL
Conflicts: mkinitcpio
Provides: mkinitcpio=22-2
Submitter: replabrobin
Maintainer: replabrobin
Last Packager: replabrobin
Votes: 7
Popularity: 0.153503
First Submitted: 2015-04-29 11:17
Last Updated: 2016-11-29 07:45

Dependencies (17)

Required by (141)

Sources (3)

Latest Comments

Cromer commented on 2016-11-29 00:46

same problem, can't build without asciidoc, makedepends=('asciidoc') needs to be added.

alium commented on 2016-08-28 07:29

cannot build without asciidoc :-(

a2x -d manpage \
-f manpage \
-a manversion=19 \
-a manmanual="mkinitcpio manual" man/mkinitcpio.8.txt
/bin/sh: a2x: command not found
make: *** [Makefile:65: man/mkinitcpio.8] Error 127

replabrobin commented on 2016-02-19 17:17

I added back the provides and conflict. Leftout the makedepends=('asciidoc') since it's not in the current official PKGBUILD. Hope this now works for you.

replabrobin commented on 2016-02-19 17:05

I must have hit dd, I'll fix it right away

nous commented on 2016-02-19 16:14

Was there a reason you removed the provides=("mkinitcpio=${pkgver}-${pkgrel}") line from the PKGBUILD? It breaks system updates because linux kernel packages depend of mkinitcpio.

replabrobin commented on 2015-07-13 15:41

Mr Green, yes I have the same problem with some of the upstream package signing not failing. Don't think that has much to do with the pacman keys though. I have tried importing some of the keys and that generally works.

mrgreen commented on 2015-07-13 07:02

I found package in openrc-eudev repo, still did not work as I was getting loop device not found. So after a search found the answer by adding earlymodules=loop too kernel append line....

Now running runit, systemd free iso

mrgreen commented on 2015-07-13 06:31

Assuming my pacman-key is up to date am getting this error

ptional dependencies for asciidoc
lilypond: music-filter
imagemagick: music-filter (used in conjunction with lilypond)
source-highlight: source-highlight-filter
dblatex: pdf generation
fop: alternative pdf generation
lynx: text generation [installed]
w3m: text generation (alternative to lynx)
==> Retrieving sources...
-> Found mkinitcpio-18.tar.gz
-> Found mkinitcpio-18.tar.gz.sig
-> Found 0001-avoid-compound-conditional-leading-to-spurious-error.patch
-> Found 0002-remove-systemd.patch
==> Validating source files with sha256sums...
mkinitcpio-18.tar.gz ... Passed
mkinitcpio-18.tar.gz.sig ... Skipped
0001-avoid-compound-conditional-leading-to-spurious-error.patch ... Passed
0002-remove-systemd.patch ... Passed
==> Verifying source file signatures with gpg...
mkinitcpio-18.tar.gz ... FAILED (unknown public key 1EB2638FF56C0C53)
==> ERROR: One or more PGP signatures could not be verified!
==> Removing installed dependencies...
checking dependencies...

Have refreshed keys but error remains...