Package Details: mkxp-git r745.794e86d-1

Git Clone URL: https://aur.archlinux.org/mkxp-git.git (read-only)
Package Base: mkxp-git
Description: Open source implementation of the Ruby Game Scripting System of RPG Maker XP/VX/VX Ace (development version)
Upstream URL: https://github.com/Ancurio/mkxp
Licenses: GPL2
Conflicts: mkxp
Provides: mkxp
Submitter: carstene1ns
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 3
Popularity: 0.000000
First Submitted: 2014-01-11 06:59
Last Updated: 2015-07-08 03:26

Latest Comments

PyroDevil commented on 2015-12-29 08:04

Hi again.

Now it needs '-DCMAKE_CXX_FLAGS=-std=c++11' to get build with the current libraries (libsigc++>=2.5.1).

maz-1 commented on 2015-11-01 14:06

Hello, just to let you know, I set up a repo on opensuse build service that provides mkxp-git and some other emulators/game runtime
https://github.com/maz-1/OBS-ArchLinux

If you want to use it, add these lines to pacman.conf

[home_mazdlc_emulators_Arch_Extra]
SigLevel = Never
Server = http://download.opensuse.org/repositories/home:/mazdlc:/emulators/Arch_Extra/$arch

Note: I adjusted some dependencies to avoid installing some bleeding-edge packages that break stable ones. physfs-hg is statically linked into mkxp ; requires fluidsynth stable version instead of git one ; sdl_sound-patched-hg renamed to sdl2_sound-patched-hg and modified to avoid confliction with sdl_sound.

carstene1ns commented on 2015-05-10 15:02

@fenuks: It is not as easy as you think. While we can get the ruby version with your provided command (btw. it is easier to just use ruby itself: ruby -e "print RUBY_VERSION.split('.')[0..1].join('.')"), it will only work with the normal 'ruby' package or if built in a chroot. As soon as you use 'rvm'[1], 'rbenv'[2] or an alternative ruby implementation like rubinius (with a compat package like 'rubinius-ruby'[3]) it breaks. Using pacman here should be a more reliable choice. However, as 'rubinius-ruby' provides 'ruby', I needed to add an additional check for this.
I hope this lasts a bit longer until this breaks 'again' (it has been a year, since I modified the value btw.)

[1]: https://wiki.archlinux.org/index.php/RVM
[2]: https://wiki.archlinux.org/index.php/Rbenv
[3]: https://www.archlinux.org/packages/community/x86_64/rubinius-ruby/

fenuks commented on 2015-05-07 08:19

Again -DMRIVERSION is incorrect. Instead hard-coding its value you can use something like -DMRIVERSION=`ruby --version | grep -oP '(?<=ruby )\d+\.\d+'`. Also, in file $srcdir/mkxp/src/eventthread.cpp:495 SDL_RENDER_DEVICE_RESET is not defined in latest stable SDL available in Arch repos. You can change dependency to SDL from AUR or comment it out since it's used only for debugging.

carstene1ns commented on 2014-04-16 16:08

Oh yes, you are right. Sometimes it is not easy to keep up with all the package updates. :) Thanks!

PyroDevil commented on 2014-04-15 22:26

You should change
cmake ./
to
cmake -DMRIVERSION=2.1 ./

Because ruby 2.1 is currently standard in arch.

carstene1ns commented on 2014-01-11 07:30

I had to add vim as makedep, because it packages the needed tool xxd.
If you don't want to have vim, you can easily substitute the makedep with xxd[1] from aur.

[1]: https://aur.archlinux.org/packages/xxd/