Package Details: mnemosyne 2.7.3-1

Git Clone URL: https://aur.archlinux.org/mnemosyne.git (read-only, click to copy)
Package Base: mnemosyne
Description: A flash-card tool with a sophisticated card review algorithm
Upstream URL: http://www.mnemosyne-proj.org
Keywords: Anki flashcard learn memorize
Licenses: GPL
Conflicts: mnemosyne-bzr
Submitter: wide-eyed
Maintainer: billypilgrim
Last Packager: billypilgrim
Votes: 85
Popularity: 0.043269
First Submitted: 2007-11-04 20:08
Last Updated: 2020-12-11 16:07

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

smls commented on 2017-06-30 20:44

@Kanjelman

I'm not getting that error on Arch Linux / KDE.

However, the Mnemosyne mailing list seems to have a report of the same error by a Linux Mint user a few months ago: https://groups.google.com/forum/#!topic/mnemosyne-proj-users/OEI50SSlzf4
Apparently it was solved by "making sure leftovers from a previous partial install were deleted", though no details are given.

Did you have an existing ~/.local/share/mnemosyne/ or ~/.config/mnemosyne/ or ~/.Mnemosyne/, and if so, does removing those folders fix the problem? (Be sure to make backup first of course.)

Kanjelman commented on 2017-06-30 02:06

Hello, I just installed Mnemosyne 2.4.1 via AUR in Manjaro Linux xfce. Upon launching the program, the following error occurred. Any assistance is appreciated.

An unexpected error has occurred.
Please forward the following info to the developers:

Traceback (innermost last):
File "/usr/bin/mnemosyne", line 247, in <module>
debug_file=options.debug_file)
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/__init__.py", line 226, in initialise
raise e
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/__init__.py", line 217, in initialise
self.log().started_program()
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/loggers/database_logger.py", line 26, in started_program
self.database().log_started_program(self.timestamp, version_string)
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/databases/SQLite_logging.py", line 30, in log_started_program
self.con.execute(\
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/databases/SQLite.py", line 256, in con
self._connection = _Sqlite3(self.component_manager, self._path)
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/databases/_sqlite3.py", line 53, in __init__
self.connection = sqlite3.connect(path)
TypeError: argument 1 must be str, not None

smls commented on 2017-04-28 09:50

@jsh6789: I've added it to optdepends for now, since not every Mnemosyne installation needs to support starting a sync server.

jsh6789 commented on 2017-04-04 00:05

In order to start the sync server, the package python-cheroot must be installed; please add it as a dependency.

Relevant error message:
Traceback (innermost last):
File "/usr/lib/python3.6/site-packages/mnemosyne/pyqt_ui/configuration_dlg.py", line 54, in accept
self.tab_widget.widget(index).apply()
File "/usr/lib/python3.6/site-packages/mnemosyne/pyqt_ui/configuration_wdgt_servers.py", line 84, in apply
self.component_manager.current("sync_server").activate()
File "/usr/lib/python3.6/site-packages/mnemosyne/pyqt_ui/qt_sync_server.py", line 193, in activate
component_manager=self.component_manager)
File "/usr/lib/python3.6/site-packages/mnemosyne/pyqt_ui/qt_sync_server.py", line 65, in __init__
super().__init__(ui=self, **kwds)
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/sync_server.py", line 31, in __init__
port=config["sync_server_port"], **kwds)
File "/usr/lib/python3.6/site-packages/mnemosyne/libmnemosyne/component.py", line 48, in __init__
super().__init__(**kwds)
File "/usr/lib/python3.6/site-packages/openSM2sync/server.py", line 98, in __init__
from cheroot import wsgi
ModuleNotFoundError: No module named 'cheroot'

Thanks in advance,
JSH

bonob commented on 2017-01-11 15:16

Support for Fcitx input method requires fcitx-qt5 when upgrading to Mnemosyne 2.4.
Not sure if that deserves an optional dependency here, or maybe a note on the wiki page?
In any case, if someone runs into the same problem as me, my comment may be of help.

smls commented on 2016-12-21 00:47

@bialou: Added.

bialou commented on 2016-12-20 23:32

@smls So we probably should put that python-pillow package as a dependency.
.... or any other package that has pillow and/or(?) image in it.
P.S. I run i3wm, if it matters.

bialou commented on 2016-12-20 23:26

@Ichimonji10 "pip3 install --user image" installed 3 packages: django-1.10.4 image-1.5.5 pillow-3.4.2;

I uninstalled them manually and tried python-pillow package instead. Everything still works good now and I don't have that error on "Browse Cards" button you have. So, it must be something else going on. The only thing I did before installing python-pillow is to uninstall django, image, and pillow with "pip uninstall ..."

jerebear commented on 2016-12-20 22:57

@smls, thanks for the fix! Mnemosyne no longer suffers from the error I outlined.

I now suffer from the same error described by @bialou: PIL (python imaging library) is not installed. The suggested solution is to install image with pip. I *think* a more generic solution is to install the python-pillow package with pacman. It works well enough to let mnemosyne start.

Edit: I'm now suffering from a new issue. It's probably an issue with mnemosyne itself. @smls, can you take a look, and let the maintainers know about it if appropriate? This error log pops up when I press the "Browse cards" button. http://i.imgur.com/Ekie5SU.png

bialou commented on 2016-12-20 06:16

@hongleong: Installing it manually "pip3 install --user image" takes care of that problem. Hopefully, this can be fixed correctly later. Thank you, for help.