Package Details: mod_perl 2.0.11-5

Git Clone URL: (read-only, click to copy)
Package Base: mod_perl
Description: Apache module that embeds the Perl interpreter within the server
Upstream URL:
Licenses: Apache
Submitter: anatolik
Maintainer: mattsday
Last Packager: mattsday
Votes: 8
Popularity: 0.093904
First Submitted: 2015-06-28 15:38
Last Updated: 2021-05-29 07:23

Pinned Comments

lb.laboon commented on 2017-09-14 16:24

A note to everyone compiling this package:

You must import PGP key AB34BA0040E92ECE into your keyring in order to validate the source package.
Please see the Arch wiki for more details:

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

lb.laboon commented on 2015-12-20 16:35

mod_perl won't work with the latest version of perl. If you are replacing the 'perl<5.22' dependency with 'perl' then the package will build successfully, but it won't work when you try to run it (i.e. with Apache). The only way for it to work is to install perl 5.20 or lower, but it is no longer in the repositories. You will have to compile it from source yourself.

nelsinchi commented on 2015-12-20 14:06

@ArthurBorsboom: Thanks a lot for your support! I was configuring BackupPC and by doing this I was needing to install mod_perl.

I found the 2 errors and I followed what you said and it works.

Just one more thing, when I add "LoadModule perl_module modules/" into my httpd.conf, the service does not run.


lb.laboon commented on 2015-11-25 18:24

According to the bug thread, it looks like they have a fix which will be implemented in version 2.0.10 pretty soon. When that happens, will this package move back to the official repos or is it going to stay in the AUR?

anatolik commented on 2015-09-01 17:28

Besides downgrading perl you have 2 more options:

- The best option is to avoid using mod_perl. mod_perl development is in stagnation nowdays.

- Contact upstream and ask to fix Perl 5.22 issues.

lclc commented on 2015-09-01 14:37

I downgraded my Perl version (and a few packages depending on v5.22) to work around this for now (so far no negative side effects):

cd /var/cache/pacman/pkg/
sudo pacman -U perl-5.20.2-1-x86_64.pkg.tar.xz perl-dbd-mysql-4.031-1-x86_64.pkg.tar.xz perl-dbi-1.633-1-x86_64.pkg.tar.xz perl-linux-pid-0.04-4-x86_64.pkg.tar.xz perl-xml-libxml-2.0121-1-x86_64.pkg.tar.xz perl-xml-parser-2.44-1-x86_64.pkg.tar.xz

Very annoying.

loserMcloser commented on 2015-08-15 17:15


Straight from the mod_perl v2.0.9 announce mail (fourth message from the bottom at

"Note that Perl 5.22.x is currently not supported. This is logged as
CPAN RT#101962 and will hopefully be addressed in 2.0.10."

ArthurBorsboom commented on 2015-08-10 13:58

Although it builds with perl, the perl module segfaults with perl > 5.21

Apparently a known problem:

I guess we have to wait for a solution.

ArthurBorsboom commented on 2015-08-10 12:45

Two errors

1. error: target not found: perl<5.22

Workaround: Replace in PKGBUILD 'perl<5.22' with perl

2. ==> Verifying source file signatures with gpg...
mod_perl-2.0.9.tar.gz ... FAILED (unknown public key AB34BA0040E92ECE)

Workaround: Remove in PKGBUILD {,.asc} and Remove the line 'SKIP'

@anatolik, would you mind to fix it properly?