Package Details: mod_python2 3.5.0-3

Git Clone URL: https://aur.archlinux.org/mod_python2.git (read-only, click to copy)
Package Base: mod_python2
Description: An Apache module that embeds the Python2 interpreter within the server
Upstream URL: http://www.modpython.org/
Licenses: Apache
Conflicts: mod_python, mod_python2-legacy
Submitter: AstroProfundis
Maintainer: tallero
Last Packager: micwoj92
Votes: 1
Popularity: 0.000000
First Submitted: 2014-05-05 09:32 (UTC)
Last Updated: 2020-10-30 22:07 (UTC)

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

AstroProfundis commented on 2014-10-12 09:14 (UTC)

Using "true" doesn't work for me either, instead, I used the $pkgrel to replace the git commit hash.

visit commented on 2014-10-11 14:32 (UTC)

Please add this to build() sed -i -e "s#git describe --always#true#" dist/version.sh

AstroProfundis commented on 2014-09-27 21:56 (UTC)

I tried to apply this fix and build the package, it generates an egg named mod_python-3.5.0_-py2.7.egg-info, this doesn't look good to me. Meanwhile, the current (not patched) script builds an egg named mod_python-3.5.0_3765322-py2.7.egg-info which works for me. I'm afraid there might be some environment difference between us. You can try my binary package: http://fun.atr.me/archlinux/x86_64/mod_python2-3.5.0-1-x86_64.pkg.tar.xz (i686 also available), it is built with clang other than gcc.

geosam commented on 2014-09-27 19:29 (UTC)

Error execute python scripts: The solution in: http://stackoverflow.com/questions/20022952/fatal-not-a-git-repository-when-installing-mod-python