Package Details: moksha-module-alarm-git 752dafe-1

Git Clone URL: https://aur.archlinux.org/moksha-modules-extra-git.git (read-only, click to copy)
Package Base: moksha-modules-extra-git
Description: Moksha modules meta-package
Upstream URL: http://mokshadesktop.org
Keywords: moksha moksha-module
Licenses: BSD
Submitter: fusion809
Maintainer: None
Last Packager: fusion809
Votes: 4
Popularity: 0.000000
First Submitted: 2016-01-22 15:36 (UTC)
Last Updated: 2017-12-11 14:54 (UTC)

Latest Comments

M3gts58 commented on 2017-12-12 15:57 (UTC)

You are right, sorry. I thought yaourt would detect the missing dependencies and install them, but I guess it didn't do that for me and because of that I forgot to check if I can find these dependencies seperated in the AUR xD

fusion809 commented on 2017-12-11 22:19 (UTC) (edited on 2017-12-11 22:29 (UTC) by fusion809)

Those packages all exist here in the AUR? https://aur.archlinux.org/packages/moksha-module-net-git, https://aur.archlinux.org/packages/moksha-module-mem-git, https://aur.archlinux.org/packages/moksha-module-diskio-git. If there's something wrong with them feel free to report said problem in their comments.

M3gts58 commented on 2017-12-11 20:54 (UTC)

thx you fixed the major problem, but there are still dependencies mentioned at the end of the pkguild without a function for building them from your github page. So the following warning is caused when using yaourt:

warning: cannot resolve "moksha-module-diskio-git", a dependency of "moksha-modu les-extra-git" warning: cannot resolve "moksha-module-mem-git", a dependency of "moksha-modules -extra-git" warning: cannot resolve "moksha-module-net-git", a dependency of "moksha-modules -extra-git" :: The following package cannot be upgraded due to unresolvable dependencies: moksha-modules-extra-git

So it would be awesome if you would add functions for these modules as well.

fusion809 commented on 2017-12-11 14:52 (UTC)

Oops sorry it seems like I had a commit that should fix this that I hadn't pushed

M3gts58 commented on 2017-12-11 14:45 (UTC) (edited on 2017-12-11 14:47 (UTC) by M3gts58)

The pkgbuild seems to be broken. There still exists the error Tiedemann reported. I was able to solve it by changing /cpu in this section to /calendar, but there are still missing functions for makepkg to resolve the dependencies mentioned at the end of the pkgbuild.

package_moksha-module-calendar-git() { pkgdesc="Moskha calendar module built from git sources"

cd "${srcdir}/${_pkgname}/cpu" <br> msg2 "Installing cpu" make DESTDIR="${pkgdir}" install

install text files

[[ -e ChangeLog ]] && install -Dm644 ChangeLog "${pkgdir}/usr/share/doc/${pkgname%-}/ChangeLog" || true [[ -e NEWS ]] && install -Dm644 NEWS "${pkgdir}/usr/share/doc/${pkgname%-}/NEWS" || true [[ -e README ]] && install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname%-*}/README" || true

install license files

[[ -e AUTHORS ]] && install -Dm644 AUTHORS "${pkgdir}/usr/share/licenses/$pkgname/AUTHORS" || true [[ -e COPYING ]] && install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/COPYING" || true [[ -e COPYING-PLAIN ]] && install -Dm644 COPYING-PLAIN "${pkgdir}/usr/share/licenses/$pkgname/COPYING-PLAIN" || true }

fusion809 commented on 2017-09-18 06:29 (UTC)

Thanks I just implemented your fix

FabioLolix commented on 2017-09-17 23:21 (UTC)

There are several errors and don't build has already reported. Here's a working pkgbuild https://raw.githubusercontent.com/FabioLolix/PKGBUILD/master/moksha-modules-extra-git/PKGBUILD

Tiedemann commented on 2017-01-27 16:14 (UTC)

This always fails for me: make[2]: Leaving directory '/home/oscar/build/makepkg/moksha-modules-extra-git/src/moksha-modules-extra/alarm' make[1]: Leaving directory '/home/oscar/build/makepkg/moksha-modules-extra-git/src/moksha-modules-extra/alarm' ==> Tidying install... -> Removing libtool files... -> Purging unwanted files... -> Removing static library files... -> Stripping unneeded symbols from binaries and libraries... -> Compressing man and info pages... ==> Checking for packaging issue... ==> Creating package "moksha-module-alarm-git"... -> Generating .PKGINFO file... -> Generating .BUILDINFO file... -> Generating .MTREE file... -> Compressing package... ==> Starting package_moksha-module-calendar-git()... -> Installing cpu make: *** No rule to make target 'install'. Stop. ==> ERROR: A failure occurred in package_moksha-module-calendar-git(). Aborting... ==> ERROR: Makepkg was unable to build moksha-modules-extra-git. ==> Restart building moksha-module-calendar-git ? [y/N]

fusion809 commented on 2016-02-04 21:03 (UTC)

Thanks, I just fixed it.

nessus commented on 2016-02-04 20:54 (UTC)

moksha-modules-emprint-git doesn't exist, it is named moksha-module-emprint-git