Package Details: moksha 0.2.1-1

Git Clone URL: https://aur.archlinux.org/moksha.git (read-only)
Package Base: moksha
Description: A fork of the E17 window manager used by Bodhi Linux.
Upstream URL: http://mokshadesktop.org
Keywords: moksha
Licenses: BSD
Conflicts: enlightenment
Provides: moksha
Submitter: fusion809
Maintainer: fusion809
Last Packager: fusion809
Votes: 7
Popularity: 0.081471
First Submitted: 2016-01-18 19:04
Last Updated: 2017-05-10 09:17

Latest Comments

fusion809 commented on 2016-12-20 20:09

Haven't the foggiest. But if you want a work-around I have a pre-built Moksha package in my pkgbuild-current repo. See https://github.com/fusion809/PKGBUILDs/releases/tag/current for details.

heichblatt commented on 2016-12-20 09:52

configure: error: Package requirements (
(..)
No package 'xcb-keysyms' found

Installing xcb-util-keysyms-0.4.0-1 fixes this. Please add as a dependency.

fusion809 commented on 2016-10-30 11:20

Yep I know, but efl-git provides it. If I exclude it as a dependency the build fails.

heichblatt commented on 2016-10-30 10:03

There is no package called 'elementary'.

fusion809 commented on 2016-03-10 09:25

Hey folks, if you don't feel like building the Moksha package from this PKGBUILD and would rather install a pre-built binary, try adding my pkgbuild-current repo. Namely, by adding:

[pkgbuild-current]
Server = https://github.com/fusion809/PKGBUILDs/releases/download/current
SigLevel = PackageOptional

to your /etc/pacman.conf file and run (as root):

pacman -Syu
pacman -S moksha

fusion809 commented on 2016-02-27 05:18

@AJSlye, on a new Arch install I managed to fix that problem. Sorry for any inconvenience this delay may have caused (not just speaking to AJSlye, rather talking to everyone).

fusion809 commented on 2016-02-09 03:53

@AJSlye I know, that link to the forums I posted was regarding that problem. I can't fix it as the AUR is refusing my commits ever since I pushed that erroneous change to the moksha PKGBUILD. As a solution I have added the correct PKGBUILD to my GitHub repo of PKGBUILDs https://github.com/fusion809/PKGBUILDs.

AJSlye commented on 2016-02-09 03:49

The pkgbuild has install=moksha.install' it's missing '
this should be install='moksha.install'

fusion809 commented on 2016-02-07 00:36

@altalpo thanks for reporting, I just attempted to fix it. See https://bbs.archlinux.org/viewtopic.php?id=208595 for details on the issues I've encountered.

altalpo commented on 2016-02-07 00:22

yaourt complained like...

==> ERROR: install should not be an array
==> ERROR: Makepkg was unable to build moksha.

so, I have to change

install=('moksha.install')

as

install='moksha.install'

thanks

All comments