Package Details: monero-feather-git 0.8.0.ff6e6adf0c-1

Git Clone URL: https://aur.archlinux.org/monero-feather-git.git (read-only, click to copy)
Package Base: monero-feather-git
Description: A free Monero desktop wallet
Upstream URL: https://featherwallet.org
Licenses: BSD
Submitter: wowario
Maintainer: wowario
Last Packager: wowario
Votes: 1
Popularity: 0.33
First Submitted: 2020-10-12 13:49
Last Updated: 2021-07-14 17:56

Latest Comments

wowario commented on 2021-03-25 08:25

@arpspoof compiling should be fixed now.

arpspoof commented on 2021-02-25 12:34

You don't have this issue compiling from source?

wowario commented on 2021-02-22 18:47

@arpspoof you can can up issue in repo https://git.featherwallet.org/feather/feather/issues

thank you!

arpspoof commented on 2021-02-19 22:38

I'm still getting compile error:

5:31: error: ‘sleep_for’ is not a member of ‘std::this_thread’
 1315 |             std::this_thread::sleep_for(intervalResolution);

Should I file as bug or is this on my end only?

arpspoof commented on 2021-02-17 13:49


[ 70%] Building CXX object src/CMakeFiles/feather.dir/model/RedditModel.cpp.o
/home/me/.cache/pacaur/monero-feather-git/src/monero-feather-git/src/libwalletqt/Wallet.cpp: In lambda function:
/home/me/.cache/pacaur/monero-feather-git/src/monero-feather-git/src/libwalletqt/Wallet.cpp:1315:31: error: ‘sleep_for’ is not a member of ‘std::this_thread’
 1315 |             std::this_thread::sleep_for(intervalResolution);
      |                               ^~~~~~~~~
[ 71%] Building CXX object src/CMakeFiles/feather.dir/model/SubaddressAccountModel.cpp.o
[ 71%] Building CXX object src/CMakeFiles/feather.dir/model/SubaddressModel.cpp.o
make[2]: *** [src/CMakeFiles/feather.dir/build.make:1095: src/CMakeFiles/feather.dir/libwalletqt/Wallet.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/Makefile2:2571: src/CMakeFiles/feather.dir/all] Error 2
make: *** [Makefile:149: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

wowario commented on 2021-01-02 10:09

@arpspoof fixed

arpspoof commented on 2021-01-02 08:41

When attempting to install using pacman or makepkg I get this error.

==> Starting pkgver()... ==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.

==> ERROR: pkgver() generated an invalid version: beta-3.c2ec2c5dc :: failed to verify integrity or prepare monero-feather-git package

wowario commented on 2020-12-22 19:03

Thanks for reporting. I've added desktop file.

GI_Jack commented on 2020-12-22 01:32

No .Desktop file.

sad :(

edit: Add Desktop file to PKGBUILD. IT exists in source:

package_monero-feather-git() {
  install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
  install -Dm755 "${srcdir}/${pkgname}/build/bin/feather" "${pkgdir}/usr/bin/feather"
  install -Dm644 "${srcdir}/${pkgname}/src/assets/feather.desktop" "${pkgdir}/usr/share/applications/feather.desktop"
}

GI_Jack commented on 2020-10-25 17:51

CMake Error at CMakeLists.txt:88 (message): [submodule] Monero HEAD was at 3d5dae1f42618fe2e85fa27d939d2f8a5b1aae44 but should be at a39fd7ea978053929da63dcdb8073806573be5ba