Package Details: mongo-cxx-driver-legacy 1.1.2-1

Git Clone URL: https://aur.archlinux.org/mongo-cxx-driver-legacy.git (read-only)
Package Base: mongo-cxx-driver-legacy
Description: Official MongoDB C++ driver (legacy).
Upstream URL: http://www.mongodb.org
Keywords: mongodb
Licenses: Apache
Conflicts: mongodb<2.6.0
Provides: mongo-cxx-driver
Submitter: mrohnstock
Maintainer: tbrock
Last Packager: mrohnstock
Votes: 6
Popularity: 0.000000
First Submitted: 2014-04-25 06:26
Last Updated: 2016-06-22 06:34

Pinned Comments

mrohnstock commented on 2015-02-13 06:59

ATTENTION FOR C++11 USERS:

If you want to use this driver for a project which gets compiled with c++11 features enabled (-std=c++11), you have to add --c++11 flag to scons, otherwise intialize the driver will crash with segmentation fault (see https://jira.mongodb.org/browse/CXX-458).

I can't enable this flag by default, because your project has to compile with -std=c++11, too. I could create an other package for reflecting this issue, if someone ask for it.

Otherwise current develop-branch of this driver is for c++11 only, but will take some time until it's usable (at least for testing).

Latest Comments

1 2 3 Next › Last »

lsr commented on 2019-02-18 14:11

PKGBUILD with 1.1.3, patched for openssl-1.0 and latest boost:

# $Id$
# Maintainer: monty <linksoft [at] gmx [dot] de>

_pkg=mongo-cxx-driver
_subpkg=legacy
pkgname=${_pkg}-${_subpkg}
pkgver=1.1.3
pkgrel=1
pkgdesc='Official MongoDB C++ driver (legacy).'
arch=('i686' 'x86_64')
url='http://www.mongodb.org'
license=(APACHE)
depends=('boost-libs' 'libsasl' 'openssl-1.0')
makedepends=('scons' 'boost' 'readline' 'openssl-1.0')
source=("https://github.com/mongodb/${_pkg}/archive/${_subpkg}-${pkgver//_/-}.tar.gz")
conflicts=("mongodb<2.6.0")
options=("staticlibs")
provides=("mongo-cxx-driver")
sha512sums=('c2b259a6cd10415efaa7ac464180640f7218d6e4e470ebedc03957e5651a79f4d62269ab4aa8f07d036286a8b9e34e3f9a2fc3183159dc54e50ebe487f9abb85')

prepare() {
  cd ${pkgname}-${pkgver//_/-}
  sed -e 's,boost::next,std::next,g' -i src/mongo/client/wire_protocol_writer.cpp
  sed -e 's,boost::next,std::next,g' -i src/mongo/client/command_writer.cpp 
}

package() {
  cd ${pkgname}-${pkgver//_/-}

  scons \
    --use-sasl-client \
    --ssl \
    --prefix="$pkgdir/usr" \
    --disable-warnings-as-errors \
    --sharedclient \
    --cpppath=/usr/include/openssl-1.0 \
    --libpath=/usr/lib/openssl-1.0 \
    install
}

lsr commented on 2018-01-11 07:32

Patch to fix PKGBUILD to use openssl-1.0:

--- /tmp/yaourt-tmp-user/aur-mongo-cxx-driver-legacy/PKGBUILD       2018-01-11 09:14:12.313143011 +0200
+++ PKGBUILD    2018-01-11 09:29:59.212768439 +0200
@@ -10,8 +10,8 @@
 arch=('i686' 'x86_64')
 url='http://www.mongodb.org'
 license=(APACHE)
-depends=('boost-libs' 'openssl' 'libsasl')
-makedepends=('scons' 'boost' 'readline')
+depends=('boost-libs' 'libsasl' 'openssl-1.0')
+makedepends=('scons' 'boost' 'readline' 'openssl-1.0')
 source=("https://github.com/mongodb/${_pkg}/archive/${_subpkg}-${pkgver//_/-}.tar.gz")
 conflicts=("mongodb<2.6.0")
 options=("staticlibs")
@@ -27,5 +27,7 @@
     --prefix="$pkgdir/usr" \
     --disable-warnings-as-errors \
     --sharedclient \
+    --cpppath=/usr/include/openssl-1.0 \
+    --libpath=/usr/lib/openssl-1.0 \
     install
 }

mrohnstock commented on 2015-02-13 06:59

ATTENTION FOR C++11 USERS:

If you want to use this driver for a project which gets compiled with c++11 features enabled (-std=c++11), you have to add --c++11 flag to scons, otherwise intialize the driver will crash with segmentation fault (see https://jira.mongodb.org/browse/CXX-458).

I can't enable this flag by default, because your project has to compile with -std=c++11, too. I could create an other package for reflecting this issue, if someone ask for it.

Otherwise current develop-branch of this driver is for c++11 only, but will take some time until it's usable (at least for testing).

mrohnstock commented on 2015-01-29 08:46

changes 1.0.0-2 -> 1.0.0-3: removed ncurses as dependency

Hi tbrock,

I know, but if the user has mongodb<2.6.0 package from archlinux installed, he won't be able to install this package, because of the conflict with the provided driver in mongodb package before 2.6.0.

That this driver will actually work with mongodb >= 2.0.0 has nothing to do with the package conflict.

Hope you understand the reason.

tbrock commented on 2015-01-29 08:21

Hey monty,

We actually test the legacy driver for use with MongoDB all the way back to 2.2 (although it should also work with 2.0 we simply don't test it). You can see this on the RHEL 5.5 builder here: https://mci.10gen.com/waterfall/mongodb-cpp-driver#/filter//

Also we don't depend on ncurses.

mrohnstock commented on 2015-01-29 07:07

changes 1.0.0-1 -> 1.0.0-2: revert conflict with mongodb<2.0.0, this package will actually conflict with archlinux mongodb package before 2.6.0.

Before 2.6.0 archlinux packages provides the c++-driver, which would conflict with library files provided by this package.

mrohnstock commented on 2015-01-29 06:46

changes 1.0.0_rc4-1 -> 1.0.0-1: Upstream update

mrohnstock commented on 2015-01-26 07:16

changes 1.0.0_rc3-1 -> 1.0.0_rc4-1: Upstream update

mrohnstock commented on 2014-12-22 06:56

changes 1.0.0_rc2-1 -> 1.0.0_rc3-1: Upstream update

mrohnstock commented on 2014-11-14 06:34

changes 1.0.0_rc1-1 -> 1.0.0_rc2-1: Upstream update