Package Details: mongrel2 1.11.0-1

Git Clone URL: https://aur.archlinux.org/mongrel2.git (read-only)
Package Base: mongrel2
Description: Application, language, and network architecture agnostic web server
Upstream URL: http://mongrel2.org
Licenses: BSD
Submitter: manveru
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 11
Popularity: 0.000001
First Submitted: 2010-07-31 11:24
Last Updated: 2016-05-16 08:57

Latest Comments

kimiamania commented on 2015-10-20 10:11

Repo has been moved to https://github.com/mongrel2/mongrel2. Could you please update it ? Thanks!

codekoala commented on 2013-09-18 21:42

There's a 1.8.1 hotfix merged into master now. Also, there are some uses of ${gitname} instead of ${_gitname} in the PKGBUILD that cause build problems.

I'm getting a weird error while building after fixing some stuff in the PKGBUILD:

sh ./tests/runtests.sh
Running unit tests:
tests/bstr_tests PASS
tests/cache_tests PASS
ERROR in test tests/config_tests:
----
RUNNING: ./tests/config_tests
FAILED: Failed to load the right number of mimetypes.
Tests run: 1
make[2]: *** [tests] Error 1
make[2]: Leaving directory `/home/wheaties/repos/build/mongrel2/src/v1.8.0-build'
make[1]: *** [../../build/libm2.a] Error 2
make[1]: Leaving directory `/home/wheaties/repos/build/mongrel2/src/v1.8.0-build/tools/m2sh'
make: *** [m2sh] Error 2


Any ideas?

Anonymous comment on 2013-04-07 16:32

Updated PKGBUILD to new style and GIT the package branch instead of downloading the tarball.

Anonymous comment on 2013-04-07 08:42

If possible, please update this package to the new PKGBUILD style (splitting build() and package() steps).
I've posted a rough conversion at: https://gist.github.com/gvialetto/5329598

Anonymous comment on 2012-12-13 02:55

Updated to version 1.8.0.

galdor commented on 2012-08-23 07:11

This package is _not_ out-of-date. http://mongrel2.org still indicates that the 1.7.5 version is the last release available.

galdor commented on 2012-02-07 21:20

Thank you for the tips :)
I updated the package.

vimes656 commented on 2012-02-07 17:18

I had some issues building this package because of the startdir variable, which is deprecated (https://wiki.archlinux.org/index.php/Creating_Packages#Defining_PKGBUILD_variables). I replaced it with the srcdir and pkgdir variables: http://paste.pocoo.org/show/547343/

galdor commented on 2011-07-17 11:12

Updated to 1.7.5.

galdor commented on 2011-06-12 18:58

Updated to 1.7.3.

All comments