Package Details: monodevelop-bin 7.8.4.1_0xamarin6_ubuntu1804b1-2

Git Clone URL: https://aur.archlinux.org/monodevelop-bin.git (read-only, click to copy)
Package Base: monodevelop-bin
Description: MonoDevelop is a GNOME IDE primarily designed for C# and other CLI (.NET) languages
Upstream URL: https://github.com/mono/monodevelop
Licenses: MIT
Conflicts: monodevelop
Provides: monodevelop
Submitter: SolarAquarion
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 8
Popularity: 0.49
First Submitted: 2019-08-26 03:11
Last Updated: 2020-04-08 12:46

Dependencies (3)

Required by (6)

Sources (1)

Latest Comments

sum01 commented on 2020-09-06 01:25

mono-msbuild is a required dependency to create projects. The program does start without it, but you cannot actually make anything without this dependency. See https://github.com/mono/monodevelop/issues/6684

Peredo commented on 2020-07-25 18:39

Thank you!

warwickmm commented on 2020-07-03 22:35

Is gtk-sharp-3 really a required dependency? I was having issues elsewhere on my system when gtk-sharp-3 is installed. After I removed gtk-sharp-3 from the PKGBUILD dependencies, monodevelop still seemed to work without any issues.

palein commented on 2020-05-18 21:26

Outdated binary. Compiling any program with this version requires dotnet core 1.1 which is outdated and can't be build.

erayerdin commented on 2020-03-29 23:20

Alright, the issue is solved.


A temporary solution (I hope maintainer will fix it) is to do the steps below. Also have yay and nano (or a text editor of your choice) installed, otherwise, your installation process might differ.

  1. Install gtk-sharp-2 and gtk-sharp-3 packages as I've told you. I don't know if this fixes the issue but better be safe than sorry.

  2. Then do yay -S monodevelop-bin --editmenu --mflags --skipinteg. What this does it to enable editing PKGBUILD on the run and skip integration checking. Integration checks are usually needed but I suppose you trust your government, ISP or network in this case (so they won't inject arbitrary code into the package you download).

  3. If you have tried to install the package before, you probably have your build cached. yay will ask you to cleanBuild. Simply press 1 and clean the build or it will use the previous build and it won't work.

  4. When you come to "Edit PKGBUILD" step, say yes, type nano (or your editor choice). This will open up the editor. If you do not know how to use nano, google it. It's the simplest terminal editor to use.

  5. When your editor opens up, as hussam says, change arm64.deb bit to amd64.deb. I have checked the URL, they have the package.

  6. Save and exit the editor. Then, it will install the package.

You will then finally be able to launch monodevelop. Hope this helps.

erayerdin commented on 2020-03-29 23:04

Running "sudo pacman -S gtk-sharp-2 gtk-sharp-3" on Manjaro will resolve sudden exit, yet it still hangs there and will not launch.

hussam commented on 2020-02-18 17:48

That's expected. He is using the arm64 bit binary. source=("monodevelop-amd64-v${_pkgver}.deb::http://download.mono-project.com/repo/ubuntu/pool/main/m/monodevelop/monodevelop_7.8.4.1-0xamarin6+ubuntu1804b1_arm64.deb") You want the amd64 binary instead.

notfood commented on 2020-02-18 16:53

Is it launching for anyone else? Running monodevelop just exits with no error for me.

rrprabhu commented on 2020-02-08 23:37

Is this package working?

SolarAquarion commented on 2019-12-20 13:51

There's no new package in the bin directory