Package Details: mopidy-git 1.1.1.r120.gcc3ec5e-1

Git Clone URL: https://aur.archlinux.org/mopidy-git.git (read-only)
Package Base: mopidy-git
Description: A music server which can play music from Spotify
Upstream URL: http://www.mopidy.com
Licenses: Apache
Conflicts: mopidy
Provides: mopidy=1.1.1.r120.gcc3ec5e-1
Submitter: None
Maintainer: Freso
Last Packager: Freso
Votes: 23
Popularity: 0.708697
First Submitted: 2010-11-30 07:41
Last Updated: 2015-11-23 13:34

Required by (35)

Sources (3)

Latest Comments

halycon commented on 2015-11-23 08:47

Mopidy also depends upon python2-requests. Thanks!

Dabbeljoe commented on 2014-08-09 08:36

I think there should be a bit more information in the PKGBUILD. I too had problems installing mopidy-spotify with mopidy-git, because it couldn't find the dependency "mopidy".

Turns out mopidy-spotify is looking for a specific version of mopidy, and since a version number is not present in "provides" in mopidy-git, it couldn't find it. When I changed the line in PKGBUILD to: "provides=('mopidy=0.19.3')", everything was well again.

Explanation here: https://wiki.archlinux.org/index.php/PKGBUILD#provides

Freso commented on 2014-08-06 10:26

Updated the PKGBUILD with the updated HTTP frontend optional dependency.

@facunditito:
1) mopidy-git has "provided" mopidy since before I took over the package, so since before November last year.
2) Whenever you install this package, you will get the latest version from the git repository and makepkg will use the pkgver() function to update your local package's version accordingly. There's no need for me (or anyone else) to manually update the package version whenever someone does a new commit.

facunditito commented on 2014-07-29 13:07

Hi Freso, I see than you're the new package's mantainer. Please, update the PKGBUILD with the new package version and update the dependencies.

And please, do that Alex2101 said in the page of mopidy-spotify package :

"(...) In mopidy-git PKGBUILD, you should add provides=('mopidy'). Then this will allow all extension to work to with mopidy-git without updating all of them."

Thanks

facunditito commented on 2014-07-28 17:50

Hi Freso, I see than you're the new package's mantainer. Please, update the PKGBUILD with the new package version and update the dependencies. Thanks

drizz commented on 2014-07-28 15:31

mopidy also depends on 'python2-tornado>=2.3'.

Freso commented on 2013-11-06 22:44

If you don't want to update the package anymore, you should disown it, so other people who are still interested in using the latest development version of this, can update the package.

trygveaa commented on 2013-10-31 00:51

Sorry for the absence. Now that a non-git version has been released, I will recommend using that instead (https://aur.archlinux.org/packages/mopidy/). Therefore, I will not update this package.

butler360 commented on 2013-10-07 06:51

Still getting the continuous update prompts.

geekmiki commented on 2013-09-02 16:55

Hi,

It's almost been a month since the package was updated last time. Do you think you can implement the changes in the PKGBUILD now both for mopidy-git and pyspotify-git?

Thank you in advance!

All comments