Package Details: mopidy-git 2.1.0.r38.g33856830-1

Git Clone URL: (read-only)
Package Base: mopidy-git
Description: An extensible music server written in Python
Upstream URL:
Licenses: Apache
Conflicts: mopidy
Provides: mopidy=2.1.0.r38.g33856830-1
Submitter: None
Maintainer: gemaputr
Last Packager: gemaputr
Votes: 23
Popularity: 0.000093
First Submitted: 2010-11-30 07:41
Last Updated: 2017-07-31 17:51

Required by (39)

Sources (3)

Latest Comments

trygveaa commented on 2017-07-10 13:28

It should rather depend on gst-python2, which is required and depends on python2-gobject. With that the dependency on python2-gobject is superfluous. This should replace the dependency on gst-python, since mopidy doesn't support python 3 yet, and gst-python (without 2) is only for python 3.

taylorjoshua88 commented on 2017-07-08 02:18

python2-gobject should be added as a dependency. I had to do a bit of Googling to figure that out when mopidy wouldn't start complaining about not being able to find the 'gi' module.

halycon commented on 2015-11-23 08:47

Mopidy also depends upon python2-requests. Thanks!

Dabbeljoe commented on 2014-08-09 08:36

I think there should be a bit more information in the PKGBUILD. I too had problems installing mopidy-spotify with mopidy-git, because it couldn't find the dependency "mopidy".

Turns out mopidy-spotify is looking for a specific version of mopidy, and since a version number is not present in "provides" in mopidy-git, it couldn't find it. When I changed the line in PKGBUILD to: "provides=('mopidy=0.19.3')", everything was well again.

Explanation here:

Freso commented on 2014-08-06 10:26

Updated the PKGBUILD with the updated HTTP frontend optional dependency.

1) mopidy-git has "provided" mopidy since before I took over the package, so since before November last year.
2) Whenever you install this package, you will get the latest version from the git repository and makepkg will use the pkgver() function to update your local package's version accordingly. There's no need for me (or anyone else) to manually update the package version whenever someone does a new commit.

facunditito commented on 2014-07-29 13:07

Hi Freso, I see than you're the new package's mantainer. Please, update the PKGBUILD with the new package version and update the dependencies.

And please, do that Alex2101 said in the page of mopidy-spotify package :

"(...) In mopidy-git PKGBUILD, you should add provides=('mopidy'). Then this will allow all extension to work to with mopidy-git without updating all of them."


facunditito commented on 2014-07-28 17:50

Hi Freso, I see than you're the new package's mantainer. Please, update the PKGBUILD with the new package version and update the dependencies. Thanks

drizz commented on 2014-07-28 15:31

mopidy also depends on 'python2-tornado>=2.3'.

Freso commented on 2013-11-06 22:44

If you don't want to update the package anymore, you should disown it, so other people who are still interested in using the latest development version of this, can update the package.

trygveaa commented on 2013-10-31 00:51

Sorry for the absence. Now that a non-git version has been released, I will recommend using that instead ( Therefore, I will not update this package.

butler360 commented on 2013-10-07 06:51

Still getting the continuous update prompts.

geekmiki commented on 2013-09-02 16:55


It's almost been a month since the package was updated last time. Do you think you can implement the changes in the PKGBUILD now both for mopidy-git and pyspotify-git?

Thank you in advance!

trygveaa commented on 2013-08-15 21:32

Hmm, the problem is that if it is changed, then the persons with the old version will never receive the upgrade from yaourt/packer.

Though, I guess there is no better solution, so I will have to change it, but I think I will wait until some more have upgraded.

geekmiki commented on 2013-08-15 21:23

version in PKGBUILD needs to be updated
from pkgver=20130807
to pkgver=

Otherwise, yaourt/packer prompt for an update continuously.

trygveaa commented on 2013-08-10 11:35

It is provided by

Although, maybe a -git-package should depend on -git-packages.

trygveaa commented on 2013-08-10 11:33

It is provided by

Rasi commented on 2013-08-10 11:29

Optional dependencies for mopidy-git
python2-cherrypy: HTTP frontend
python2-ws4py: HTTP frontend

the latter does not exist...

trygveaa commented on 2013-08-06 23:44

Updated after Alex2101' and alzeih's comments.

alzeih commented on 2013-08-06 13:15

I think it also needs gstreamer0.10-ugly-plugins as a dependency for mp3 support - some of the tests fail without it.

alzeih commented on 2013-08-04 05:29

Updated files:
mopidy@.service: (thanks Alex2101)

alzeih commented on 2013-08-04 05:27

Updated files:
mopidy@.service: (thanks @Alex2101)

AlexandrePTJ commented on 2013-05-30 06:16

Hi here is systemd unit for mopidy : mopidy@.service
Starts with : systemctl start mopidy@<user>


ExecStart=/usr/bin/mopidy &


jodal commented on 2013-04-29 11:35

As of Mopidy 0.14 a dependency on python2-distribute is needed.

chmurli commented on 2013-04-02 21:55

thanks! I think proper requirement should be added to pkgbuild, even if pykka is outdated. I posted pkgbuild for python2-pykka 1.1.0

jodal commented on 2013-04-02 21:32

The python2-pykka dependency must be updated to >= 1.1.

chmurli commented on 2013-04-02 21:01

I cannot start mopidy:

Traceback (most recent call last):
File "/usr/bin/mopidy", line 4, in <module>
from mopidy.__main__ import main
File "/usr/lib/python2.7/site-packages/mopidy/", line 12, in <module>
import pykka.debug
ImportError: No module named debug

trygveaa commented on 2013-02-10 19:27

This package now pulls from master, since develop is broken at the moment. I also added some optional dependencies.

grine commented on 2013-01-25 14:49

Imo this package should pull from the master branch instead of develop. Develop is broken right now and it's pretty annoying.

For now it's simple to change the branch by editing in -b master in the PKGBUILD git clone line.

Shugyousha commented on 2013-01-14 18:28

The dependency 'pyspotify-git' has to be >=0.9 in order for mopidy to work. Thought I mention it because mine was out-of-date and caused a crash.

trygveaa commented on 2012-12-15 21:53

Can you add these optional dependencies?
optdepends=('python2-cherrypy: HTTP frontend'
'python2-ws4py: HTTP frontend'
'python2-pylast: frontend')

Also, git should be added as a makedepend and you should add the license:
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"

jcerdan commented on 2012-11-21 14:47

Does anyone know of python-indicate package to make modipy available through pnp?
I've been looking but couldn't found anything...

jodal commented on 2012-11-06 11:15

It's only an optional dependency of Mopidy, but since it's already packaged and quite small, you might consider adding python2-pylast as a dependency.

Anonymous comment on 2012-02-19 18:20

Added gstreamer0.10-base-plugins dependency.

jodal commented on 2012-02-14 22:26

I assumed -good-plugins would depend on -base-plugins, but it only depends on -good, which depends on -base. So yes, -base-plugins should be added as a dependency.

Anonymous comment on 2012-02-14 22:22

I had some troubles getting Mopidy to work properly. Playing a track caused a "Failed to find a supported audio sink" error message to pop-up and no sound. Installing gstreamer0.10-base-plugins resolved the issue.

Anonymous comment on 2011-11-28 09:10

Updated package dependencies according to jodal's recommendations.

jodal commented on 2011-11-24 21:21

Also, python-pyalsaaudio may be removed or changed to an optional dependency. It was used for audio output during initial development, but is currently only used for a non-default audio mixer.

jodal commented on 2011-11-24 21:11

Hi, I'm the upstream author of this package.

Could you add gstreamer0.10-good to the list of dependencies? I've had a couple of Arch Linux users struggling with sound issues because they've been missing the gstreamer0.10-good package and the autoaudiosink Gstreamer sink it comes with.


Anonymous comment on 2011-08-24 07:56

Why was this flagged out of date? It's a git package...

Anonymous comment on 2011-05-05 09:05

There is a known problem with playlists in mopidy, see .

Anonymous comment on 2011-04-18 14:40

does this work for you? I've tried a few clients and none seem to work. I can see the client connection to mopidy but that's about it, can't view playlists etc.

Anonymous comment on 2011-04-05 07:15

I have added python2-pykka as a dependency now.

Anonymous comment on 2011-04-04 22:00

New version requires python2-pykka as a dependency.