Package Details: mozvoikko 2.2-1

Git Clone URL: https://aur.archlinux.org/mozvoikko.git (read-only)
Package Base: mozvoikko
Description: Finnish spell-checker extension for Firefox/thunderbird/seamonkey using Voikko
Upstream URL: http://voikko.sourceforge.net
Licenses: GPL2
Submitter: None
Maintainer: Huulivoide
Last Packager: Huulivoide
Votes: 6
Popularity: 0.000711
First Submitted: 2009-10-01 15:21
Last Updated: 2015-12-15 21:08

Latest Comments

sumt commented on 2015-12-16 05:12

With Firefox 43.0 Mozvoikko is detected as unsigned and cannot be enabled. If it is installed using the web page at [1] it is usable. What could be the problem here? Do you have the same?
[1]: http://voikko.puimula.org/sources.html

Pohjoistuuli commented on 2014-03-15 14:30

Minulla oli samanlaiset ongelmat kuin käyttäjä dlandau. Sitten olen asentannut vielä paketit 'malaga' ja 'suomi-malaga-voikko'. Tämän jälkeen Firefox ja Thunderbird alkoivat toimia mozvoikko-pluginilla. Kannattaisi ehkä tarkistaa riippuvuudet (myös libvoikkolta?!). Muuten: kiitos hyvästä työstä!

dlandau commented on 2013-12-13 01:41

Tämän asentamisen jälkeen Firefox alkoi kaatuilla (segmentation fault, paha merkki) useammin ja useammin kunnes lopulta Firefox kaatui suoraan käynnistyessä. Tässä vaiheessa selvitin asiaa ja paikallistin ongelman mozvoikkoon.

pekka commented on 2013-03-17 10:39

vielä yksi 2.12.1 jäljellä
mkdir -p "${pkgdir}/usr/lib/seamonkey-2.12.1/extensions/"


pekka commented on 2013-03-15 21:47

Ei toimi thunderbirdissä,tekee väärän sympolisen linkin.
/tmp/yaourt-tmp-root/aur-mozvoikko/pkg/usr/lib/firefox/extensions/{b676e3ff-cda7-4e0c-b2b8-74e4bb40a67a}

poistin ensimmäisen ${pkgdir}
ln -s "/usr/lib/firefox/extensions/${_UUID}" "${pkgdir}/usr/lib/thunderbird/extensions/${_UUID}"
niin rupes toimiin ,onko sitten oikea tapa korjata ??

Seamonkey hakemisto ja linkki versiolle 2.12.1 ??

Huulivoide commented on 2012-01-09 05:21

Nonniin, nyt toimii taas muutki kielet kuvvaan suoami
mie luulin et se on firefoxis joku vika, en ois koskaan
uskonu et so vois olla voikko syypäänä. Mu nyt toimii taas.

jtts commented on 2012-01-08 23:21

Tässä PKGBUILD mozvoikon versiolle 2.0.1:

http://pastebin.com/eXWDJhzX

jtts commented on 2012-01-08 23:09

Jaaha, ongelma onkin jo korjattu mozvoikon 2.0.1 -versiossa.

jtts commented on 2012-01-08 23:01

Jostain syystä mozvoikkon ollessa asennettuna en voi vaihtaa Firefoxissa oikoluvun kieltä, vaan se on aina suomi. Onko vika mozvoikossa yleensä, vai vain ArchLinuxissa?

jtts commented on 2011-12-21 16:23

Jaahas, unohtui päivittää nuo versioriippuvuudet tuosta PKGBUILDista.

Tässä korjattu versio:

http://pastebin.com/dn6kZhYH

jtts commented on 2011-12-21 16:15

Firefoxin versio 9 on ilmestynyt, ja mozvoikko on "epäyhteensopiva" sen kanssa.

Uusi PKGBUILD:
http://pastebin.com/7wAhdZ7T

Patch joka tekee mozvoikosta "yhteensopivan" firefoxin version 9 kanssa:
http://pastebin.com/5ci0dCAR

Huulivoide commented on 2011-11-09 18:18

Joo firefox oli aiemmin kansiossa /usr/lib/firefox-VERSIO/
Mu just nyt ton 8 version myötä on siirrytty /usr/lib/firefox/
rakenteeseen :D

jtts commented on 2011-11-09 18:15

Joo, nyt toimii!

Itselläni mozvoikon version 2.0-1:n kanssa ei Firefoxin päivityksen yhteydessä tuossa listassa oli kyllä muut lisäosat mutta ei mozvoikkoa. Mutta versio 2.0-2 toimii, ja sen asennuksen jälkeen tuli juuri tuo ilmoitus, että otetaanko asennettu lisäosa käyttöön.

Kiitos pikaisesta korjauksesta!

Huulivoide commented on 2011-11-09 15:24

Nyti onmpi korjattu, tulevausuudessa ei tarvi päivittää sit jokakerta
ku Firefox päivittyy, kiitos muutosten Archin firefox paketin uuden
kansiorakenteen.

Suosittelen ehottomasti tän paketin käyttöö koska tää vie tilaa vaan
100Kt toisinku toi tol sivul oleva joka vie 9.2Mt tilaa ja jonka
joka käyttäjä joutuu asentaan erikseen. Toiseks se saattaa sisältää
vanhentuneet versiot libvoikko kirjastosta ha sanastoista..... koska
99% todennäköisyydellä toi paketti tehään ubuntulla, niin se voi olla
hyvn että se ei ees toimis sit joskus Archissa ku tulee johonko kirjastoon
joku päivitys. Ja muuteski se siis hei asentaa samalla myos Mac ja
Windows versiot siit yfffff.....

Itselläni Firefoxin päivitys otti liitännäisen pois päältä ja piti pistää
uudelleen päälle se, samalla lailla ku suomenkielen pakettikin.....

jtts commented on 2011-11-08 23:45

Tämä AUR:ssa oleva mozvoikko ei ainakaan minulla toiminut Firefox 8:n kanssa, mutta sen sijaan addons.mozilla.org:ssa oleva Suomen kielen oikolukusanasto on ajan tasalla ja toimii taas pitkästä aikaa.

Huulivoide commented on 2011-10-12 14:57

http://huulivoide.pp.fi/Arch/mozvoikko2.xpi
tässä ois 2 versio, käyttäkäähän tota siihen asti et keksin
et miten ihmeessä tän uuren version saa asennettuu järjestelmä
laajusisti ja järkevästi..... paketoituu

Huulivoide commented on 2011-09-28 17:09

Niin, taijampa ny jättää sen tekemättä. Katotaan et josko me saahaan se
javascriptil toteutettu versio ulos ennen ku tulee 8 versiojulki FFstä.
Jos ei tu niin sitten päivitän senki tähän sit 8 extraan putkahtaessa

jtts commented on 2011-09-28 16:36

Kiitos pikaisesta paketin päivityksestä. Nyt kun riippuvuus firefoxin versiosta on rajattu koskemaan vain seiskaversioita, niin pitäisikö myös xulrunnerin make-riippuvuus rajata koskemaan vastaavasti xulrunnerin seiskaversioita?

jtts commented on 2011-09-27 22:09

Firefoxin 7-versio on ilmestynyt. Tässä sen kanssa toimiva versio PKGBUILD:sta:

http://pastebin.com/CPaFWE7e

Nostin paketin versionumeron 1.10.0-3:een. Ja koska mozvoikko.config-tiedoston latauslinkki ei toiminut (sen voi tosin ladata käsinkin), niin lisäsin sen kuuluvaksi tarballiin. Tässä myös ko. tiedoston sisältö:

http://pastebin.com/Bi5T4nMD

Huulivoide commented on 2011-08-23 15:44

Fixed. Korjattu tukee 6 sarjan tulihäntää nyti ^^

jtts commented on 2011-08-18 20:27

Nykyinen versio (1.10.0-1) ei käänny Xulrunnerin version 6.0 kanssa.