Package Details: mp3diags-unstable 1.5.02-1

Git Clone URL: https://aur.archlinux.org/mp3diags-unstable.git (read-only, click to copy)
Package Base: mp3diags-unstable
Description: Identify issues with your MP3 files, fix those issues and make other changes
Upstream URL: http://mp3diags.sourceforge.net/
Keywords: audio
Licenses: GPL
Submitter: Harvey
Maintainer: Harvey
Last Packager: Harvey
Votes: 12
Popularity: 0.000729
First Submitted: 2012-05-15 07:13 (UTC)
Last Updated: 2021-09-01 20:25 (UTC)

Latest Comments

Harvey commented on 2021-09-01 20:26 (UTC)

New version 1.5.02 fixes compile errors.

Harvey commented on 2021-09-01 16:50 (UTC)

MP3Diags (unstable) does not compile on archlinux atm because of the standard compiler flags. To compile the program temporarily disable [-Werror=format-security] in /etc/makepkg.conf CFLAGS. A new release will be coming soon to address this (and some other) errors.

Harvey commented on 2021-08-26 15:47 (UTC)

MP3Diags (unstable) does not compile on archlinux anymore because of the standard compiler flags. The make process throws the following error: Mp3TransformThread.cpp:679:15: error: format not a string literal and no format arguments [-Werror=format-security] Temporarily disabling this in CFLAGS fixes the error and the program compiles again. Seems there is a format error in Mp3TransformThread.cpp but it is beyond my scope to find out where...

Harvey commented on 2019-10-08 06:30 (UTC)

@nirnakinho: this is what I assumed. Thank you for testing. Just pushed a new -2 release without translations section.

nirnakinho commented on 2019-10-07 15:44 (UTC)

Just did a new build. Only English language is available.

Harvey commented on 2019-10-05 12:59 (UTC)

@nirnakinho: I see the build failure but as far as I see there is only english language available in the program. So I tend to remove the translations section from the PKGBUILD and avoid bringing in an unneeded makedep. Just in case: do you see any other languages than english when building with qt5-tools?

Harvey commented on 2019-10-02 12:20 (UTC)

@mocambo: I don't want to support anything else than Archlinux. Editing the PKGBUILD to reflect working builds under i686 enforces me to provide patches if builds do not work anymore on i686 which is possible at any time... If it comes down to editing the PKGBUILD and set arch=("i686") then I hope any user can do this by himself and try if it works. Other opinions?

mocambo commented on 2019-10-02 00:16 (UTC)

Compiles well also on 32-bit Manjaro. So please add "i686" to PKGBUILD. Some 32-bit distros (e.g. Archlinux 32) still depend on AUR. Thanks !

nirnakinho commented on 2019-08-13 09:21 (UTC)

please add qt5-tools as a makedep, otherwise the build will fail during the making translations phase. Thank you.

Regards,

Harvey commented on 2019-04-29 10:07 (UTC)

Update to Version 1.5.01, now ported to qt5

Harvey commented on 2016-08-01 09:29 (UTC)

updated to 1.3.04, no patch needed anymore

Harvey commented on 2016-07-03 17:07 (UTC)

You have to download a snapshot, not only the PKGBUILD. The patch is included there.

yorrd commented on 2016-07-02 10:56 (UTC)

==> Starting build()... /tmp/yaourt-tmp-username/aur-mp3diags-unstable/./PKGBUILD: line 18: ../patch.diff: No such file or directory ==> ERROR: A failure occurred in build(). Aborting... I've already cleared all existing files related to this build

Harvey commented on 2016-06-30 09:00 (UTC) (edited on 2016-06-30 09:01 (UTC) by Harvey)

Thanks to the help of the program author the program compiles again. It failed due to some C++ 11 changes.

Harvey commented on 2016-06-27 11:57 (UTC)

It's not out-of-date... But it doesn't build here as well at the moment. I'm investigating this, but I'm short on time atm. Does anybody have a clue. Must be in some recent arch updates...

jo-shva commented on 2016-06-24 11:51 (UTC)

Does not build, make[2]: Leaving directory '/tmp/makepkg/mp3diags-unstable/src/MP3Diags-unstable-1.3.03/src' make[1]: *** [Makefile:34: release] Error 2 make[1]: Leaving directory '/tmp/makepkg/mp3diags-unstable/src/MP3Diags-unstable-1.3.03/src' make: *** [Makefile:39: sub-src-make_default] Error 2

mocambo commented on 2016-01-10 20:56 (UTC)

Can it be unlinked from boost-libs versioning ? Boost-libs are already updated to 1.60 but mp3diags-unstable searches for 1.58.0. "MP3Diags-unstable: error while loading shared libraries: libboost_serialization.so.1.58.0: cannot open shared object file: No such file or directory". libboost_serialization.so is sufficient.

Harvey commented on 2015-03-22 10:20 (UTC)

updated to 1.3.03

Harvey commented on 2014-07-27 10:20 (UTC)

Update to 1.3.01

Harvey commented on 2014-01-17 10:38 (UTC)

Update to 1.3.0

Harvey commented on 2013-04-07 09:34 (UTC)

Update to 1.2.00. Sorry for the delay - I was on holiday for a few days.

Harvey commented on 2013-03-01 15:29 (UTC)

replaced qt and qmake with qt4 components

Harvey commented on 2012-12-02 10:46 (UTC)

updated to 1.1.21.080. @mrbit: How do you get this information so soon? Is there a mailing list I could add myself to? BTW, flagging out-of-date is enough. I get a notification for this too ;)

mrbit commented on 2012-12-02 08:36 (UTC)

please update 1.1.21 thanks

Harvey commented on 2012-10-20 16:51 (UTC)

Updated to 1.1.20.077. Boy, you are fast ;)

mrbit commented on 2012-10-20 13:52 (UTC)

please update 1.1.29.077 thanks