Package Details: mp4joiner 3.8-2

Git Clone URL: https://aur.archlinux.org/mp4joiner.git (read-only, click to copy)
Package Base: mp4joiner
Description: A collection of tools to manipulate MP4 files
Upstream URL: https://www.mp4joiner.org/
Licenses: GPL
Submitter: leledumbo
Maintainer: leledumbo
Last Packager: City-busz
Votes: 4
Popularity: 0.000000
First Submitted: 2015-02-26 17:11 (UTC)
Last Updated: 2020-07-06 10:42 (UTC)

Latest Comments

darkbasic commented on 2022-11-18 09:24 (UTC)

Please change --with-wx-config=/usr/bin/wx-config-gtk3 to --with-wx-config=/usr/bin/wx-config

rafaelff commented on 2022-08-10 13:09 (UTC)

Please remove --with-wx-config=/usr/bin/wx-config-gtk3, otherwise the build fails with:

checking for /usr/bin/wx-config-gtk3... no
configure: error: 
        Please check that wx-config is in path, the directory
        where wxWidgets libraries are installed (returned by
        'wx-config --libs' command) is in LD_LIBRARY_PATH or
        equivalent variable and wxWidgets is version 2.8.7 or above.

Please notice wxwidgets-gtk3 ships wx-config executable, not wx-config-gtk3. This dependency is already satisfied by wxsvg, but the executable name needs to be fixed.

A-KA commented on 2022-07-14 15:25 (UTC)

ffmpeg needs to be added to depends for this to succeed on clean chroot

@dreieck I was having the same issue, but it built fine in a clean chroot

dreieck commented on 2022-01-29 13:58 (UTC) (edited on 2022-01-29 14:00 (UTC) by dreieck)

It refuses to compile for me because it says that wxsvg misses ffmpeg/libav support (and also it issues a warning due to unknown ./configure option --is-lightweight):

Output of ./configure:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/[...]/mp4joiner/src/MP4Tools-3.8/missing: Unknown `--is-lightweight' option
Try `/[...]/mp4joiner/src/MP4Tools-3.8/missing --help' for more information
configure: WARNING: 'missing' script is too old or missing
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
[...]
checking for wx-config... /usr/bin/wx-config-gtk3
checking for wxWidgets version >= 2.8.7... yes (version 3.0.5)
checking for wxWidgets static library... no
checking for LIBAV... yes
checking for libavformat/avformat.h... yes
checking for wxSVG... yes
checking for wxSVG library with ffmpeg/libav support... no
configure: error: 
    MP4Joiner requires the wxSVG library with ffmpeg/libav support.

tnilzon commented on 2019-12-14 21:20 (UTC)

According to mp4joiner home page this package should actually contain two applications, namely: mp4joiner AND mp4splitter.

From the mp4joiner home page:

About MP4Tools is a collection of cross-platform free tools to manipulate MP4 files. It contains following applications:

MP4Joiner is a free application that allows join multiple MP4 files into one without reencoding and without quality loss. MP4Splitter is a free application that allows split a MP4 file in multiple files without reencoding and without quality loss.

leledumbo commented on 2017-09-09 16:27 (UTC)

@annoyingduck: Well... ffmpeg itself is not a direct dependency of this package, but indirectly through wxsvg. That package itself is an AUR package, so you might want to contact its maintainer to ask.

annoyingduck commented on 2017-09-09 16:15 (UTC)

@leledumbo So ffmpeg 0.10 needs to be installed? That package differs from the ffmpeg in the main repo @version 1:3.3.-2 which I have installed. Getting a conflict of the 2. Can the pkgbuild be made to work with the regular ffmpeg?

leledumbo commented on 2017-09-09 16:05 (UTC) (edited on 2017-09-09 16:16 (UTC) by leledumbo)

@annoyingduck: wxsvg dependency was listed until my last commit, because the INSTALL file also no longer mentioned it. Seems like that was the wrong approach, I'll put it back. For ffmpeg-compat, however, pactree gives me this: $ pactree wxsvg | grep ffmpeg ├─ffmpeg ├─ffmpeg0.10 provides ffmpeg-compat EDIT: Done, please retry.

annoyingduck commented on 2017-09-09 14:52 (UTC)

Cannot install due to wxSVG library missing. wxSVG cannot be installed to to missing dependency ffmpeg-compat. ffmpeg compat has 4 different versions. How did you get this to build?