Package Details: mpc-git 0.26-1

Git Clone URL: https://aur.archlinux.org/mpc-git.git (read-only)
Package Base: mpc-git
Description: A minimalist command line interface to MPD
Upstream URL: http://mpd.wikia.com
Licenses: GPL2
Conflicts: mpc
Provides: mpc
Replaces: mpc-svn
Submitter: Slash
Maintainer: Slash
Last Packager: Slash
Votes: 21
Popularity: 0.806802
First Submitted: 2008-09-17 23:58
Last Updated: 2015-06-08 17:49

Dependencies (3)

Required by (4)

Sources (1)

Latest Comments

emeres commented on 2014-09-14 02:19

http://pastebin.com/NfZcUiDx
This adds a feature to mpc of using 'mpc play' to restart a song (seek to 0s) when already playing. Source: http://forum.musicpd.org/viewtopic.php?f=12&t=250

Modification for PKGBUILD: in build()
patch -p 0 < ${srcdir}/command_play.patch

Slash commented on 2014-08-23 01:07

@flu: I made those changes. Although libmpdclient is currently compatible, I don't really know how often compatibility breaks. If anyone has better knowledge on this topic, then I'll change it back if it's going to become a problem.

flu commented on 2014-08-20 17:59

Hello, I updated mpc-git and now the version number string is "v0.26-1", so my AUR helper is asking every time to update. I can survive of course, but it is a bit annoying. Could you please update the pkgver or (probably better) strip the initial "v"? Like:
echo "$(git describe | sed 's/^v//').$(git rev-list --count master)"
or a more general:
echo "$(git describe | sed 's/^release-//; s/-/./g; s/^v//').$(git rev-list --count master)"

Plus, here it is working with libmpdclient from officail repos. Could you strip down "-git"?

Slash commented on 2014-01-17 20:26

Thanks, I updated the PKGBUILD.

flu commented on 2014-01-17 08:45

Updated to standards:
https://privatepaste.com/1114edd43c

test0 commented on 2012-07-04 06:04

I hear some chirping sounds when playing m4a/aac files; the official build of mpd in [extra] does the same, though. Building with ./configure --disable-aac fixes this (mpd uses FFmpeg's AAC support then).

haawda commented on 2011-04-11 20:39

Is this stuff hosted in svn or in git repo? Are both PKGBUILDs needed?