Package Details: mplayer2 20131009-14

Git Clone URL: https://aur.archlinux.org/mplayer2.git (read-only)
Package Base: mplayer2
Description: Advanced general-purpose media player. A fork of the original MPlayer project
Upstream URL: https://github.com/nezumisama/mplayer2
Keywords: media player video
Licenses: GPL
Conflicts: mplayer
Provides: mplayer
Submitter: Barthalion
Maintainer: applebloom
Last Packager: applebloom
Votes: 49
Popularity: 0.000038
First Submitted: 2013-10-04 10:30
Last Updated: 2018-11-11 19:41

Dependencies (42)

Required by (139)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Barthalion commented on 2014-02-25 10:01

lockheed: It *does* build normally if you use clean chroot. Mesa-libgl is there for a reason and it's not going anywhere.

applebloom: I've just added you to collaborators, I'll contact you later to transfer the package.

applebloom commented on 2014-02-25 09:53

Hey, a repo is a great idea. If you need it, my github account is Nezumisama. I'll be fixing stuff as long as I can for now.

By the way, you can replace "mesa-libgl" with "libgl", so it builds normally for everyone. I had to do it for my desktop with GeForce. Or you could remove that, as OpenGL is auto-detected anyway.

lockheed commented on 2014-02-25 09:48

It compiles and runs just fine without mesa-libgl.

Barthalion commented on 2014-02-25 09:46

Mesa-libgl is a build dependency, not runtime. Please compile packages in clean chroot.

lockheed commented on 2014-02-25 09:36

Please, remove dependency on mesa-libgl as this is not compatible with ATI Catalyst drivers.

Barthalion commented on 2014-02-24 21:26

I collected some patches here: https://github.com/Barthalion/mplayer2

I can give you push access there and in a few weeks pass the package to you.

applebloom commented on 2014-02-24 21:18

No reason really. I use it as one of the last people probably, so I thought about maintaining the package. But if still want, that's great.

Thanks for quick reaction.
I made another patch. After a recent rebuild, I noticed vo=gl complains about an error in a shader. So I inspected and it turns out it was producing floats with "," as the decimal point. Using LANG=C mplayer ... fixed this, so I patched the vo code to produce always "." for all locales.

Here's the file: http://sprunge.us/GGhX

Barthalion commented on 2014-02-24 21:11

Applied your patch, thanks. Any reason why would you take over the package?

applebloom commented on 2014-02-24 18:54

I patched in support for quvi0.9. Here: http://sprunge.us/KFGc

Hey, can I maintain this, by the way?

vinipsmaker commented on 2014-01-20 00:46

Increment the rel variable. The recent update to libcdio forces dependent packages to be recompiled.