Package Details: mprime-bin 289-1

Git Clone URL: https://aur.archlinux.org/mprime-bin.git (read-only)
Package Base: mprime-bin
Description: A GIMPS, distributed computing project client, dedicated to finding Mersenne primes. Precompiled binary version.
Upstream URL: http://www.mersenne.org
Licenses: custom
Conflicts: mprime
Provides: mprime
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 96
Popularity: 0.712018
First Submitted: 2012-01-22 12:11
Last Updated: 2016-04-24 23:01

Latest Comments

graysky commented on 2016-02-10 23:23

@Waifod - Why out of date? http://www.mersenne.org/download/ shown 287 as current.

graysky commented on 2015-08-26 19:58

Bump to v287-1

ubr47k commented on 2015-08-26 11:48

New version released on the forums, website still not updated. Only mprime-bin has been updated.

http://www.mersenneforum.org/showthread.php?t=20156

zer0def commented on 2015-05-29 09:58

On native i686 gcc-libs suffice. In case of running i686 on x86_64, just install gcc-libs-multilib or lib32-gcc-libs.

graysky commented on 2015-05-28 21:38

As to the the comment about multiarch md5sum, yes I can, but the issue with i686 is that it requires extra deps and I do not have an i686 install to test that it works. You are welcome to explore that and let me know at which point, I can update.

graysky commented on 2015-05-28 21:22

Upstream really needs to get their shit together. Dropping back to 286.

sl1pkn07 commented on 2015-05-28 20:18

mprime not found in package()

and you can use the pacman 4.2 sources/checksums multiarch structure

greetings

graysky commented on 2015-05-28 19:18

Bump to v287-1

graysky commented on 2015-05-28 15:09

Bump to v286-1

ubr47k commented on 2015-05-28 05:31

@graysky The most recent version can be found at http://www.mersenneforum.org/showthread.php?t=20156
Binary 64 bit tarball:
ftp://mersenne.org/gimps/p95v286.linux64.tar.gz

graysky commented on 2015-05-27 18:51

I still show 285 as current. Can you point me to a more recent tarball?

ubr47k commented on 2015-05-27 01:53

@graysky I'm sorry, the version was bumped up at the forums a lot earlier than it was on the website when I reported this

ubr47k commented on 2015-05-27 01:48

@graysky I'm sorry, the version was bumped up at the forums a lot earlier than it was on the website when I reported this. It has now been posted to the main page.

graysky commented on 2015-05-08 07:21

@ubr47k - Why out-of-date? 285 is current as far as I can tell.

graysky commented on 2014-06-04 21:30

Bump to v285-1

graysky commented on 2014-06-04 21:28

Bump to v280-1

graysky commented on 2013-12-11 21:19

Note - several of the comments below this one are not appliciable to the 'mprime-bin' package which supplies the precompiled version of mprime. If you're looking for the mprime that you compile from source, search of simply, 'mprime' not 'mprime-bin.'

graysky commented on 2013-12-08 12:42

Bump to v279-4

Changelog: Fixed PKGBUILD omitting lines to files upstream did not include in this version.

kfgz commented on 2013-12-08 11:19

Graysky, fix the license.txt file issue. Please.

felixonmars commented on 2013-12-08 02:20

But I'm building for x86_64 :3

graysky commented on 2013-12-07 17:10

@felix - When I try to build i686, the errors are deeper than that:
==> Starting build()...
...
gcc -I.. -I../gwnum -O2 -march=i486 -malign-double -Wno-unused-result -c menu.c
In file included from prime.h:92:0,
from prime.c:6:
../commonb.h:11:22: fatal error: security.h: No such file or directory
#include "security.h"
^
compilation terminated.
makefile:37: recipe for target 'prime.o' failed
make: *** [prime.o] Error 1
make: *** Waiting for unfinished jobs....
In file included from prime.h:92:0,
from menu.c:7:
../commonb.h:11:22: fatal error: security.h: No such file or directory
#include "security.h"
^
compilation terminated.
[ ! -e ../security.c ] && touch ../security.c || true
makefile:37: recipe for target 'menu.o' failed
make: *** [menu.o] Error 1
[ ! -e ../secure5.c ] && touch ../secure5.c || true
==> ERROR: A failure occurred in build().

felixonmars commented on 2013-12-07 16:28

Missing license.txt failed package() here:

==> Starting package()...
install: cannot stat ‘license.txt’: No such file or directory
==> ERROR: A failure occurred in package().

graysky commented on 2013-12-07 12:04

You are right... I can't get it to build for i686 either. I will remove that arch from the package. Users of i686 should use the mprime-bin package (precompiled by upstream).

yar commented on 2013-12-07 00:55

Works in a clean x86_64 chroot. However, on a clean i686 chroot I am getting the exact same error as @Gooberslot. Perhaps there's a dependency missing?

Anonymous comment on 2013-07-05 12:52

(accidently I deleted my previous comment, sorry about that)
@graysky: thanks, i'll try to build in clean chroot

graysky commented on 2013-07-05 12:04

Dunno what to tell you guys. Builds for me in a clean chroot[1]. Are you sure you have both base and base-devel installed? These are prerequists for building in the AUR[2].

1. https://gist.github.com/graysky2/5934081
2. https://wiki.archlinux.org/index.php/AUR#Prerequisites and https://wiki.archlinux.org/index.php/AUR#Q:_Foo_in_AUR_does_not_compile_when_I_run_makepkg.3B_what_should_I_do.3F

graysky commented on 2013-03-28 22:15

...Why out-of-date, anonymous_user?

graysky commented on 2013-03-28 22:14

...why out-of-date, anonymous_user?

graysky commented on 2012-06-07 01:30

Bump to v277-1

Changelog: The FFT assembly code has been rewritten for better speed on Intel's newer CPUs supporting AVX instructions. Sandy Bridge and Ivy Bridge CPUs (Core i3/i5/i7-2xxx and 3xxx models) should see a huge performance increase. To upgrade, simply exit Prime95, download the new version, and unzip the new version replacing the old version.

graysky commented on 2012-06-07 01:30

Bump to v277-1

Changelog: The FFT assembly code has been rewritten for better speed on Intel's newer CPUs supporting AVX instructions. Sandy Bridge and Ivy Bridge CPUs (Core i3/i5/i7-2xxx and 3xxx models) should see a huge performance increase. To upgrade, simply exit Prime95, download the new version, and unzip the new version replacing the old version.

graysky commented on 2012-06-06 01:11

@Goob-odd, builds fine for me. Have you tried building in a clean chroot?

Gooberslot commented on 2012-06-04 11:13

This won't build for me. This is the last bit of the output before it fails:

/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libc.a(setitimer.o)
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libc.a(profil.o) (__setitimer)
/usr/bin/ld: cannot find -lgcc_s
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libcurl.a(libcurl_la-netrc.o): In function `Curl_parsenetrc':
(.text+0x346): warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libcurl.a(libcurl_la-curl_addrinfo.o): In function `Curl_getaddrinfo_ex':
(.text+0x81): warning: Using 'getaddrinfo' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
prime.o: In function `pnHttpServer':
prime.c:(.text+0x191c7): warning: Using 'gethostbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/bin/ld: cannot find -lgcc_s
collect2: error: ld returned 1 exit status
make: *** [mprime] Error 1
==> ERROR: A failure occurred in build().
Aborting...

graysky commented on 2012-02-04 11:36

@erg - you want mprime-bin which contains "their" executable which is the only one that works with their servers. When you compile from source as in this pkg, their servers reject your usage perhaps to battle folks hacking the code.

Anonymous comment on 2012-02-02 02:32

I built two computers with the same specs. On the first one, I installed mprime 266-1 a few weeks ago. Now today, I installed mprime 266-2 and it's broken.

erg@ommegang /tmp $ cat prime.log.broken
[Thu Feb 2 02:15:10 2012 - ver 26.6]
Updating computer information on the server
PrimeNet error 7: Invalid parameter
parameter ss: Invalid int value/precision ''

Thanks.

graysky commented on 2012-01-22 12:10

They are statically linked. Good call, kfgz. Note that I am now maintaining two mprime packages:

1) mprime = build from source.
2) mprime-bin = uses pre-compiled binary.

slopjong commented on 2012-01-22 02:20

@kfgz, in mprime's makefile I've found LIBS = ... $(shell pkg-config --static --libs libcurl) ... doesn't this mean that it's still a dependency?

kfgz commented on 2012-01-21 16:50

It looks like that libcurl3 is no longer needed as dependency for i686 and curl for x86_84 too. But maybe I'am mistaken.

graysky commented on 2011-04-23 19:52

Updated to 266

Anonymous comment on 2011-03-10 00:05

the 2 digit numeric pkgver with _filever were there for a reason so you can remove the force flag, but its too late for that now ;/

Svenstaro commented on 2010-10-17 08:21

Got any issues with me putting this into community?