Package Details: mprime 293-1

Git Clone URL: https://aur.archlinux.org/mprime.git (read-only)
Package Base: mprime
Description: A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
Upstream URL: http://www.mersenne.org
Licenses: custom
Conflicts: mprime-bin
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 43
Popularity: 1.289429
First Submitted: 2013-12-11 21:18
Last Updated: 2017-10-18 19:25

Latest Comments

graysky commented on 2017-10-18 19:22

@sergio - Thanks for that. Will test and update.

sergio.correia commented on 2017-10-18 15:06

@graysky: here's a diff against revision "bc91d9" ("Update to 291-5") that updates it to 293-1: https://gist.github.com/qrwteyrutiyoup/4682d87516b1199fc424212ed8b1674f

graysky commented on 2017-10-09 19:24

Modification to the makefile is needed for the 293 release but I am unable to troubleshoot now. Anyone care to investigate?

graysky commented on 2017-05-13 10:41

@cinna - Upstream is to blame for this... it is really annoying.

cinna commented on 2017-05-13 08:22

Is there a reason why the checksum keeps changing for the same version? Checksum is now "b2af302d423765e1f053731f4c0dac6983a9598eb1b16fcf6159491dbb1c3972"

jugs commented on 2017-04-08 18:09

Checksum changed again

e5aada84256863882823d08e87495118c4b19e0fa03f3105da4c2fbcd26c6045 p95v291.source.zip

graysky commented on 2017-03-21 18:32

Not sure why the checksum changed from when I built it yesterday. 291-3 fixes that.

gavinhungry commented on 2017-03-21 16:33

@kerberizer, you're not mistaken.

Also, url and source may use SSL for mersenne.org.

kerberizer commented on 2017-03-21 12:28

I might be mistaken, but it seems that the sha256sum of p95v291.source.zip is "a065c0b16de8c6dbfdcf7a8e1e07c9d77cc7dbbdd882ca6f03a62a769fc4a76a".

graysky commented on 2017-03-20 11:19

Upstream needs to update their website (https://www.mersenne.org/download/) which is advertising 2810 as the current... as we sure that 29.1 is considered stable?

graysky commented on 2016-03-10 21:03

@coruun - Good question! Fixed in 287-3, thanks for pointing it out.

coruun commented on 2016-03-10 08:13

Why do you patch gwnum/makefile, while you are actually using gwnum/make64 for compilation?

graysky commented on 2016-02-18 19:10

@ase - All members of base-devel are assumed to be installed when using the AUR.[1]

1. https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

ase1590 commented on 2016-02-18 15:12

Add "patch" as a dependency please.

graysky commented on 2015-09-21 06:29

@firekage - Works for me without any switches and no hung processes. The mprime-bin is packaged with some docs but no formal manpage.

graysky commented on 2015-09-21 06:28

@firekage - Works for me without any switches and no hung processes.

firekage commented on 2015-09-21 03:27

I have one problem, maybe somebody will help me. I installed mprime using aur. For the first time it worked, could do some test and could choose which test to do. After finish i hit the exit in terminal, and after that, as soon as i start mprime again i see that command prompt is being busy but nothing happens, i don't have list with test and choices given at all. What's wrong? I type "mprime" in terminal and it either stops command prompt or give an message: "another mprime is already run" where in fact, there is no a such process at all!

Edit: there is no manpage for mprime. On mprime main website i saw that under linux it should be run wtich a switch: mprime -m.

firekage commented on 2015-09-21 03:07

I have one problem, maybe somebody will help me. I installed mprime using aur. For the first time it worked, could do some test. After finish i hit the exit in terminal, and after that, as soon as i start mprime again i see that command prompt is being busy but nothing happens, i don't have list with test and choices given at all. What's wrong? I type "mprime" in terminal and it either stops command prompt or give an message: "another mprime is already run" where in fact, there is no a such process at all!

firekage commented on 2015-09-21 02:55

I have one problem, maybe somebody will help me. I installed mprime using aur. For the first time it worked, could do some test. After finish i hit the exit in terminal, and after that, as soon as i start mprime again i see that command prompt is being busy but nothing happens, i don't have list with test and choices given at all. What's wrong?

graysky commented on 2015-05-28 19:18

Bump to v287-1

graysky commented on 2015-05-28 15:10

I will update to 286 once upstream fixes their invalid zip archive.

graysky commented on 2014-10-09 04:39

Ha! Got it working again. Enjoy!

graysky commented on 2014-08-13 19:22

Disowned. Maybe someone else with more time and know-how can update.

graysky commented on 2014-06-04 21:34

Gonna need some help getting 285 to build. Please submit changes to the PKGBUILD here.

graysky commented on 2014-02-08 13:44

Builds fine for me as-is. Suggest you delete your source zip and try again.

0x47 commented on 2014-02-07 20:53

sha256sums fails on this package...

graysky commented on 2013-12-21 11:23

Hi Xyne, thanks for the clean up. Actually i686 is supported, I just can't get it to build. Perhaps you can?

Xyne commented on 2013-12-21 01:34

Hi,

I thought the PKGBUILD was a bit messy so I cleaned it up. If i686 is no longer supported (it was commented in your PKGBUILD), then please remove all of the conditional statements.

You can find the package source archive here: http://xyne.archlinux.ca/tmp/pkgbuilds/

Regards,
Xyne