Package Details: mpv-vapoursynth 1:0.28.2-2

Git Clone URL: https://aur.archlinux.org/mpv-vapoursynth.git (read-only)
Package Base: mpv-vapoursynth
Description: Video player based on MPlayer/mplayer2
Upstream URL: http://mpv.io
Licenses: GPL
Conflicts: mpv
Provides: mpv
Submitter: YamashitaRen
Maintainer: SeriousBug
Last Packager: SeriousBug
Votes: 13
Popularity: 0.169825
First Submitted: 2014-11-04 20:57
Last Updated: 2018-06-29 17:23

Dependencies (28)

Required by (95)

Sources (1)

Latest Comments

fyvfy commented on 2018-08-06 16:41

Something is broken (in waflib?).

git clone https://aur.archlinux.org/mvp-vapoursynth.git

cd mpv-vapoursynth

makepkg -sLm

Traceback (most recent call last):

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Node.py", line 295, in ant_iter raise StopIteration

StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Scripting.py", line 120, in waf_entry_point run_commands()

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Scripting.py", line 177, in run_commands parse_options()

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Scripting.py", line 150, in parse_options Context.create_context('options').execute()

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Options.py", line 145, in execute super(OptionsContext,self).execute()

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Context.py", line 88, in execute self.recurse([os.path.dirname(g_module.root_path)])

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Context.py", line 129, in recurse user_function(self)

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/wscript", line 939, in options opt.load('compiler_c')

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Context.py", line 85, in load fun(self)

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Tools/compiler_c.py", line 40, in options opt.load_special_tools('c_*.py',ban=['c_dumbpreproc.py'])

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Context.py", line 319, in load_special_tools lst=self.root.find_node(waf_dir).find_node('waflib/extras').ant_glob(var)

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Node.py", line 344, in ant_glob ret=[x for x in self.ant_iter(accept=accept,pats=[to_pat(incl),to_pat(excl)],maxdepth=kw.get('maxdepth',25),dir=dir,src=src,remove=kw.get('remove',True))]

File "/tmp/aur/mpv-vapoursynth/src/mpv-0.28.2/.waf3-1.9.8-17756245c4cc550633dacf3b08eec42a/waflib/Node.py", line 344, in <listcomp> ret=[x for x in self.ant_iter(accept=accept,pats=[to_pat(incl),to_pat(excl)],maxdepth=kw.get('maxdepth',25),dir=dir,src=src,remove=kw.get('remove',True))]</listcomp>

RuntimeError: generator raised StopIteration

==> ERROR: A failure occurred in build().

Aborting...

SeriousBug commented on 2018-06-29 17:24

Updated the dependencies to match the official package now, thanks.

DroidFreak32 commented on 2018-06-29 17:00

It also requires vulkan-headers package dependency to build :)

Drommer commented on 2018-05-12 22:17

@SeriousBug will you update the package to the current version?

IgniSerpens commented on 2017-11-19 05:08

Thanks a lot! Now it compiles!

IgniSerpens commented on 2017-11-18 14:12

It's so pity. I can't install this package after last update, cause:

[221/486] Compiling video/out/vo_image.c
../video/vaapi.c: В функции «va_initialize»:
../video/vaapi.c:191:5: ошибка: слишком мало аргументов в вызове функции «vaSetErrorCallback»
vaSetErrorCallback(va_error_callback);
^~~~~~~~~~~~~~~~~~
In file included from ../video/vaapi.h:24:0,
from ../video/vaapi.c:22:
/usr/include/va/va.h:270:19: замечание: объявлено здесь
VAMessageCallback vaSetErrorCallback(VADisplay dpy, VAMessageCallback callback, void *user_context);
^~~~~~~~~~~~~~~~~~
../video/vaapi.c:192:5: ошибка: слишком мало аргументов в вызове функции «vaSetInfoCallback»
vaSetInfoCallback(va_info_callback);
^~~~~~~~~~~~~~~~~
In file included from ../video/vaapi.h:24:0,
from ../video/vaapi.c:22:
/usr/include/va/va.h:276:19: замечание: объявлено здесь
VAMessageCallback vaSetInfoCallback(VADisplay dpy, VAMessageCallback callback, void *user_context);
^~~~~~~~~~~~~~~~~

xingxuanma commented on 2017-10-21 02:33

The building needs hardening-wrapper but it has been removed.
https://www.archlinux.org/todo/hardening-wrapper-removal/

YamashitaRen commented on 2015-02-14 09:42

I'm disowning the package because... well... to be honest it's easier to use the -git.
Mpv only need vapoursynth to be found in order to build theses filters.
https://bugs.archlinux.org/task/41729