Package Details: mpv-vittgam 1:0.17.0-9

Git Clone URL: https://aur.archlinux.org/mpv-vittgam.git (read-only)
Package Base: mpv-vittgam
Description: My stable and sensible version of the mpv player that does not make me curse when newer upstream versions break and/or change things at random. :)
Upstream URL: None
Licenses: GPL
Conflicts: mpv
Provides: mpv
Submitter: VittGam
Maintainer: VittGam
Last Packager: VittGam
Votes: 3
Popularity: 0.000006
First Submitted: 2016-12-09 02:55
Last Updated: 2018-06-22 03:30

Required by (97)

Sources (2)

Latest Comments

1 2 Next › Last »

hamid25 commented on 2018-06-22 04:33

@VittGam Thank you so much, I was waiting :)) I will check it as soon as I can.

VittGam commented on 2018-06-22 03:33

@hamid25 Sorry for the large delay... It's kind of fixed now as it's now using FFmpeg 3.4 from the ffmpeg3.4 AUR package.

hamid25 commented on 2018-05-30 09:35

@VittGam It fails with this error: ‘CODEC_FLAG_PASS2’ undeclared (first use in this function); did you mean ‘AV_CODEC_FLAG_PASS2’?

build log: https://pastebin.com/KTJc20k1

VittGam commented on 2018-05-30 09:19

@hamid25 Changed that one too... Please try again if you want, thank you.

hamid25 commented on 2018-05-30 08:48

I get a similar error to last one. build log: https://pastebin.com/MUHp7tgS

VittGam commented on 2018-05-30 08:40

@hamid25 Please try again now... If it still fails then I'll be able to take a proper look at it later today.

hamid25 commented on 2018-05-30 08:17

Thanks @VittGam, but now I get this error: ‘FF_INPUT_BUFFER_PADDING_SIZE’ undeclared (first use in this function); did you mean ‘AV_INPUT_BUFFER_PADDING_SIZE’?

full build log: https://pastebin.com/uk9Kp0nj

VittGam commented on 2018-05-30 07:59

@hamid25, please try again now. FFmpeg v4.0 has dropped a long-deprecated header file, the one from your build log.

A proper update will be eventually made in the future with regards to the other deprecated (but not yet dropped) things...

hamid25 commented on 2018-05-29 19:25

Hi, I can't make this package. There's no file such as libavfilter/avfiltergraph. Should I use an older version of ffmpeg?

build messages: https://pastebin.com/xmZhrRvu

ffmpeg -version: https://pastebin.com/nVpuirwn

VittGam commented on 2017-01-31 18:43

Yes, the older interface is one of the reasons this package exists; I think it can be restored even in the community version by tweaking the osd configuration files; but why lose time to do it!

One of the main reasons of this package is that the newer mpv versions have a problem with audio randomly jumping backwards sometimes, on older or slower machines. But the mpv developer has expressed on github that they do not have interest in supporting niche configurations (like my older computer or my ARM board are), so...

But I've also experienced random breakage with random features over time, and I just got tired of it. So here it is, an mpv version that's almost frozen in time, when things were working perfectly fine here.