Package Details: mrrescue 1.02e-2

Git Clone URL: https://aur.archlinux.org/mrrescue.git (read-only)
Package Base: mrrescue
Description: An arcade styled 2d action game centered around evacuating civilians from burning buildings.
Upstream URL: http://tangramgames.dk/games/mrrescue/
Keywords: love
Licenses: CCPL:by-sa, zlib
Submitter: pio
Maintainer: MCMic
Last Packager: MCMic
Votes: 9
Popularity: 0.000000
First Submitted: 2013-06-23 02:12
Last Updated: 2019-06-20 22:07

Latest Comments

1 2 Next › Last »

ainola commented on 2015-09-02 02:38

I merged your patch. However, I didn't add the .png as that's an upstream issue that should be resolved. Please open a bug upstream if it bothers you. It's better to use what the package gives us.

You're also a co-maintainer now. I've never actually even played the game, I just saw value in it and moved it over :)

MCMic commented on 2015-09-01 16:51

Yes, I use fish and adding a shebang fixes the problem.
The icon of the game should also be http://tangramgames.dk/img/thumb/mrrescue.png if possible.

carstene1ns commented on 2015-09-01 13:42

ainola: Every script needs a shebang, additionally you should make it executable while installing.
I have fixed this and did some other improvements/cleanups in this patch: http://git.io/vGaNJ
You may use 'git am -s < mrrescue-1.02c-2.patch' to apply it to your AUR4 repository checkout.

ainola commented on 2015-08-31 23:03

MCMic, can you confirm that adding #!/bin/sh to the PKGBUILD fixes it for you? Are you using zsh, fish, or any alternative to bash? Is bash even installed?

MCMic commented on 2015-08-31 22:57

I’m getting:
Failed to execute process '/usr/bin/mrrescue'. Reason:
exec: Exec format error
The file '/usr/bin/mrrescue' is marked as an executable but could not be run by the operating system.

(While downloading the .love and launching it works just fine)
I’d say the launching script is missing a #!/bin/sh to launch correctly.

pio commented on 2014-06-27 22:10

Thanks, updated.

carstene1ns commented on 2014-06-27 03:24

Simon made his old games love 0.9.1 compatible some days ago, so this can depend on 'love' again.

pio commented on 2013-12-23 15:01

Fixed. Thanks for pointing that out.

leo_rockway commented on 2013-12-23 01:16

New LÖVE is 0.9 and it doesn't work with this. /usr/bin/mrrescue needs to be modified so it uses love08 and love08 (from community) needs to be a depends instead of default love.

pio commented on 2013-09-16 15:06

Updated, thank you for info.