Package Details: mssql-tools 17.4.1.1-1

Git Clone URL: https://aur.archlinux.org/mssql-tools.git (read-only, click to copy)
Package Base: mssql-tools
Description: Microsoft® SQL Server® Tools for Linux
Upstream URL: https://www.microsoft.com/en-us/sql-server/sql-server-vnext-including-Linux
Licenses: custom
Submitter: karuna_murti
Maintainer: karuna_murti
Last Packager: karuna_murti
Votes: 18
Popularity: 0.64
First Submitted: 2016-11-18 14:29
Last Updated: 2019-10-09 13:18

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Eremiell commented on 2017-04-29 06:36

diff --git a/PKGBUILD b/PKGBUILD
index 0ac7a20..8ad979e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Karuna Murti <karuna.murti@gmail.com>

pkgname=mssql-tools
-pkgver=14.0.3.0
-pkgrel=5
+pkgver=14.0.5.0
+pkgrel=1
pkgdesc="Microsoft® SQL Server® Tools for Linux"
arch=('x86_64')
url="https://www.microsoft.com/en-us/sql-server/sql-server-vnext-including-Linux"
@@ -12,7 +12,7 @@ depends=('msodbcsql')
makedepends=('patchelf')
options=('!strip')
source=("https://packages.microsoft.com/rhel/7/prod/$pkgname-$pkgver-1.x86_64.rpm")
-sha256sums=('9db9907a8151648d211bd8005c2b87ffebeca9b43c25ee56e9640804a72eaee6')
+sha512sums=('648fbc212d6569362bb1b5c0f11f917c787e5a1eb8b629751b1fb9ff0171e562d69b5c9f139b43e37eb06d027c23046dd2e10e677eecf31e4b2e0e5f4200a5b8')

package() {
cd "$srcdir"

karuna_murti commented on 2017-02-07 13:15

@mtorromeo is fine, thank you :D

mtorromeo commented on 2017-02-07 09:28

There were still many issues, especially with missing linked libraries and other packaging issues.
I updated the PKGBUILD with a reworked version. I hope you don't mind.

karuna_murti commented on 2017-02-07 08:28

Oops. Fixed.

mtorromeo commented on 2017-02-07 08:16

The symlinks in /usr/bin are wrong.
They are pointing to /opt/mssql-tools/bin/sqlcmd-$pkgver and /opt/mssql-tools/bin/bcp-$pkgver but the correct paths are /opt/mssql-tools/bin/sqlcmd and /opt/mssql-tools/bin/bcp.

mtorromeo commented on 2017-02-07 08:07

Nothing, I'll do it.

karuna_murti commented on 2017-02-07 06:36

@mtorromeo updated

flash2k2 commented on 2017-02-07 04:12

mtorromeo:
There were some conflicts with my mssql-server package. So I created separate packages.
I agree to merge them now. What should I do for this?

mtorromeo commented on 2017-02-06 16:34

Any reason to use this "-ubuntu" version over the similar mssql-tools (using rpm packages)?
If you are okay with it I would like to merge mssql-tools-ubuntu into mssql-tools and msodbcsql-ubuntu into msodbcsql

mtorromeo commented on 2017-02-06 16:31

Please update the mssql-msodbcsql dependency to msodbcsql which is the same package.