Package Details: mstflint 4.12.0.1-1

Git Clone URL: https://aur.archlinux.org/mstflint.git (read-only)
Package Base: mstflint
Description: OpenFabrics Alliance firmware burning application for Mellanox HCA/NIC cards (without inband support)
Upstream URL: https://www.openfabrics.org/index.php/overview.html
Licenses: GPL2, custom:"OpenIB.org BSD"
Submitter: twinshadow
Maintainer: jamespharvey20 (nfnty)
Last Packager: jamespharvey20
Votes: 3
Popularity: 0.003473
First Submitted: 2011-12-28 02:51
Last Updated: 2019-06-20 00:58

Pinned Comments

jamespharvey20 commented on 2018-10-13 23:10

This package is without inband support, which eliminates dependency on libibmad.

For inband support, use package mstflint-inband.

Inband support is necessary to update firmware of Mellanox SwitchX and ConnectIB devices.

Latest Comments

1 2 Next › Last »

jamespharvey20 commented on 2019-04-25 10:50

4.11.0.4 is tagged upstream, but they tagged it as a pre-release. I've asked them if that was intentional, seems out of place to me. https://github.com/Mellanox/mstflint/issues/89

jamespharvey20 commented on 2018-12-19 22:11

Upstream released 4.11.0-1, but it fails to compile, at least on current gcc.

Reported upstream: https://github.com/Mellanox/mstflint/issues/27

jamespharvey20 commented on 2018-10-16 02:58

Just pushed 4.10.0.3-1. 4.10.0.2-1 may fail to build, depending on which AUR build method you use. IMO, upstream's packaging style is broken. 4.10.0.3-1 switches from using a release tarball to a git clone with the tag of the release number. Sorry, I didn't catch that because the problem is that compilation would work only if it was within a git tree. I was running beneath a git tree of this AUR repository (maintainers interact with each AUR package through a git repository) so it was avoiding the failure for me.

alexanderp commented on 2018-10-14 10:55

Thanks for the update!

jamespharvey20 commented on 2018-10-13 23:10

This package is without inband support, which eliminates dependency on libibmad.

For inband support, use package mstflint-inband.

Inband support is necessary to update firmware of Mellanox SwitchX and ConnectIB devices.

segfaults commented on 2018-09-16 16:01

Latest version required the following flags added to the build in order to compile: -Wimplicit-fallthrough=0 -Wformat-overflow=0 -Wno-cast-function-type -Wno-class-memaccess -O

vmaffione commented on 2018-04-24 13:46

Hi, Current version does not compile because of warnings treated as errors. I got rid of the warnings adding the following to CFLAGS,CXXFLAGS, and CPPFLAGS:

-Wimplicit-fallthrough=0 -Wformat-overflow=0

ajs124 commented on 2017-11-22 21:08

Updated PKGBUILD for new upstream/version: https://gist.github.com/ajs124/9fde3f9f29e724e9e2c5531bd564e7c5

Note: this currently does not compile, except if my pull request is merged or you point it to my fork.

nightah commented on 2017-10-06 12:26

Inserting: sed -i 's/Werror/Wno-error/g' before the configure line doesn't actually do anything. It will bail out prematurely with an error of "sed: no input files".

ljw1 commented on 2017-10-05 08:47

Package 4.5.0-1 doesn't build due to warnings.

To fix insert this line in PKGBUILD before the configure line.
sed -i 's/Werror/Wno-error/g'