Package Details: mtproxy-git 17.580909c-2

Git Clone URL: https://aur.archlinux.org/mtproxy-git.git (read-only)
Package Base: mtproxy-git
Description: Proxy server for Telegram messaging app
Upstream URL: https://github.com/TelegramMessenger/MTProxy
Licenses: GPLv2, LGPLv2
Submitter: sarum9in
Maintainer: sarum9in
Last Packager: sarum9in
Votes: 4
Popularity: 0.005880
First Submitted: 2018-05-31 12:40
Last Updated: 2018-06-06 10:34

Latest Comments

sarum9in commented on 2018-06-06 10:23

Good catch, thank you.

levitsky commented on 2018-06-06 10:11

The main service fails to start on boot with a dependency error on my VPS:

systemd[1]: Dependency failed for Telegram proxy server.
systemd[1]: mtproxy.service: Job mtproxy.service/start failed with result 'dependency'

The failed dependency is actually mtproxy-config.service, which fails when called because the network is still not configured:

systemd[1]: Starting Updates Telegram configuration...
systemd[1]: mtproxy-config.service: Main process exited, code=exited, status=6/NOTCONFIGURED
systemd[1]: mtproxy-config.service: Failed with result 'exit-code'.
systemd[1]: Failed to start Updates Telegram configuration.

I fixed this by adding

Requires=network-online.target
After=network-online.target

in the mtproxy-config.service file.

sarum9in commented on 2018-06-01 08:54

  1. mtproxy.service, but yes, you are right, I fixed it.
  2. I simply forgot >_<

Thank you for the feedback! Everything you mentioned should be fixed now.

levitsky commented on 2018-05-31 20:06

Thanks for this package! I was just thinking about creating one myself, I like that it has a service and a configuration update timer, that's very convenient. A couple of questions:

1) mtproxy-config.service has WantedBy=network-online.target. Shouldn't it be Wants?

2) Have you tried adding a pkgver function?