Package Details: mu-editor 1:1.0.2-1

Git Clone URL: https://aur.archlinux.org/mu-editor.git (read-only)
Package Base: mu-editor
Description: A simple Python editor for beginner programmers
Upstream URL: https://codewith.mu/
Licenses: GPL3
Submitter: webmeister
Maintainer: webmeister (SpotlightKid)
Last Packager: SpotlightKid
Votes: 10
Popularity: 0.660570
First Submitted: 2016-07-20 09:37
Last Updated: 2019-01-15 21:00

Latest Comments

1 2 Next › Last »

m01 commented on 2019-08-16 23:05

@SpotlightKid: Thank you for explaining, that makes sense.

SpotlightKid commented on 2019-08-16 22:40

@m01: there is the theoretical possibility that someone installs this package under Python 3.7.0, in which case this patch would still be needed. Anyway, it doesn't do anything on other Python versions, and mu 1.1 is not far off, so I'll probably remove it then.

m01 commented on 2019-08-16 20:34

Is the diff still required? It looks like the upstream Python bug mentioned in the comment is marked as resolved.

SpotlightKid commented on 2018-08-07 15:37

@webmeister: all dependencies for a new version are now up-to-date in AUR. Let me know if I can help with a new package release.

SpotlightKid commented on 2018-07-31 16:07

Here's an updated PKGBUILD:

https://gist.github.com/SpotlightKid/5cf6dda1006e31469e405da56a5c5408

Please note that this relies on the following packages, which are currently out-of-date, to be updated:

  • python-pyqtchart
  • python-gpiozero

SpotlightKid commented on 2018-07-31 15:22

mu insists on pinning dependency versions in its setup.py, which is (besides being always bad) not working with the python-pyqt5 and python-qscintilla dependencies, because they are not installed with the necessary *-.egg-info directory, so the version checks fail when mu is started.

I worked around this with the following prepare function:

prepare() {
  cd "$srcdir/mu-$pkgver"
  # python-pyqt5 and python-qscintilla are not python-setuptools compatible
  # the dependencies are handled by the package
  sed -i -e "s/'pyqt5==[0-9.]*',//" -e "s/'qscintilla==[0-9.]*',//" setup.py
}

SpotlightKid commented on 2018-07-31 14:48

@seirl: 'qt5' is already an indirect dependency via 'python-pyqt5'.

@bakerman: The executable was renamed to 'mu-editor' by upstream in newer versions already.

@webmeister:

  • Version 1.0.0 also depends on a lot more Python packages. See here https://github.com/mu-editor/mu/blob/master/setup.py#L14. I've added the missing ones to AUR. Unfortunately 'python-gpiozero' is still at version 1.4.0 but mu needs >= 1.4.1. I've flagged the 'python-gpiozero' package as out-of-date.
  • Dependeny 'python' is already covered by all the other 'python-*' dependencies.
  • Dependency 'python-pyqt5' is already covered by 'python-qscintilla-qt5'

seirl commented on 2018-06-05 00:06

It's missing a dependency to qt5.

backerman commented on 2018-04-11 21:25

This can't be installed with community/mu as /usr/bin/mu is installed by both. Can we install mu-editor here instead?

haawda commented on 2017-02-23 19:28

Please use
source=("$pkgname-$pkgver.tar.gz::https://github.com/mu-editor/mu/archive/v$pkgver.tar.gz")
because there may be name clashes for users with SRCDEST defined.