Package Details: multimc-git 0.6.11.r1.g21ac860e-1

Git Clone URL: https://aur.archlinux.org/multimc-git.git (read-only, click to copy)
Package Base: multimc-git
Description: Free, open source launcher and instance manager for Minecraft.
Upstream URL: http://multimc.org/
Keywords: launcher minecraft
Licenses: Apache
Conflicts: multimc, multimc5, multimc5-git
Provides: multimc, multimc5, multimc5-git
Replaces: multimc5-git
Submitter: peterix
Maintainer: peterix
Last Packager: peterix
Votes: 32
Popularity: 2.68
First Submitted: 2017-05-13 09:34
Last Updated: 2020-03-29 02:12

Dependencies (12)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

xiretza commented on 2018-06-13 14:01

This should probably be set as provides=('multimc' 'multimc5') and conflicts=('multimc' 'multimc5'). Just multimc should be enough as well.

Zebulan commented on 2018-04-09 18:23

This package does not install properly when OpenJDK 10 is being used.

Here is the log for when I tried to install the package: https://pastebin.com/JWzXBy99

peterix commented on 2017-05-13 11:49

I am going to continue maintaining this as multimc-git and have requested merging this (multimc5-git) into that AUR package:
https://aur.archlinux.org/packages/multimc-git

There are some changes involved:
1. Wrapper scripts are no longer used. There is /usr/bin/multimc instead.
2. Storage of user data has been moved to the standard XDG directory:
```
$XDG_DATA_HOME defines the base directory relative to which user specific data files should be stored. If $XDG_DATA_HOME is either not set or empty, a default equal to $HOME/.local/share should be used.
```
This means you should move your MultiMC data from ~/.multimc5 to ~/.local/share/multimc
Other XDG directories are not used, the code is not ready for that.
3. There might be some issues with integration with Steam. I haven't tested it yet, but some sort of `/usr/bin/multimc-steam` wrapper that fixes the environment might be needed.

peterix commented on 2017-01-14 16:26

I fixed it. And I also took over the package.

You can yell at me on discord if it breaks. I can respond there faster than to any notifications from AUR:
https://discordapp.com/invite/0k2zsXGNHs0fE4Wm

benklett commented on 2016-10-29 18:55

@SoniEx2
Sorry, I do not have the time to take care of it. I will just disown the package for now.
If I find some time and the package is still orphan, I will update it.

SoniEx2 commented on 2016-10-29 18:09

Please fix your package https://wiki.archlinux.org/index.php/XDG_Base_Directory_support

(stop using ~/.multimc5 >.>)

wlhlm commented on 2016-05-19 09:46

@benklett Thanks for the quick fix! It works now without a hitch.

BONUS: Here is an updated .desktop file (the shebang is not needed):

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=MultiMC 5
GenericName=Minecraft launcher
Comment=Greatly enhanced game launcher for Minecraft
Type=Application
Terminal=false
Exec=multimc5
Icon=multimc5
Categories=Application;Game

Thanks for packaging multimc5! <3

benklett commented on 2016-05-17 10:38

wlhlm, I added an install instruction for the metioned library.
I hope that fixes your problem as I am not able to test multimc5 at the moment.

wlhlm commented on 2016-05-17 09:08

Currently built MultiMC fails to launch with:

$ multimc5
/usr/lib/multimc5/bin/MultiMC: error while loading shared libraries: libMultiMC_gui.so: cannot open shared object file: No such file or directory

$ pacman -Q multimc5-git
multimc5-git 0.4.11.r67.ga750f6e-1

benklett commented on 2016-02-23 19:15

I did, thanks for the hint.