Package Details: multisystem 1.0350-1

Git Clone URL: https://aur.archlinux.org/multisystem.git (read-only)
Package Base: multisystem
Description: A GUI tool to create a usb system that can boot multiple distro's
Upstream URL: http://liveusb.info/dotclear/index.php
Keywords: Multiboot System USB
Licenses: GPL3
Provides: multisystem
Submitter: ValHue
Maintainer: ValHue
Last Packager: ValHue
Votes: 82
Popularity: 4.282733
First Submitted: 2012-12-02 14:06
Last Updated: 2016-05-01 09:48

Latest Comments

ValHue commented on 2016-05-01 09:52

It is easier still . Mark the package as outdated and I do get the notice. I update it and go.

Thanks!!

kriscokris commented on 2016-04-28 07:56

stop yaourt instalation
cd /tmp/yaourt-tmp-"your-user"/aur-multisystem
makepkg -g >> PKGBUILD
makepkg
if get error edit PKGBUILD and comment 97 line
and try again
ls
pacman -U multisystem-"yours-version".pkg.tar.xz
this is work for me

kriscokris commented on 2016-04-28 07:37

Validating source files with sha256sums...
multisystem.tar.bz2 ... FAILED
Packages ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build multisystem.

kriscokris commented on 2016-04-27 16:43

please update checksum

mariusv1 commented on 2016-04-08 08:49

New Sha256sums:

sha256sums=('062fc6478cf2f97434ebf62281e1e88bd2f84957105bad6db6e9e3781cb43f5b'
'2371bf9f2be02b3485905787afad15e5456d184f2044509deb21103f5dcfde02')

mmimaa commented on 2016-04-06 17:15

sha256sums=('00e6861e1726f31c93bec68bee256a1a8e0856d6b5c8a16f49edcdedcd4fa667'
'fd37e624770fb56a7866500e4f8ce89aee8442f71f39d0881040a6ff04ac2c55')

shahin commented on 2016-04-06 08:03

hash checksum failed
please update

agm28011997 commented on 2016-03-22 17:39

didn't you have problems with the usb created and bios non-uefi ?
when my usb is opened with bios the exit is ''failed to load com32 image .....vesamenu.c32''

zerophase commented on 2016-03-22 11:45

Package prevents Nemo from launching a file browser as root.

sv-esk commented on 2016-03-15 19:20

sha256sums=('b9441956dc0575f83d0406bed7b344375bb2c592a1f06a63641629403d808c72'
'a182f7057ca716cffff92763497accc9b84ca2b621cfd4760dba00119b0105ea')

cb474 commented on 2016-02-07 04:35

I'm still getting an error with the checksums that aborts the install. Although using the checksums listed at http://liveusb.info/multisystem/depot/dists/all/main/binary-i386/Packages does not solve the problem. They are different from what I get if I download the multisystem.tar.bz2 file and run the checksum myself, as well as being different from what's in the pkgbuild here. Are the checksums in the pkgbuild and on the multisystem site therefore both wrong? Not sure how to solve this issue.

Pival81 commented on 2016-01-31 19:17

plz update checksums

Kazun commented on 2016-01-15 20:06

valid checksums -
sha256sums=('4af8ba6bb469d4cbfa9944cbc026742183547ba82c0fe7b82edf5762425c7b02'
'83528962fe79b2db0190cb4be504fd3178aad1f697e218ce51058015ec5c379b')

rafaelsoaresbr commented on 2015-12-31 18:51

Please update checksums.

pixonct commented on 2015-12-30 13:57

Solution to validating source files with sha256sums...
in / tmp, or we can also manually download from AUR where you want) and run:
makepkg -g >> PKGBUILD

and then

makepkg

This creates the PKGBUILD updated with signatures and file .tar.xz that allow Pacman local installation; in the case of the example:

sudo pacman -U-1.0319-1 Multisystem-i686.pkg.tar.xz


http://www.tomi.cat/2015/05/manjaro-installar-un-paquet-aur-que-no.html

hotshot247 commented on 2015-12-19 14:55

i'm having the same error, this is what mine says
"Validating source files with sha256sums...
multisystem.tar.bz2 ... FAILED
Packages ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build multisystem.
==> Restart building multisystem ? [y/N]
==> ------------------------------------"
any help would be great! Thanks!

luiscuadrado123 commented on 2015-12-17 00:54

==> Validating source files with sha256sums...
multisystem.tar.bz2 ... FAILED
Packages ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build multisystem.

how can i solve this?

ritchy commented on 2015-12-14 19:24

Ok,

remove this files :

/var/cache/pacman/pkg-yaourt/multisystem.tar.bz2
/var/cache/pacman/pkg-yaourt/Packages

or purge your yaourt cache
and now, you can reinstall them or update !

;)

ritchy commented on 2015-12-14 18:58

source=("http://liveusb.info/${pkgname}/${pkgname}.tar.bz2"
"http://liveusb.info/${pkgname}/depot/dists/all/main/binary-i386/Packages")


sha256sums=('62f301a95eed9f74dcbfef29d0d468ed946b2116e84bdb0d166b6ad1a5c37de4'
'2b35c7a3600a2b82ad7631fb7fa973edf591c1ad22d77736bb90574942ef8b92')
__________________________________________________________

[root@x devel]# sha256sum multisystem.tar.bz2
62f301a95eed9f74dcbfef29d0d468ed946b2116e84bdb0d166b6ad1a5c37de4 multisystem.tar.bz2
[root@x devel]# sha256sum Packages
2b35c7a3600a2b82ad7631fb7fa973edf591c1ad22d77736bb90574942ef8b92 Packages


It's the same hash ! what's the problem ???

flag this paquet ?

HLFH commented on 2015-12-14 14:04

Same issue as JohnRobson

JohnRobson commented on 2015-12-13 06:57

==> Validating source files with sha256sums...
multisystem.tar.bz2 ... FAILED
Packages ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build multisystem.

reven commented on 2015-12-02 11:18

new sha256sum

line 21
47bfe2f1a99aa7bd7df83c516b0a2201caaf8bb0710c8208de68d71576723b30

line 22

38a9f8d2b1d157756a21e8c8490973e9c845240bfe5177b59e61f305eeebf5be

ValHue commented on 2015-11-27 13:15

Communicating is outdated !!

Ridbowt commented on 2015-11-26 22:10

I've just installed the Multisystem, using some "tweaks" (to avoid an error during installation):

0. An extra action: install these packeges before -
sudo pacman -S xterm mtools imagemagick vim

1. Well, make sure, that you can edit PKGBUILD files -
sudo nano /etc/yaourtrc
and make EDITFILES=1 instead of EDITFILES=0 by default

2. Then, start to install Multisystem via command line -
yaourt multisystem
and press "Y" to get into the PKGBUILD (when you will be asked to do it)

3. Delete the sha256sums key in the 21st line. Insert this new key -
2a6aefc865ad59db62181c93315d35e109ae5d55ec3543698450d3f93a8fe85c

4. Delete the sha256sums key in the 22nd line. Insert the new one -
148ca5efde9b2fe2279202c525dd05ca13922c25835bcdc938f3892d109dc4ac

(OR, YOU MAY CHECK THE SUMS BY HIMSELF WITH HELP "sha256sum" UTILITY - DONWLOAD THE SOURCES: SEE LINKS ABOVE THIS COMMENTARY)

5. Press "Ctrl+O" to save the changes and "Ctrl+X" to leave Nano

6. After doing this operation, continue the installation as usually

That's all.

Mikaela commented on 2015-11-13 10:32

Why does this package require `gtkdialog-svn` instead of `gtkdialog`?

EDIT: because otherwise trying to write iso says "The terminal (VteTerminal) widget requires a version of gtkdialog built with libvte."

schmoken commented on 2015-10-28 19:27

Editing PKGBUILD for the updated checksum of 'Packages' worked for me.

zerophase commented on 2015-10-10 06:29

Is anyone else still failing the sha256sums? Every time I try to download it it fails.

kazimk1 commented on 2015-09-02 17:43

When I try to add iso.It gives error below.What can be reason for that?
bash: /etc/default/console-setup No such file or directory
Unknown --info item "filelist"
rsync: error sysntax or usage error

kazimk1 commented on 2015-09-02 17:40

When I try to add iso.It gives error below.What can be reason for that?
Unknown --info item "filelist"
rsync: error sysntax or usage error

yaourt commented on 2015-07-24 15:14

@JohnRobson You need to update the PKGBUILD witht the correct checksums.

Mine looked like this:

source=("http://liveusb.info/${pkgname}/${pkgname}.tar.bz2"
"http://liveusb.info/${pkgname}/depot/dists/all/main/binary-i386/Packages.gz")
md5sums=('04767f247847a7204a221c1cf8fd9554'
'dafb3060dbe25d7dd3c6d6a75192e24e')

hotshot247 commented on 2015-07-22 16:22

After I compile and Install the program, I can't get the program to display in english...I tried to select english on the drop down menu but the language stays the same..I also tried another language just to see if it'll change and it changed with no problem..just english won't work. any help would be great! Thanks in advance!

JohnRobson commented on 2015-06-04 19:06

==> Validating source files with sha256sums...
multisystem.tar.bz2 ... FAILED
Packages ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build .

ValHue commented on 2015-05-31 19:44

@kazimk1 Ok, then I guess that it will be some dependency, so far no one had reported anything like that and I guess there will be more users of KDE.

I will investigate with google to see if I find some bug or something

kazimk1 commented on 2015-05-31 18:29

Isos which I tried are supported.For example Archlinux iso.

kazimk1 commented on 2015-05-31 18:27

Isos which I tried are supported for example Archlinux iso.I searched internet and found two link for that error

https://translate.google.com/translate?hl=tr&sl=auto&tl=en&u=http%3A%2F%2Fforum.ubuntu-fr.org%2Fviewtopic.php%3Fid%3D1229491%26p%3D14

https://translate.google.com/translate?hl=tr&sl=auto&tl=en&u=https%3A%2F%2Ftoster.ru%2Fq%2F199567&sandbox=1

ValHue commented on 2015-05-31 09:17

I know it can not be happening, I just added my USB iso with multisystem smoothly.

The iso're trying to add is on the list of supported OS?

http://liveusb.info/dotclear/index.php?pages/os

kazimk1 commented on 2015-05-30 16:55

when I select iso file.I get infinite "TIMER refresh true" print in terminal and multisystem window became not responsive.I use kde desktop.What problem coul be reason for that?

ValHue commented on 2015-03-20 18:51

When not stand the test of integrity, may be due to an update. In this case use the updpkgsums command. It updated PKGBUILD

And of course I would notify them as soon as possible so I'll update.

ValHue commented on 2015-03-20 18:48

Being able to control the integrity of files, I will not use md5sums=(SKIP)

That would go against the principle of security.

ieltxu commented on 2015-03-18 12:05

Editando el PKGBUILD no da error de validación y lo instala. Bajo tus propios riesgos.
....
md5sums=('SKIP' 'SKIP')
....

dust commented on 2015-03-04 02:37

edit PKGBUILD as follow:
pkgname="multisystem"
pkgver=1.0314
...
source=("http://liveusb.info/${pkgname}/${pkgname}.tar.bz2"
"http://liveusb.info/${pkgname}/depot/dists/all/main/binary-i386/Packages.gz")
md5sums=('B681087A486AF4ABED50B420F047B15D'
'181485F674A48343D5E7DE0DA718016D')

4ndrxmetal commented on 2015-02-02 15:49

Please, change md5sum of the archives in PKGBUILD:

==> Validando las fuentes con md5sums...
multisystem.tar.bz2 ... HA FALLADO
Packages ... HA FALLADO
==> ERROR: ¡Uno o más archivos no superaron el control de validación!
==> ERROR: Makepkg no ha podido compilar multisystem.

ValHue commented on 2015-01-25 17:38

@Daniel.alomar thanks, I have again included as a dependency to gtkdialog-svn. The if that is compiled with VTE and now should not give any error.

Daniel.alomar commented on 2015-01-24 11:03

Downloaded and installed yesterday (1.0312-2) and I get the following message when I drag a ISO:
"The terminal (VteTerminal) widget requires a version of gtkdialog built with libvte" I have installed gtkdialog 0.8.3-2

ValHue commented on 2015-01-18 11:46

Thanks @cl0ne

cl0ne commented on 2015-01-11 18:22

no need for gtkdialog-svn, current version in community is 0.8.3

Lordsigma commented on 2014-10-27 03:17

If you put 'SKIP'in both hash arrays it will skip checksum and intall the package (under your own risk, though)

Lordsigma commented on 2014-10-27 02:27

when installing Multisystme got this:
ERROR: One or more files did not pass the validity check!

AnSnarkista commented on 2014-10-24 14:37

Please, change md5sum of the archives in PKGBUILD:

multisystem.tar.bz2 -> ef54ec208363f8f80e711f685a72c402
Packages -> I haven't found the md5sum for this package. I tried with Packages.gz (3de0e49a408c2956c6bd93833a1f5920), but fails

ValHue commented on 2014-10-01 09:19

@leodrw Thanks
Updated to 1.0306

leodrw commented on 2014-09-30 12:41

P.S. I'm replace hash in pkgbuild and installation successfully

leodrw commented on 2014-09-30 12:38

to install need update pkgbuild md5sums...
multisystem.tar.bz2 new version have different hash

alchemygear commented on 2014-08-23 23:06

MD5sum still does not match tarball. This is the exact error.

==> Retrieving sources...
-> Found multisystem.tar.bz2
==> Validating source files with md5sums...
multisystem.tar.bz2 ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build multisystem.
==> Restart building multisystem ? [y/N]

petaramesh commented on 2014-08-16 07:21

Wrong tarball MD5SUM these last days. Needs an update.

tony_p commented on 2014-07-31 09:53

Hi,

it seems there is a new version:
- multisystem.tar.bz2 30-Jul-2014 20:14 9.8M
- fb280f4fa6eaf80d273e59806b25d154 multisystem.tar.bz2

Thanks

WoefulDerelict commented on 2014-06-26 14:53

It would appear there has been another minor update. The time stamp on version-multisystem.txt is early this morning.

vimalkvn commented on 2014-06-24 18:24

Please update. There is a new version available as of 24 Jun 2014.

85f9c1797efcceadfbc57cb728fbc0b2 multisystem.tar.bz2

ValHue commented on 2014-05-20 07:32

Again, if you do not pass validation, check for new version and notify. Better mark it as outdated.

As I have knowledge of this, attempt to fix.

Updated to 1.0294

Abrer commented on 2014-05-18 14:42

Validity check issue. Check the MD5?

namae commented on 2014-05-03 21:55

i found python-pyqt4 is also dependency and needs to be added to the PKGBUILD

diraimondo commented on 2014-04-26 10:54

@cuentos:
I had the same error. Remove the file multisystem.tar.bz2 from your yaourt cache and retry...

cuentos commented on 2014-04-17 03:41

multisystem.tar.bz2 ... FALLÓ
==> ERROR: ¡Uno o más archivos no pasaron la verificación de integridad!
Error de md5sum, donde el correcto es:
def8e424113e4d8e3630bb2f517c0589 multisystem.tar.bz2

ValHue commented on 2014-03-22 11:07

@abis:

Thanks for the notification. Done. Updated to 1.0292

abis commented on 2014-03-20 19:41

(Correcting a typo from my last comment) It looks like the package was updated on 20140315 so the md5sum check is causing the installation to fail. Could you update the PKGBUILD, please?

abis commented on 2014-03-20 19:32

It looks like the package was updated on 20130315 so the md5sum check is causing the installation to fail. Could you update the PKGBUILD, please?

ValHue commented on 2014-03-06 09:15

@Merlin: I tried to reproduce your bug without success. I do not know that it can happen to you, I've tried it in gnome, cinnamon and openbox and does not give me any problems, even downloaded the same iso you Manjaro that produced the error, and has worked for me perfectly.

@mitcoes:YUMI knew for windows, I'll have a look at the version of linux, see what I can do. Thanks for the info.

Merlin commented on 2014-03-05 12:23

Hi, your package does not always work ... Always the same type errors:
bash: FCT_UPDATEGRUB: command not found ... etc.
I tested several distributions based on Arch Linux, and many different systems, it is the same ...
Do you have an explanation?
thank you
Sorry for my English, I use google translate, I'm french;)

mitcoes commented on 2014-03-04 12:48

AS YUMI
http://www.pendrivelinux.com/downloads/YUMI/ubuntu/yumi_0.0.1.orig.tar.gz
http://www.pendrivelinux.com/yumi-multiboot-usb-creator/

Is now available for GNU/Linux too

Would you be so gentle to package it for AUR?

Thanks in advance

ValHue commented on 2014-03-03 08:23

See the Terms of Use of AUR.

"The AUR Web Interface has a comments facility that allows users to provide suggestions and feedback on improvements to the PKGBUILD contributor. Avoid pasting patches or PKGBUILDs into the comments section: they quickly become obsolete and just end up needlessly taking up lots of space. Instead email those files to the maintainer, or even use a pastebin."

Merlin commented on 2014-02-25 10:47

ERROR aur/multisystem 1.0287-1

merlin@witchcraft ~ $ . /tmp/multisystem/multisystem-vte
bash: ./common.sh: Aucun fichier ou dossier de ce type
Veuillez saisir votre mot de passe d'administrateur
[sudo] password for merlin:

bash: 41%/1024 : erreur de syntaxe : opérande attendue (le symbole erroné est "/1024")
fichier:/home/merlin/Téléchargements/manjaro-xfce-0.8.9-x86_64.iso
iso:1175Mio
bash: 41%/1024 : erreur de syntaxe : opérande attendue (le symbole erroné est "/1024")
Demande de votre mot de passe d'administrateur pour monter le fichier
mount: /dev/loop0 est protégé en écriture, sera monté en lecture seule
bash: /etc/default/console-setup: Aucun fichier ou dossier de ce type
bash: /etc/default/console-setup: Aucun fichier ou dossier de ce type
XKBLAYOUT:
XKBVARIANT:
XKBMODEL:
bash: ./os_support.sh: Aucun fichier ou dossier de ce type
Copie du fichier iso en cours...
sending incremental file list
manjaro-xfce-0.8.9-x86_64.iso
1.23G 100% 106.86MB/s 0:00:11 (xfr#1, to-chk=0/1)

sent 1.23G bytes received 35 bytes 5.67M bytes/sec
total size is 1.23G speedup is 1.00


bash: FCT_UPDATEGRUB : commande introuvable
bash: FCT_UPDATETREE : commande introuvable
bash: FCT_END : commande introuvable
merlin@witchcraft ~ $

ValHue commented on 2014-02-21 16:23

Sorry, I have been 3 updates in the last 2 days.

Updated to 1.0287

ValHue commented on 2014-02-05 11:47

Updated to 1.0284

ValHue commented on 2014-02-05 11:42

@bugmenot:
- And would not it be more effective to inform the package maintainer, this has changed or been updated?

Well not that long posts are recommended, you could've linked the manual. See the Terms of Use of AUR.

bugmenot commented on 2014-02-04 15:41

For people like me who didnt understand how people got the correct md5sums to fix this error and people who havent yet edited package builds:
a short guide to fix the md5 problem

go here:
http://liveusb.info/multisystem/
and download: multisystem.tar.bz2

open terminal and enter:
md5sum /path/to/multisystem.tar.bz2

my result on 04.February.2014 :
[chief@manjaro ~]$ md5sum /home/chief/Downloads/multisystem.tar.bz2
ef89a4ce44f8279e62c0a3e8079f8684 /home/chief/Downloads/multisystem.tar.bz2

copy paste your result... in my case ef89a4ce44f8279e62c0a3e8079f8684

terminal: enter:
yaourt multisystem

at the first prompt whether you want to edit the PKGBUILD enter:
y and choose vim, geany, gedit, leafpad, ...
replace:
md5sums=('5946f1aa8db7cab111c8b66664343399')

with your md5sum

cheers

ValHue commented on 2014-01-04 09:35

Updated to 1.0282

kylebofh commented on 2014-01-03 07:03

New md5sum for version 1.0281-1: a29a6cd3ef2d4dba4674dd63699ba51d

ValHue commented on 2013-12-12 18:05

Sorry for the "delay" have been 3 updates in the last 3 days :(


We've gone from version 1.0278 to 1.0281

tmallafre commented on 2013-12-10 20:29

md5sum needs to be updated. Thanks

tmallafre commented on 2013-12-10 20:16

md5sum needs to be updated to 14219d60f4b1aa8ad784c80f49ac7e7d
Thanks

mikronimo commented on 2013-12-06 14:40

ok, thanks... now with the new md5 all works as it have to!

molux commented on 2013-12-05 22:11

New md5sum? I have to replace with 8f64b7ccc33d98a2080a81b99685b300

ValHue commented on 2013-11-14 15:06

@ftuesca:

Thanks for your comment. Updated!

FacuTuesca commented on 2013-11-11 23:20

There is a mistake in the PKGBUILD. This:

if pacman -Qq vim-runtime >/dev/null 2>&1; then
depends=('vim' 'cdrkit' 'cryptsetup' 'dosfstools' 'gksu' 'grub' 'gtkdialog-svn' 'gvfs' 'hdparm' 'imagemagick' 'lsb-release' 'lsof' 'mtools' 'parted' 'qemu' 'rsync' 'squashfs-tools' 'sudo' 'syslinux' 'unzip' 'wmctrl' 'xdotool' 'xterm' 'zenity')
else
depends=('xxd' 'cdrkit' 'cryptsetup' 'dosfstools' 'gksu' 'grub' 'gtkdialog-svn' 'gvfs' 'hdparm' 'imagemagick' 'lsb-release' 'lsof' 'mtools' 'parted' 'qemu' 'rsync' 'squashfs-tools' 'sudo' 'syslinux' 'unzip' 'wmctrl' 'xdotool' 'xterm' 'zenity')
fi

Should be:
if pacman -Qq vim-runtime >/dev/null 2>&1; then
depends=('vim' 'cdrkit' 'cryptsetup' 'dosfstools' 'gksu' 'grub' 'gtkdialog-svn' 'gvfs' 'hdparm' 'imagemagick' 'lsb-release' 'lsof' 'mtools' 'parted' 'qemu' 'rsync' 'squashfs-tools' 'sudo' 'syslinux' 'unzip' 'wmctrl' 'xdotool' 'xterm' 'zenity');
else
depends=('xxd' 'cdrkit' 'cryptsetup' 'dosfstools' 'gksu' 'grub' 'gtkdialog-svn' 'gvfs' 'hdparm' 'imagemagick' 'lsb-release' 'lsof' 'mtools' 'parted' 'qemu' 'rsync' 'squashfs-tools' 'sudo' 'syslinux' 'unzip' 'wmctrl' 'xdotool' 'xterm' 'zenity');
fi

Without the semicolons, the if always enters the else case.

HellOfBSOD commented on 2013-10-28 10:37

I beleive the MD5 is now 94e2375c7de6b918e4bad2cfbc48dc6e

petaramesh commented on 2013-10-23 07:51

I do not quite understand. I have a 3 (KDE+Gnome) Arch machines on which Multisystem doesn't work as reported below. I have CLONED one of their HDs to another machine (except for /home), and on the new one Multisystem works like a charm !

The machines on which it doesn't work were "pure Arch". The machine on which it now works used to be an Ubuntu, that got erased except for its /home that I kept from Ubuntu...And on this one Multisystem works ?!?

MelTraX commented on 2013-10-16 14:18

I had to replace the md5sum with 13fde809363e034af343d55106c3d855.

jbernardo commented on 2013-10-10 08:47

A small correction, typing my password a few times "in the blind" seems to work.

jbernardo commented on 2013-10-10 08:40

I am having the same issues as @petaramesh, drag and drop does not work, and selecting an ISO leads to a non-responding multisystem window. When run from the console, all I get is a "TIMER refresh true".
I am using KDE as my desktop, could it be related?

greenfuse commented on 2013-10-05 05:01

The md5sum is now 00fdca650ef241e138685034f06b2b5a

Multisystem works fine for me

ValHue commented on 2013-09-24 10:00

Updated to 1.0272-2, grub-bios disappears as a dependency and is now used grub:
https://www.archlinux.org/packages/core/i686/grub/

For errors reported by @mitcoes and @petaramesh, do not know the causes, nothing like that happens to me.

-- Are you using gtkdialog-svn or gtkdialog?

petaramesh commented on 2013-09-22 05:33

The missing scripts reported by mitcoes below could well be the cause of the issues I report with VTE in my comment from 2013-09-02... I've tried installing multisystem on 3 different fresh Arch machines, it worked on NONE...

mitcoes commented on 2013-09-20 10:26

Errors - does not work adding isos -
but digging at the terminal history some scripts are missing

I'll try to copy paste them from my Ubuntu installation

./multisystem-vte

./multisystem-vte: línea 12: ./common.sh: No existe el fichero o el directorio
./multisystem-vte: línea 18: ./gui_multi_sel.sh: No existe el fichero o el directorio
add 1
./multisystem-vte: línea 33: ./iso_add.sh: No existe el fichero o el directorio
./multisystem-vte: línea 38: FCT_UPDATEGRUB: no se encontró la orden
./multisystem-vte: línea 41: FCT_UPDATETREE: no se encontró la orden
./multisystem-vte: línea 42: FCT_END: no se encontró la orden

EnigmaCurry commented on 2013-09-14 18:26

Dependency `grub-bios' of `multisystem' does not exist.

ValHue commented on 2013-09-09 18:26

Thanks @Mektub

Updated to 1.0272!

Mektub commented on 2013-09-09 17:49

Checksum failed, I had to change:

md5sums=('1bee0b5c4bd6874ebb8eccce7b2eec2a')

to

md5sums=('3197986616d446e80eb5bfdfc56a3f92')

Mektub

ValHue commented on 2013-09-02 18:54

Updated to the latest version. I do not know what the cause of the problems says @petaramesh. I checked the resulting package with namcap and has no dependencies, including some I mark them as unnecessary, but I tried it on a new installation from scratch, and begged them to me, so they are included.

If anyone can shed light on the subject, happy to make the changes that were necessary.

A greeting.

petaramesh commented on 2013-09-02 11:38

Hi,
When I drag an ISO into Multisystem, I do *not* get the terminal window showing progress and asking for my PW that I get in other distros, and nothing happens. However if I type my PWD "in the blind" then click a couple times on the (frozen) window, I can see my USB key blink and then the ISO gets installed properly onto it "in the blind".
I assume that I miss a dependancy which the package missed to specify, but which ? That's a mystery to me...

ValHue commented on 2013-08-07 08:04

@Mektub,

-The PKGBUILD respects they created the program, if someone manages gui_multisystem.sh a script that runs from /usr/bin modified the PKGBUILD without any problems.

-You got it properly installed, update-grub2 is another script, created and built by me in the PKGBUILD, precisely because the program is based on Ubuntu, and there is no update-grub2 in Arch, but if you look at the content it does is mimic to update-grub2 in Ubuntu.

Anonymous comment on 2013-08-07 03:31

Two problems:

A. It says it is in English but everything displays in something else. French?

B. I can still navigate it well enough, but when I do something that prompts for a password, the password prompt closes before I can enter all of it.

Mektub commented on 2013-08-04 13:17

Why do I have to execute /usr/local/share/multisystem/gui_multisystem.sh (saw in the comments) and not something in /usr/bin ?

I know I can make a link, but how is one supposed to find out above path ?

Did i do something wrong ? the only thing I have from multisystem in /usr/bin is update-grub2.

Mektub

onny commented on 2013-08-04 05:54

md5sum updated again, please fix it!

ValHue commented on 2013-07-07 17:42

Updated to 1.0265

Danon commented on 2013-07-05 16:51

@valhue. The md5sum is messed up again, even when i paste
md5sums=('ca5b6bb670b97aba00e0ab9a910113e3')
into the package build file.

ValHue commented on 2013-06-27 07:21

Updated to 1.0264

@bifkit you're right.
Sometimes when multisystem is updated, I modify the PKGBUILD for the md5sums is correct, and they instantly change again.

FSMaxB commented on 2013-06-26 19:08

md5sums=('ca5b6bb670b97aba00e0ab9a910113e3')

bifkit commented on 2013-06-26 17:51

They updated again on 2013-06-25. The current PKGBUILD no longer contains the correct md5 hash.

It's like they waited for ValHue to update the hash on 2013-06-24 and then shouted "Ha ha! NOW we update again!"

ValHue commented on 2013-06-26 08:47

@Danon xxd only available in AUR.

Are you new to Arch?

visit:
- https://wiki.archlinux.org/index.php/AUR_User_Guidelines#Installing_packages
- https://wiki.archlinux.org/index.php/Yaourt

Danon commented on 2013-06-24 14:13

Thanks For Fixing.
I Think The Only Dependencies Pacman Cant download with pacman -S is
xxd and xterm.

ValHue commented on 2013-06-24 11:42

Updated to 1.0263

Danon commented on 2013-06-24 05:42

@valhue
The MD5 Hash Is Not Working.

==> Making package: multisystem 1.0261-4 (Mon Jun 24 01:33:57 EDT 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading multisystem.tar.bz2...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 8689k 100 8689k 0 0 547k 0 0:00:15 0:00:15 --:--:-- 902k
==> Validating source files with md5sums...
multisystem.tar.bz2 ... FAILED
==> ERROR: One or more files did not pass the validity check!



ValHue commented on 2013-06-07 08:15

@SohorX:
This package is already adapted to the new location of binaries:

https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/

What have you done? If you did not, follow the steps in the link above.

Anonymous comment on 2013-06-07 01:17

After the installing, I have this:
$pacman -Qqo /bin
multisystem

it created an error when I launched an upgrade for the filesystem.

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [######################] 100%
(1/1) checking package integrity [######################] 100%
(1/1) loading package files [######################] 100%
(1/1) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem
Errors occurred, no packages were upgraded.

ValHue commented on 2013-06-03 20:14

Well it seems I made a mistake to adapt the PKGBUILD as:

https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/

when moved update-grub2 from /bin to /usr/bin, don't as, but I changed the permissions to the generated file.

@AVDuma thanks for the warning.

PS: update-grub2 is generates and installs automatically when you install multisystem with this PKGBUILD

AVDuma commented on 2013-06-03 17:28

I've installed with yaourt multisystem, but I get this error when I've launched it:
[albi@localhost ~]$ /usr/local/share/multisystem/gui_multisystem.sh
Gtkdialog version: 0.8.4
LANG:it_IT.UTF-8
LANGUAGE:it_IT.UTF-8
LANGSEL:Italian|it|it_IT.UTF-8|Federico Kircheis|fekir1.618@gmail.com
Errore: Manca: update-grub2

how can I find update-grub2? I have grub2 installed.

Thanks

AVDuma commented on 2013-06-03 17:20

I've installed with yaourt multisystem, but I get this error when I've launched it:
[albi@localhost ~]$ /usr/local/share/multisystem/gui_multisystem.sh
Gtkdialog version: 0.8.4
LANG:it_IT.UTF-8
LANGUAGE:it_IT.UTF-8
LANGSEL:Italian|it|it_IT.UTF-8|Federico Kircheis|fekir1.618@gmail.com
Errore: Manca: update-grub2

how can I find update-grub2? I have grub2 installed.

Thanks

AVDuma commented on 2013-06-03 17:18

I've installed with yaourt multisystem, but I get this error when I've launched it:
[albi@localhost ~]$ /usr/local/share/multisystem/gui_multisystem.sh
Gtkdialog version: 0.8.4
LANG:it_IT.UTF-8
LANGUAGE:it_IT.UTF-8
LANGSEL:Italian|it|it_IT.UTF-8|Federico Kircheis|fekir1.618@gmail.com
Errore: Manca: update-grub2

how can I find update-grub2? I have grub2 installed.

Thanks

ValHue commented on 2013-05-22 18:43

Updated to 1.0261

dojero commented on 2013-05-22 16:14

Generated md5sum for multisystem tar file as of 5/21. It worked, so for those interested: 4e9c265dbc5864cb005c9db8445b5ab8

dojero commented on 2013-05-22 15:58

As of today, md5sum is apparently incorrect. Please advise as to the correct md5sum so that I can change the PKGBUILD.

ValHue commented on 2013-05-06 12:31

@petaramesh:

Well I do not find anything unusual.

Now gtkdialog is used to open a embedded terminal and some options xterm opens, both are included as dependencies and runs smoothly.

Anyone else does this happen?
With that desk?, Wm, etc ...

petaramesh commented on 2013-05-06 11:48

Installs OK, but doesn't actually work : Does not open the terminal that it should open to prompt for sudo password and run operations. Missing dependancy or incomplete install ?

FSMaxB commented on 2013-04-30 10:20

It isn't possible to install this package parallel to vim or gvim as xxd conflicts with them (vim and gvim provide xxd). Maybe there is any way to make this package dependend on vim, gvim or xxd (with one of those dependencies being enough). Don't know if this is possible, as I'm not that much into PKGBUILDs.

bobwya commented on 2013-04-13 16:39

I'm seeing the classic:
mkdir: cannot create directory ‘/tmp/multisystem/pkg’: Permission denied

ls -l /tmp/multisystem/
d--------- 2 robert users 40 Apr 10 23:39 pkg/
drwxr-xr-x 3 robert users 140 Apr 10 23:39 src/

Permissions on /tmp:
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime)

Tried both regular (manual) makepkg and yaourt routes... Other stuff is building fine...

Any thoughts what's going wrong?

bobwya commented on 2013-04-11 16:31

I'm seeing the classic:
mkdir: cannot create directory ‘/tmp/multisystem/pkg’: Permission denied

ls -l /tmp/multisystem/
d--------- 2 robert users 40 Apr 10 23:39 pkg/
drwxr-xr-x 3 robert users 140 Apr 10 23:39 src/

Permissions on /tmp:
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime)

Tried both regular (manual) makepkg and yaourt routes... Other stuff is building fine...

Any thoughts what's going wrong?

mjob commented on 2013-04-04 14:14

Updated version - april 2nd - my md5sum: d34a8c8b1e4d56199a0a890ae5f05ff8

ValHue commented on 2013-03-15 07:57

Updated at 1.0256 (15-Mar-2013 03:10)

He had suffered 3 updates in less than four days.

ValHue commented on 2013-03-15 07:50

md5sum is incorrect because the package has been updated.

When this happens to click "Flag package out-of-date" in the "Package Actions". So I receive notification via email and via the web and can update the PKGBUILD in less time.

Anonymous comment on 2013-03-14 13:40

md5sum is incorrect

please update to: 3b8d3c2470578aafc2279563841fb715

thanks

Anonymous comment on 2013-02-24 05:53

ValHue,

libvte is required for the VteTerminal widget. When gtkdialog is built it will automatically include vte header files if they exists. libvte can be installed in official repos via "pacman -S vte". Once it's installed everything works. Thanks for maintaining this tool!

Per gtkdialog README:

VTE
---
Gtkdialog's configure script will compile-in support for the Virtual
Terminal Emulator if it finds libvte and its development headers.
libvte source package -> http://ftp.gnome.org/pub/GNOME/sources/vte/

ValHue commented on 2013-02-21 11:59

I'm back to include qemu-kvm as a dependency.

After running "pkgfile kvm" I noticed that kvm is currently only provided by qemu-kvm.

ValHue commented on 2013-02-21 11:44

Updated to new release!

pinball-fixer commented on 2013-02-21 09:58

md5sum is incorrect (looks like the package has been updated).

Please update to: b84551cb9d58d80086fb861b464b51a2

mikronimo commented on 2013-02-14 22:51

Now it works; thanks. :D

Kai23 commented on 2013-02-14 11:02

Ehy !

To make it work today, I had to

- Remove multisystem
- Remove gtkdialog
- download gtkdialog (http://code.google.com/p/gtkdialog/downloads/detail?name=gtkdialog-0.8.3.tar.gz&can=2&q=)
- configure - make - make install
- install multisystem
- edit /usr/local/share/multisystem/dependances.txt and remove kvm

And go ! :)


ValHue commented on 2013-02-14 08:50

Ooops ... have returned to update. Fixed!

wlmeng11 commented on 2013-02-14 06:28

The MD5SUM is wrong.
It should be:
22a6ba9c5b112964db4d77a7c2762be1

mikronimo commented on 2013-02-14 06:18

I got some problem with validation control, so i can't update. :)

ValHue commented on 2013-02-13 17:44

@ImNtReal, Done. Updated!

ImNtReal commented on 2013-01-28 19:23

Since qemu-kvm has been replaced by qemu, you should change that just qemu on your next release. Thanks.

ValHue commented on 2013-01-13 13:12

Updated PKGBUILD.!!

Now check vim-runtime is installed, is a unit of vim, and if so, xxd no longer listed as dependency. Otherwise, as we have vim installed, and xxd necessary, installed from AUR without installing vim.

ValHue commented on 2013-01-13 08:49

xxd is necessary according to the creators of multisystem, so is included in the PKGBUILD as a dependency. You can see it in /usr/local/share/multisystem/dependances.txt. I do not use vim and had not noticed anything.

Now if those using vim, xxd been removed and multisystem works 100%, and then put it off as a dependency.

ImNtReal commented on 2013-01-13 01:02

@Mektub at this point if you have vim installed, you have to manually edit the PKGBUILD as noted in other comments.

Mektub commented on 2013-01-13 00:30

There is something wrong with this package. It wants to remove vim (no joke, please) and if I remove xxd it installs an update-grub2 and thats it.

ValHue commented on 2013-01-04 12:10

New update!

Now desktop files and update-grub2 are included in the PKGBUILD itself, and are generated during installation.

wlmeng11 commented on 2013-01-01 20:30

@ImNtReal
vim should include xxd, so I just removed xxd from the PKGBUILD and it installed fine.

wlmeng11 commented on 2013-01-01 20:30

@ImNtReal
vim should include xxd, so I just removed xxd from the PKGBUILD and it installed fine.

ValHue commented on 2012-12-29 17:53

Updated to multisystem 1.0249

ImNtReal commented on 2012-12-07 15:44

Does this really require xxd? It seems it won't install without replacing vim.

ImNtReal commented on 2012-12-07 15:44

Does this really require xdd? It seems it won't install without replacing vim.

ValHue commented on 2012-12-07 11:35

I performed a clean install of arch, and updated the dependencies for multisystem start without errors.

ImNtReal commented on 2012-12-07 02:27

I think hdparm should be in depends. I needed to install it to get it running.

ValHue commented on 2012-12-06 10:41

Updated!!

ValHue commented on 2012-12-06 08:42

Hello quantumphaze,

as I said, I do not fatresize needed at all. I hope the opnion of more users to respect.

The commenting lines 227-235 of usr/local/share/multisystem/gui_multisystem.sh try to be resolved in the next version of the PKGBUILD. Very good contribution.

The issue of local, as is, to me work. I am Spanish and the program shows me correctly. As I misunderstood what you meant. Nor should we copy everything that makes Ubuntu. If it works, leave it, you know, KISS philosophy, this is Arch

Thanks for your comment.

ValHue commented on 2012-12-06 08:38

Hello quantumphaze,

as I said, I do not fatresize needed at all. I hope the users opnion of more respect.

The commenting lines 227-235 of usr / local / share / multisystem / gui_multisystem.sh try to be resolved in the next version of the PKGBUILD. Very good contribution.

The issue of local, as is, to me work. I am Spanish and the program shows me correctly, as I misunderstood what you meant. Nor should we copy everything that makes Ubuntu. If it works, leave it, you know, KISS philosophy, this is Arch.

Thanks for your comment.

quantumphaze commented on 2012-12-06 07:26

I removed fatresize from /usr/local/share/multisystem/dependances.txt

It now comlains about me not being admin. I assume it expects me to be in the group "admin" (which is Ubuntu for "wheel").

So I commented the verification in the file /usr/local/share/multisystem/gui_multisystem.sh lines 227 to 235. The adm group doesn't appear to be used much other than the contents of /var/log/journal/ on Arch Linux (something to do with systemd).

Now it can't find the files /etc/default/{locale,console-setup}. These files are found on Ubuntu so it may just be easier to use that.

If anyone else wants to fix any more of the Ubuntu assumptions feel free to comment.

ValHue commented on 2012-12-05 19:27

In principle fatresize is a dependency of multisystem install.sh file. But looking at the parted libraries not think it takes to install. I'll add in optdeps.
Thanks for the comment.

PD: Sorry for my English

ValHue commented on 2012-12-05 19:17

In principle fatresize is a dependency of multisystem install.sh file. But looking at the parted libraries not think it takes to install. I'll add in optdeps.
Thanks for the comment.

PD: Sorry for my English

ImNtReal commented on 2012-12-05 18:23

fatresize should probably be added to either depends or optdeps. I can't tell which, yet because I haven't actually got the app to fully start.