Package Details: mumps 5.1.1-1

Git Clone URL: https://aur.archlinux.org/mumps.git (read-only)
Package Base: mumps
Description: Sparse solver library using Gaussian elimination
Upstream URL: http://mumps.enseeiht.fr
Licenses: custom
Submitter: mickele
Maintainer: heitzmann
Last Packager: heitzmann
Votes: 7
Popularity: 0.161189
First Submitted: 2009-04-05 16:37
Last Updated: 2017-07-26 01:30

Latest Comments

heitzmann commented on 2017-06-20 13:29

@capitalaslash
Sure, if you could paste it somewhere and link it here it would be great!
Thanks!

capitalaslash commented on 2017-06-20 13:20

I have an updated PKGBUILD for 5.1.1 with real shared library compilation, let me know if you want it.

heitzmann commented on 2016-05-31 12:49

Thanks @gdolle!
I've included your fix straight into Makefile.inc.
Let me know if the problem persists.

gdolle commented on 2016-05-29 13:32

Hi, I got this error since zlib 1.2.8
----
/usr/lib/libscotch.so : référence indéfinie vers « gzwrite »
/usr/lib/libscotch.so : référence indéfinie vers « gzsetparams »
/usr/lib/libscotch.so : référence indéfinie vers « gzclose »
/usr/lib/libscotch.so : référence indéfinie vers « gzdopen »
/usr/lib/libscotch.so : référence indéfinie vers « gzread »
collect2: erreur : ld a retourné 1 code d'état d'exécution
----
I don't know if it comes from my install, but if someone has the same problem, adding zlib linking "-lz" should solve the problem.

See this patch
https://gist.github.com/gdolle/7e1b15abe12f983e340ba215e667f337

mickele commented on 2015-08-07 18:30

@hyperelastic
Try mumps4

hyperelastic commented on 2015-08-04 22:25

Doesnt build. In turn, unable to install aster. The message looks like this:

libcmumps.a(cana_aux_par.o): In function `__cmumps_parallel_analysis_MOD_cmumps_assemble_top_graph':

...

libcmumps.a(cfac_asm_master_m.o):cfac_asm_master_m.F:(.text+0x74e5): more undefined references to `__stack_chk_fail_local' follow

mickele commented on 2015-02-28 07:05

I tried compiling with metis-4, but it stopped with an error. It seems mumps-5 requires metis-5.

fhr commented on 2015-02-27 23:31

You can use Metis 4.x or lower by compiling with -Dmetis4, ParMetis 3.2.0 or lower with -Dparmetis3. So you could have a mumps-5_metis-4 package I guess...

mickele commented on 2015-02-27 18:28

mumps-5 requires metis-5, so I had to create another package (mumps4) to link with code-aster (that requires metis-4).

eleftg commented on 2015-02-19 16:35

@eolianoe: Indeed. Those extra'pkg' in the install paths are redundant :-)

However mine built fine with 16 procs. Weird... (timing issue perhaps?)

All comments