Package Details: murmur-git 1.4.0.r712.g414ab61b6-1

Git Clone URL: https://aur.archlinux.org/murmur-git.git (read-only, click to copy)
Package Base: murmur-git
Description: The voice chat application server for Mumble (git version)
Upstream URL: https://www.mumble.info/
Licenses: BSD
Conflicts: murmur, murmur-ice, murmur-static
Provides: murmur
Submitter: OttoA
Maintainer: disastro
Last Packager: disastro
Votes: 10
Popularity: 0.193463
First Submitted: 2009-12-15 16:30 (UTC)
Last Updated: 2022-06-17 16:04 (UTC)

Pinned Comments

disastro commented on 2016-11-10 08:06 (UTC)

Latest ZeroC Ice 3.6.3 finally supports PHP 7 at least on 64-bit. https://aur.archlinux.org/packages/zeroc-ice-php56 should work with the changes I described in the comments.

Latest Comments

1 2 3 Next › Last »

disastro commented on 2022-01-22 10:40 (UTC)

@Philos Yeah I've had this on my radar since last weekend but only updating the package now, thank you :)

Philos commented on 2022-01-22 10:06 (UTC)

Version 1.4.230 (snapshot.006.r472.gdb3a28058 in my case) does not compile on aarch64 due to the submodule tracy not being fetched. Tracy was added fairly recently in commit db57b63 (2021-12-29). I've added:

git config submodule.3rdparty/tracy.url $srcdir/tracy
git submodule update 3rdparty/tracy

to prepare() in PKGBUILD and it now compiles & runs cleanly.

soupaloignon commented on 2021-10-21 23:00 (UTC)

Can you add the aarch64 architecture? I tested it and it just built smoothly :)

beano commented on 2021-08-28 19:20 (UTC) (edited on 2021-08-28 19:32 (UTC) by beano)

No /usr/bin/murmurd after build and install.

edit: instead the binary is at /usr/bin/mumble-server

disastro commented on 2020-09-26 18:44 (UTC) (edited on 2020-09-27 19:30 (UTC) by disastro)

Just a heads up that I'm working on updating the package to cmake, it does not build currently at all.

EDIT: Current roadblock https://github.com/mumble-voip/mumble/issues/4508

disastro commented on 2017-12-31 11:43 (UTC)

@sanerb Thank you for the patch. I've updated the package with gRPC from your patch and other small changes.

sanerb commented on 2017-11-14 23:45 (UTC) (edited on 2017-11-15 00:30 (UTC) by sanerb)

please enable grpc support. i generated a patch for you: https://pastebin.com/CDxgG7ms (it includes enabling Ice support since the conf enables it by default) (also includes updating to SHA512 since they're such small files and MD5 has proven collisions: https://crypto.stackexchange.com/a/1436)

ararhoo commented on 2017-05-26 17:10 (UTC) (edited on 2017-05-26 17:39 (UTC) by ararhoo)

Hi there, I'm now getting the following error due to the fact that the corrosponding package got an update: /usr/bin/murmurd: error while loading shared libraries: libprotobuf.so.12: cannot open shared object file: No such file or directory I'll try to recompile from existing source. Update: After rebuilding it throws errors due to more actual libssl and libcrypto / duplicates. I think this package shouldn't build old libs.. but how to "fix" it? Thanks in advance! :) Update(2): Linking new versions to needed ones obviously throws new errors: /usr/bin/murmurd: /usr/lib/libcrypto.so.1.1: version `OPENSSL_1.0.0' not found (required by /usr/lib/libQt5Network.so.5) Meh..

Lazy commented on 2017-02-13 14:19 (UTC)

I can't compile it stops at server.cpp on class QSslConfiguration has no member named 'setDiffieHellmanParameters Am I missing a Qt5 library?

disastro commented on 2016-12-05 10:12 (UTC)

Build works again without changes to CONFIG, has for some time now.