Package Details: murmur-git 1.2.5.980.ga59e166-1

Git Clone URL: https://aur.archlinux.org/murmur-git.git (read-only)
Package Base: murmur-git
Description: The voice chat application server for Mumble (git version)
Upstream URL: http://mumble.sourceforge.net
Licenses: BSD
Conflicts: murmur, murmur-ice, murmur-static
Provides: murmur
Submitter: OttoA
Maintainer: disastro
Last Packager: disastro
Votes: 4
Popularity: 0.002398
First Submitted: 2009-12-15 16:30
Last Updated: 2016-03-28 01:31

Required by (0)

Sources (3)

Pinned Comments

disastro commented on 2016-11-10 08:06

Latest ZeroC Ice 3.6.3 finally supports PHP 7 at least on 64-bit.
https://aur.archlinux.org/packages/zeroc-ice-php56 should work with the changes I described in the comments.

Latest Comments

disastro commented on 2016-12-05 10:12

Build works again without changes to CONFIG, has for some time now.

disastro commented on 2016-11-10 08:06

Latest ZeroC Ice 3.6.3 finally supports PHP 7 at least on 64-bit.
https://aur.archlinux.org/packages/zeroc-ice-php56 should work with the changes I described in the comments.

disastro commented on 2016-11-06 22:02

Qt 5.7 incompatibility should be fixed upstream sooner rather than later so I decided to skip fixing it a few days ago already. https://github.com/mumble-voip/mumble/pull/2630 For the time being adding c++11 or c++14 to CONFIG in the PKGBUILD should indeed fix the issue.

nullnan commented on 2016-11-06 21:42

Review with armv7h (Odroid U3):
Compiled zeroc-ice without any additions (besides adding armv7h).
Compiled murmur-git with adding c++11 to the CONFIG+="..." params

Maybe add it in the package per default?

disastro commented on 2016-04-17 08:14

Ice took a while to get working for me again but if anyone uses it, I had to compile zeroc-ice with "-std=c++11 -fPIC -pthread" for Murmur to not fail compiling.

disastro commented on 2016-02-13 05:55

@YAOMTC It's basically their 1.3.0 yeah but I think they haven't got git tags for 1.3.0 even to this date so in a way it gets mislabeled

@FryDay Probably yeah, I haven't really done arm arches for my packages even though I've got an RPi2 just because, but I might as well

FryDay commented on 2016-02-13 03:45

Please add armv7h to the PKGBUILD. I can confirm it builds fine.

YAOMTC commented on 2016-01-18 06:23

So this installs "1.2.5.939" - is this actually 1.3, mislabeled?

disastro commented on 2016-01-07 20:47

Updated to qt5, and yes ice is fully working.

meZee commented on 2015-12-10 12:10

The Ice package is currently fixed and compiling. Current mumble version is 1.3.0, and Qt5 is now the qt dependency.

All comments