Package Details: murmur-static 1.3.4-1

Git Clone URL: https://aur.archlinux.org/murmur-static.git (read-only, click to copy)
Package Base: murmur-static
Description: The voice chat application server for Mumble (static version)
Upstream URL: https://www.mumble.info/
Licenses: GPL
Conflicts: murmur, murmur-git, murmur-ice
Provides: murmur
Submitter: OttoA
Maintainer: buzo
Last Packager: buzo
Votes: 6
Popularity: 0.000000
First Submitted: 2009-12-14 17:56 (UTC)
Last Updated: 2021-02-10 12:33 (UTC)

Pinned Comments

buzo commented on 2022-02-15 19:31 (UTC)

There won't be any static builds any more, see here for details. So I'm removing the out-of-date flag for now.

buzo commented on 2021-02-10 12:37 (UTC)

GnuPG signature is active in this build. If you get an unknown public key error, you need to import the missing key:

curl -L https://github.com/mumble-voip/mumble-gpg-signatures/raw/master/mumble-auto-build-2021.asc | gpg --import

See here for details.

Latest Comments

buzo commented on 2022-02-15 19:31 (UTC)

There won't be any static builds any more, see here for details. So I'm removing the out-of-date flag for now.

buzo commented on 2022-01-18 17:47 (UTC)

Unfortunately the new version 1.4.230 is not released with a static build any more. (Or not yet?)

buzo commented on 2021-02-10 12:37 (UTC)

GnuPG signature is active in this build. If you get an unknown public key error, you need to import the missing key:

curl -L https://github.com/mumble-voip/mumble-gpg-signatures/raw/master/mumble-auto-build-2021.asc | gpg --import

See here for details.

buzo commented on 2021-01-04 11:26 (UTC)

Thanks, CromFr – fixed. (Gpg warns about an expired key though.)

CromFr commented on 2021-01-03 19:48 (UTC) (edited on 2021-01-03 19:48 (UTC) by CromFr)

Download URL needs to be changed from

https://mumble.info/snapshot/stable/murmur-static_x86-${pkgver}.tar.bz2{,.sig}

to:

https://dl.mumble.info/stable/murmur-static_x86-${pkgver}.tar.bz2{,.sig}

buzo commented on 2020-07-16 08:53 (UTC)

shadowbob: This is strange. Upstream has changed the tar file, although the content remains the same. (I unpacked both and compared them.) So I have just updated the checksum without bumping pkgrel.

shadowbob commented on 2020-07-15 05:42 (UTC)

I cannot upgrade to 1.3.2, getting this error:

==> Validating source files with sha512sums...
    murmur-static_x86-1.3.2.tar.bz2 ... FAILED
    murmur-static_x86-1.3.2.tar.bz2.sig ... Skipped
    murmur.service ... Passed
    murmur.sysusers ... Passed
    murmurd.1 ... Passed
==> ERROR: One or more files did not pass the validity check!

tuxayo commented on 2020-04-02 02:51 (UTC) (edited on 2020-04-02 02:52 (UTC) by tuxayo)

Has anyone else had issues to import the key?

root@server ~ # gpg --recv-keys 56D0B23AE00B1EE9A8BAAC0F5B8CF87BB893449B
gpg: key 5B8CF87BB893449B: 1 signature not checked due to a missing key
gpg: key 5B8CF87BB893449B: "Mumble Automatic Build Infrastructure 2019 <mumble-auto-build-2019@mumble.info>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

buzo commented on 2019-09-13 10:05 (UTC) (edited on 2020-06-09 07:33 (UTC) by buzo)

GnuPG signature checking has been added. If you get an unknown public key error, you need to import the missing key:

gpg --recv-keys 76B50270322F0E3D78DCE8298AA328A315175AE3

buzo commented on 2019-06-11 16:26 (UTC)

When upgrading from murmur-static <= 1.3.0rc1-2, you need to manually move /var/lib/murmur to /var/db/murmur. I have changed the directory to be compatible with the community package. The config file /etc/murmur.ini needs to be adapted accordingly, too, of course.

Please also note that the comment marker has changed upstream in version 1.3 and have a look at /etc/murmur.ini.pacnew.

Serra commented on 2016-12-11 16:52 (UTC)

@mitchhentges Murmur uses some parts of the qt4 GUI toolkit. Since arch does not provide the gui-less parts of qt4 as a separate package a normal murmur installation pulls in the X stack. The -static part means that this package does not use the arch packages for its dependencies (including qt4). Instead it provides its own version of these libraries. This way we can avoid pulling in things we don't want. You may want to look more into the differences between static and dynamic linking. E.g: http://cs-fundamentals.com/tech-interview/c/difference-between-static-and-dynamic-linking.php

mitchhentges commented on 2016-12-10 20:06 (UTC)

What is the difference between this distribution of Murmur vs the actual Murmur package? What does it mean to be the static version? I'm looking for murmur that doesn't transitively depend on X, and this package seems to fit that requirement. Is that all that "static" means here, or is there anything I'm missing?

OttoA commented on 2015-02-17 10:54 (UTC)

sorry no time to fix atm package ready for adoption

Serra commented on 2015-02-17 10:23 (UTC)

I have the same problem as kawasakai on a clean install

kawasakai commented on 2015-02-08 17:56 (UTC)

getting this error during install: error: failed to commit transaction (conflicting files) murmur-static: /var/run exists in filesystem Errors occurred, no packages were upgraded.

OttoA commented on 2014-08-27 08:34 (UTC)

bump to 1.2.8

OttoA commented on 2014-04-17 13:13 (UTC)

finally got around to it - let me know if anything is broken!

djmattyg007 commented on 2014-04-14 14:01 (UTC)

I'm pretty sure this needs to be updated for v1.2.5 of the server software.

OttoA commented on 2013-12-15 21:06 (UTC)

fixed

guihongwen commented on 2013-11-23 07:00 (UTC)

hi, how to bulid murmur server in static thanks!

Yushyin commented on 2013-10-31 21:00 (UTC)

Just build it and the size of the package was only 36kbyte. Don’t know the problem but options=(!strip) is a working workaround.

American_Jesus commented on 2012-12-13 22:30 (UTC)

wont build ==> Building and installing package ==> ERROR: install file ((murmur.install)) does not exist. ==> ERROR: Makepkg was unable to build murmur-static.

panthar commented on 2012-09-18 15:46 (UTC)

Removed out of date flag. If the flagger had a reason, please add a comment with the flag so the maintainer knows what may need to be updated.

OttoA commented on 2012-09-12 14:39 (UTC)

Flagged out of date - did I miss anything? The official page says 1.2.3 is the current stable version