Package Details: mwlib 0.15.14-2

Git Clone URL: https://aur.archlinux.org/mwlib.git (read-only)
Package Base: mwlib
Description: Converts MediaWiki articles to pdf, odf, and docbook
Upstream URL: http://code.pediapress.com/wiki/wiki
Licenses: BSD
Submitter: None
Maintainer: pingveno
Last Packager: pingveno
Votes: 4
Popularity: 0.000000
First Submitted: 2008-09-22 20:59
Last Updated: 2015-07-08 18:08

Latest Comments

pingveno commented on 2014-07-24 07:52

There was an issue with pyparsing's Python 2 support in pyparsing 2.0, so mwlib is marked as needing pyparsing<1.6. The bug appears to be fixed in the current release of pyparsing, so I added in a sed line to remove the <1.6 requirement.

kopiersperre commented on 2014-07-21 01:13

I can't run mwlib:

Traceback (most recent call last):
File "/usr/bin/mw-render", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2876, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 451, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 464, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 639, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pyparsing>=1.4.11,<1.6

vnoel commented on 2010-11-08 20:46

Hi, I updated python-webob and made it available as a python2 package:
http://aur.archlinux.org/packages.php?ID=43257

andre commented on 2010-08-14 10:38

for mwlib 0.12.13-1 use this PKGBUILD ( http://aur.pastebin.com/Hs4yXUGy ) and the provided requires.txt

andre commented on 2010-08-14 10:31

please add x86_64
builds fine here!