Package Details: mycli 1.19.0-2

Git Clone URL: https://aur.archlinux.org/mycli.git (read-only)
Package Base: mycli
Description: A Terminal Client for MySQL with AutoCompletion and Syntax Highlighting
Upstream URL: https://github.com/dbcli/mycli
Keywords: cli mariadb mysql
Licenses: BSD
Submitter: aabmass
Maintainer: loonies
Last Packager: loonies
Votes: 21
Popularity: 0.480515
First Submitted: 2015-08-05 15:33
Last Updated: 2018-12-17 21:54

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

aabmass commented on 2016-01-23 20:38

Sorry for the slow update. Updated to 1.5.2. The dev for mycli has prompt_toolkit up to the version in the AUR, so no issues anymore!

Anonymous comment on 2015-12-18 15:51

I did, this way:
1. download snapshot python-prompt_toolkit 0.54-1
2. edit PKGBUILD - set version to 0.46
4. then run makepkg --skipinteg
5. install generated package with pacman -U
5. install mycli

aabmass commented on 2015-12-08 01:11

Not really sure how to handle this, prompt_toolkit 0.54 completely breaks this package. Any ideas?

aabmass commented on 2015-12-08 00:18

@lenin, unfortunately, the mycli devs say that prompt-toolkit has to stay at 0.46 (https://github.com/dbcli/mycli/issues/204). Let me see what I can do, though

lenin commented on 2015-12-02 06:21

After installing, simply run mycli will complain this error:

Traceback (most recent call last):
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 658, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 959, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 851, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (prompt-toolkit 0.54 (/usr/lib/python3.5/site-packages), Requirement.parse('prompt-toolkit==0.46'), {'mycli'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/mycli", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3143, in <module>
@_call_aside
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3129, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3156, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 660, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 673, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 846, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'prompt-toolkit==0.46' distribution was not found and is required by mycli

aabmass commented on 2015-08-24 16:51

I filed requests to delete python*-mycli packages. Sorry for the confusion to the moderators! This package should NOT be deleted anymore.

aabmass commented on 2015-08-24 16:06

@carlgeorge yes, I actually submitted this issue on github (https://github.com/dbcli/mycli/issues/134) and the dev changed the sqlparse requirement in response.

It looks like arch's sqlparse is up to 0.1.16 and a new mycli release hit pypi today (1.4.0). I'll upgrade this package.

I also asked the dev about the prompt_toolkit==0.46 frozen dependency and he said that one can't be changed. Check out what he said, maybe you have a solution that works for everyone: https://github.com/dbcli/mycli/issues/134. The aur/python-prompt_toolkit version is currently at 0.46-1 but it's flagged out of date, so this will probably break soon.

Thank you for the advice!

Anonymous comment on 2015-08-20 00:44

I don't use this package personally, but another user mistakenly reported an error on my python-click package. mycli 1.3.0 requires sqlparse 0.1.14 _exactly_.

https://github.com/dbcli/mycli/blob/v1.3.0/setup.py#L30

The arch package python-sqlparse in community is currently at 0.1.15, so this is broken. This has already been fixed in the mycli codebase, but it was fixed after the v1.3.0 tag. Additionally, it was fixed by requiring 0.1.16 or greater, which hasn't been released on Arch yet.

https://github.com/dbcli/mycli/commit/ff5649792babaaa90cd72f76132bbd0fb16ae387

Long term fix:
* python-sqlparse is updated to 0.1.16.
* mycli releases a new version that contains the above commit, and you update your package to that version.

Short term fix:
* Create a patch that modifies the requirements in setup.py to 'sqlparse >= 0.1.15'.
* Remove the patch once mycli releases a new version.

Hope this helps, if you have further questions or need help creating the patch, just ask!

Anonymous comment on 2015-08-20 00:28

@aabmass You were on the right track with those python packaging guidelines. You need to keep the "mycli" package and remove the python- and python2- variants. @gsingh93 is totally off base with that error, and I would bet money that a python2-mycli package will not fix his issue.

@gsingh93 The error you saw has nothing to do with setting python2 as the default (which is an incredibly bad thing to do to your system). The packages python-configobj and python2-configobj are from the same PKGBUILD, so both packages have the same version number. To that point, those packages were updated to 5.0.6 last year.

https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/python-configobj&id=c8aa3ffe341e74d13c25ce29c142aaef5d05a738

This lead me to believe one of to things has happened.

1) You haven't updated python2-configobj since before 5.0.6 was released.
2) You installed configobj with pip instead of using pacman.

Since you are willing to change /usr/bin/python to python2, I'm guessing you probably went with the pip option. Feel free to break your own system however you want to, but don't use it as justification to have other package maintainers go against Arch packaging standards.

aabmass commented on 2015-08-17 15:32

Alright, I renamed this package to python-mycli and am waiting for a mod to delete this package.

I also made a python2-mycli package.