Package Details: mycli 1.22.1-1

Git Clone URL: (read-only, click to copy)
Package Base: mycli
Description: A Terminal Client for MySQL with AutoCompletion and Syntax Highlighting
Upstream URL:
Keywords: cli mariadb mysql
Licenses: BSD
Submitter: aabmass
Maintainer: loonies
Last Packager: loonies
Votes: 26
Popularity: 0.052038
First Submitted: 2015-08-05 15:33
Last Updated: 2020-08-01 15:37

Pinned Comments

loonies commented on 2019-12-06 11:43

Prior to flagging the package out-of-date or reporting build errors please:

  • Make sure that your system is up-to-date (pacman -Syu)
  • Rebuild and reinstall dependencies (especially ones from AUR)
  • Rebuild and reinstall the package

Do not expect AUR packages to trigger rebuild or suggest bumping "pkgrel" number. This is expected behaviour and the way Arch packing is designed to work.

For more information read the official documentation and man pages.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

aabmass commented on 2016-02-01 16:19

@loonies thanks, I added it in

loonies commented on 2016-01-25 13:36

python-crypto dependency is missing

aabmass commented on 2016-01-23 20:38

Sorry for the slow update. Updated to 1.5.2. The dev for mycli has prompt_toolkit up to the version in the AUR, so no issues anymore!

Anonymous comment on 2015-12-18 15:51

I did, this way:
1. download snapshot python-prompt_toolkit 0.54-1
2. edit PKGBUILD - set version to 0.46
4. then run makepkg --skipinteg
5. install generated package with pacman -U
5. install mycli

aabmass commented on 2015-12-08 01:11

Not really sure how to handle this, prompt_toolkit 0.54 completely breaks this package. Any ideas?

aabmass commented on 2015-12-08 00:18

@lenin, unfortunately, the mycli devs say that prompt-toolkit has to stay at 0.46 ( Let me see what I can do, though

lenin commented on 2015-12-02 06:21

After installing, simply run mycli will complain this error:

Traceback (most recent call last):
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 658, in _build_master
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 959, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 851, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (prompt-toolkit 0.54 (/usr/lib/python3.5/site-packages), Requirement.parse('prompt-toolkit==0.46'), {'mycli'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/mycli", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 3143, in <module>
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 3129, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 3156, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 660, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 673, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.5/site-packages/pkg_resources/", line 846, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'prompt-toolkit==0.46' distribution was not found and is required by mycli

aabmass commented on 2015-08-24 16:51

I filed requests to delete python*-mycli packages. Sorry for the confusion to the moderators! This package should NOT be deleted anymore.

aabmass commented on 2015-08-24 16:06

@carlgeorge yes, I actually submitted this issue on github ( and the dev changed the sqlparse requirement in response.

It looks like arch's sqlparse is up to 0.1.16 and a new mycli release hit pypi today (1.4.0). I'll upgrade this package.

I also asked the dev about the prompt_toolkit==0.46 frozen dependency and he said that one can't be changed. Check out what he said, maybe you have a solution that works for everyone: The aur/python-prompt_toolkit version is currently at 0.46-1 but it's flagged out of date, so this will probably break soon.

Thank you for the advice!

Anonymous comment on 2015-08-20 00:44

I don't use this package personally, but another user mistakenly reported an error on my python-click package. mycli 1.3.0 requires sqlparse 0.1.14 _exactly_.

The arch package python-sqlparse in community is currently at 0.1.15, so this is broken. This has already been fixed in the mycli codebase, but it was fixed after the v1.3.0 tag. Additionally, it was fixed by requiring 0.1.16 or greater, which hasn't been released on Arch yet.

Long term fix:
* python-sqlparse is updated to 0.1.16.
* mycli releases a new version that contains the above commit, and you update your package to that version.

Short term fix:
* Create a patch that modifies the requirements in to 'sqlparse >= 0.1.15'.
* Remove the patch once mycli releases a new version.

Hope this helps, if you have further questions or need help creating the patch, just ask!