Package Details: mypaint-git 1.2.0.r237.gf2e1648-1

Git Clone URL: (read-only)
Package Base: mypaint-git
Description: A fast and easy painting application for digital painters, with brush dynamics
Upstream URL:
Licenses: GPL
Conflicts: mypaint
Provides: mypaint
Submitter: jonnor
Maintainer: ShadowKyogre
Last Packager: ShadowKyogre
Votes: 20
Popularity: 0.018727
First Submitted: 2009-06-08 17:08
Last Updated: 2016-05-20 03:11

Latest Comments

ShadowKyogre commented on 2016-06-05 19:58

@electricprism: Did you install libmypaint-git? It looks like you don't have the latest copy of the PKGBUILD.

electricprism commented on 2016-06-05 03:47

In file included from lib/mypaintlib.hpp:13:0,
from lib/
lib/mapping.hpp:21:29: fatal error: mypaint-mapping.h: No such file or directory
#include <mypaint-mapping.h>
compilation terminated.
scons: *** [lib/mypaintlib_wrap.os] Error 1
scons: building terminated because of errors.
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build mypaint-git.
==> Restart building mypaint-git ? [y/N]

ShadowKyogre commented on 2016-05-20 03:13

mypaint-git can now live happily alongside libmypaint-git. Rejoice!

aaronp commented on 2016-05-20 02:10

Fantastic, thanks for your efforts ShadowKyogre!

ShadowKyogre commented on 2016-05-20 00:42

Notification from upstream about issue being reconsidered. I'll modify this PKGBUILD to build against libmypaint-git as soon as I can. It'll just take some time.

ShadowKyogre commented on 2016-05-19 23:31 - *sigh* Doesn't look like this is going to get fixed until an actual 1.3 release. I'll go talk to the libmypaint maintainer about this.

ShadowKyogre commented on 2016-05-19 17:47

Hm, this is more complicated than I thought. I'll talk to upstream about it.

ShadowKyogre commented on 2016-05-19 17:39

@aaronp: Making a fix for this, give it a moment to build.

ShadowKyogre commented on 2016-05-19 14:53

@aaronp: It's due to mypaint not updating their submodule to point to the right commit.

In master, it says: brushlib @ 65ffae1

That's libmypaint at that commit.


That's the master version of libmypaint.

It's an upstream issue, but there should be a workaround for this (though IDK how to force a submodule to be updated to the most recent commit from upstream).

aaronp commented on 2016-05-19 14:24

It looks like gimp-git is requiring libmypaint >= 1.3.0, but the libmypaint provided by this package is only reporting 1.1 by pkg-config. Do you know the cause of this disparity?

All comments