Package Details: mysql-jdbc 5.1.38-1

Git Clone URL: https://aur.archlinux.org/mysql-jdbc.git (read-only)
Package Base: mysql-jdbc
Description: The official JDBC driver for MySQL
Upstream URL: https://dev.mysql.com/downloads/connector/j/
Licenses: GPL2
Submitter: None
Maintainer: Marcel_K
Last Packager: Marcel_K
Votes: 110
Popularity: 0.030617
First Submitted: 2006-12-18 21:19
Last Updated: 2015-12-14 15:41

Latest Comments

leifurhauks commented on 2016-01-20 17:55

EDIT: nvm, I figured out that the key needed to be in my *personal* keyring, not my pacman keyring

Does anyone have an idea what my problem is here? (I know I can use --skippgpcheck, but I would like to know why it's failing in the first place)

leifurpc% makepkg -s
==> Making package: mysql-jdbc 5.1.38-1 (Wed Jan 20 12:47:32 EST 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found mysql-connector-java-5.1.38.tar.gz
-> Found mysql-connector-java-5.1.38.tar.gz.asc
==> Validating source files with md5sums...
mysql-connector-java-5.1.38.tar.gz ... Passed
mysql-connector-java-5.1.38.tar.gz.asc ... Skipped
==> Verifying source file signatures with gpg...
mysql-connector-java-5.1.38.tar.gz ... FAILED (unknown public key 8C718D3B5072E1F5)
==> ERROR: One or more PGP signatures could not be verified!

leifurpc% pacman-key -l 8C718D3B5072E1F5
gpg: Note: trustdb not writable
pub dsa1024/5072E1F5 2003-02-03 [expires: 2017-02-16]
uid [ full ] MySQL Release Engineering <mysql-build@oss.oracle.com>

Marcel_K commented on 2015-08-26 10:55

What's above that message? Did you import the public key of MySQL Release Engineering (0x5072E1F5)?

manuelschneid3r commented on 2015-08-26 10:24

==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden!

Means there is a PGP sig error

manuelschneid3r commented on 2015-08-26 10:24

==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden!

cgirard commented on 2015-08-10 11:23

This is a duplicate of mysql-jdbc

barchiesi commented on 2015-03-29 21:01

@Ulvhedin:
thanks, if you prefer next time you can directly "Flag package out-of-date".

Ulvhedin commented on 2015-03-29 19:52

Please update - new version available:
mysql-connector-java-5.1.35
MD5: e59c9438a9c6c07e27252ad3156123ca

whatshisname commented on 2014-11-11 17:21

@joschi. Thanks. Installed and working! Small change to your instructions at the end of the script. Step 2) should read:

'2) Click on Tools -> Options then expand the LIbreoffice tree and select "Advanced".'

joschi commented on 2014-11-11 17:00

@whatshisname I've updated the PKGBUILD.

FWIW, "iD8DBQBUQOnZjHGNO1By4fURAv/7AJ9SMu518sd6rVWeTTVs+EOJYUKTEQCfcjJT" is not a valid SHA256 hash.

whatshisname commented on 2014-11-10 23:31

The newest version of this package is up to 5.1.34. I edited the PKGBUILD to reflect this. I also tried to insert the various checksums from http://ftp.gwdg.de/pub/misc/mysql/Downloads/Connector-J/ for that version but all variations fail the sha256sum check.

My last attempt was to substitute the top line from "mysql-connector-java-5.1.34.tar.gz.asc" ->
"iD8DBQBUQOnZjHGNO1By4fURAv/7AJ9SMu518sd6rVWeTTVs+EOJYUKTEQCfcjJT" which equaled the length, at least, of the checksum for 5.1.32 but it still failed. Suggestions?

All comments