Package Details: n1-git 0.4.32.r987.gf35008d-1

Git Clone URL: https://aur.archlinux.org/n1-git.git (read-only)
Package Base: n1-git
Description: Nylas N1 - An extensible desktop mail app built on the modern web
Upstream URL: https://github.com/nylas/N1
Licenses: GPL3
Conflicts: n1
Provides: n1
Submitter: Shibumi
Maintainer: mbilker
Last Packager: mbilker
Votes: 7
Popularity: 0.001872
First Submitted: 2015-10-28 00:12
Last Updated: 2017-01-18 07:41

Latest Comments

ArchangeGabriel commented on 2017-03-18 21:04

Yeah, K2 for N1 or the other one for Nylas Mail. All of this will happen at the same time they release Linux and Windows binaries. Which is in an undetermined amount of time, that I, for one, bet to be something like late April…

alberto2000 commented on 2017-03-18 15:12

Any update on this? Can this be built anytime soon? I guess it depends on when they open-source K2, right?

ArchangeGabriel commented on 2017-03-05 01:27

@geosam: This is a PKGBUILD for nylas-mail, not n1. You might want to change nodejs6 to nodejs-lts-boron, but anyway this PKGBUILD can’t work because of K2 being a private repository.

geosam commented on 2017-02-24 23:14

Here the new version with corrections:

https://gist.github.com/samtux/7a7111eb2220e86171a33ec9c9e878ea

ArchangeGabriel commented on 2017-02-22 13:02

@hardyh: Nylas N1 is almost discontinued, replaced by Nylas Mail. The source URL here redirects to nylas-mail. The N1 code is still available in n1-pro branch of this repo. However, this won’t help because at the moment, both Nylas Mail and N1 need a private submodule, so they can’t be build.

hardyh commented on 2017-02-21 22:49

This package is not installable:
==> Building and installing package
==> Making package: n1-git 0.4.32.r987.gf35008d-1 (Tue Feb 21 23:45:01 CET 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning N1 git repo...
Cloning into bare repository '/tmp/yaourt-tmp-hardy/aur-n1-git/N1'...
remote: Counting objects: 63565, done.
remote: Compressing objects: 100% (84/84), done.
remote: Total 63565 (delta 38), reused 0 (delta 0), pack-reused 63480
Receiving objects: 100% (63565/63565), 222.76 MiB | 1.28 MiB/s, done.
Resolving deltas: 100% (40466/40466), done.
==> Validating source files with sha512sums...
N1 ... Skipped
==> Extracting sources...
-> Creating working copy of N1 git repo...
Cloning into 'N1'...
done.
==> Starting pkgver()...
==> Updated version: n1-git 1.0.28.r8.g7890b922-1
==> Starting build()...
sed: can't read build/resources/linux/nylas.desktop.in: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build n1-git.
==> Restart building n1-git ? [y/N]

step commented on 2017-02-12 15:28

I have problem to install it:

npm WARN n1-bundled-apm@ No license field.
npm ERR! Linux 4.9.8-1-ARCH
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v7.5.0
npm ERR! npm v4.2.0
npm ERR! code ELIFECYCLE
npm ERR! errno 1

npm ERR! atom-package-manager@1.1.1 install: `node ./script/download-node.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the atom-package-manager@1.1.1 install script 'node ./script/download-node.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the atom-package-manager package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./script/download-node.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs atom-package-manager
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls atom-package-manager
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /home/andrea/.npm/_logs/2017-02-12T15_33_59_054Z-debug.log

$ cat /home/andrea/.npm/_logs/2017-02-12T15_33_59_054Z-debug.log

28819 verbose cwd /tmp/yaourt-tmp-andrea/aur-n1-git/src/N1/apm
28820 error Linux 4.9.8-1-ARCH
28821 error argv "/usr/bin/node" "/usr/bin/npm" "install"
28822 error node v7.5.0
28823 error npm v4.2.0
28824 error code ELIFECYCLE
28825 error errno 1
28826 error atom-package-manager@1.1.1 install: `node ./script/download-node.js`
28826 error Exit status 1
28827 error Failed at the atom-package-manager@1.1.1 install script 'node ./script/download-node.js'.
28827 error Make sure you have the latest version of node.js and npm installed.
28827 error If you do, this is most likely a problem with the atom-package-manager package,
28827 error not with npm itself.
28827 error Tell the author that this fails on your system:
28827 error node ./script/download-node.js
28827 error You can get information on how to open an issue for this project with:
28827 error npm bugs atom-package-manager
28827 error Or if that isn't available, you can get their info via:
28827 error npm owner ls atom-package-manager
28827 error There is likely additional logging output above.
28828 verbose exit [ 1, true ]

mbilker commented on 2017-01-18 07:41

@wget, fixed now

wget commented on 2017-01-13 19:20

Please change the description to "Nylas N1 - An extensible desktop mail app built on the modern web". PKGBUILD descriptions are designed to help the package to be found, your current one isn't. Thanks :)

XG_SiNGH commented on 2016-12-06 22:20

It seems the build process has changed upstream in release 0.4.400
[https://github.com/nylas/N1/releases/tag/0.4.400]

Changelog Quote (from link above):
- We now use electron-packager to build N1
- "script/bootstrap" has been replaced with a much simpler install flow built on electron-compile
- Removed devDependencies from main package.json reducing file size
- We no longer support Node 4 for building


Not quite sure how we have to change things on our end in the PKGBUILD... O_O

All comments