Package Details: nbfc-git 1.6.3.r40.gfc9fb97-3

Git Clone URL: https://aur.archlinux.org/nbfc-git.git (read-only, click to copy)
Package Base: nbfc-git
Description: Cross-platform fan control service for notebooks (Development version)
Upstream URL: https://github.com/hirschmann/nbfc
Licenses: GPL3
Conflicts: nbfc
Provides: nbfc
Submitter: erkexzcx
Maintainer: BachoSeven
Last Packager: BachoSeven
Votes: 4
Popularity: 0.021542
First Submitted: 2017-09-17 00:45 (UTC)
Last Updated: 2021-05-10 12:03 (UTC)

Latest Comments

dmshimself commented on 2019-10-16 20:48 (UTC)

Yes I tried with and without and get the same result. From my fading memory, object reference errors are when the app tries to dereference a null. I suspect that doesn't help vry much. Unfortunely I don't have another laptop to try this on. I'm running the latest arch system after an update.

bbaserdem commented on 2019-10-16 19:12 (UTC)

Aro you using sudo? Got the same error without having privilege

dmshimself commented on 2019-10-16 18:32 (UTC) (edited on 2019-10-16 18:33 (UTC) by dmshimself)

I have a LENOVO 80LF [Lenovo B41-30] (laptop) and with both the git and non-git versions I get an error:

Object reference not set to an instance of an object

I've enabled and started the service. Status gives back: Service enabled : False Read-only : False Selected config name : Temperature : 0

Could not get fan info because the service is disabled

Any thoughts?

bbaserdem commented on 2019-10-13 23:00 (UTC)

It builds without errors, thanks

erkexzcx commented on 2019-10-13 18:48 (UTC)

Should be OK now?

bbaserdem commented on 2019-10-10 20:14 (UTC) (edited on 2019-10-11 14:12 (UTC) by bbaserdem)

Thank you. The git issue is solved; but there is no package that provides ncurses<=6.0-4 so I can't build from this PKGBUILD. Also tested building in clean chroot without the ncurses makedepend, which built fine without errors.

erkexzcx commented on 2019-10-10 20:00 (UTC)

Hi. Added 'git' to make dependencies. Let me know if any more issues. Thanks!

bbaserdem commented on 2019-10-09 18:06 (UTC) (edited on 2019-10-09 18:07 (UTC) by bbaserdem)

The package is missing git in makedepends, and hence is failing to build in a clean chroot.

erkexzcx commented on 2019-05-06 05:21 (UTC)

I've scheduled automated daily job on my server to automatically update this AUR package.

erkexzcx commented on 2018-06-16 22:00 (UTC)

All good - recently installed it on my fresh setup on Asus UX430UQ. :)

BjarnoBe commented on 2018-03-05 01:20 (UTC)

Possibly related: https://bugs.archlinux.org/task/57300

t00my commented on 2018-03-04 18:23 (UTC) (edited on 2018-03-04 18:50 (UTC) by t00my)

I had some problems with installation of the package on my updated Arch. What worked for me: export LANG=en_US.UTF-8 && export TERM=xterm && pacaur -y nbfc-git

erkexzcx commented on 2018-03-02 10:46 (UTC)

https://github.com/hirschmann/nbfc/issues/451 - regarding downgrade of "ncurses" package. https://github.com/hirschmann/nbfc/issues/453 - nbfc does not seem to work with linux version 4.15. 4.14 (lts version) works fine.

erkexzcx commented on 2018-02-27 20:59 (UTC) (edited on 2018-02-27 21:00 (UTC) by erkexzcx)

Due to latest 6.1 version of ncurses (I don't know how about lib32-ncurses, but I downgraded it as well) - nbfc and nbfc-git fails to install. See how to install and downgrade ncurses: https://github.com/hirschmann/nbfc/issues/451